Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Sporadischer Paketverlust zwischen Firewall und Modem

Mitglied: dq28121989

dq28121989 (Level 1) - Jetzt verbinden

30.05.2013 um 11:07 Uhr, 2858 Aufrufe, 5 Kommentare, 2 Danke

Hallo Community,

ich habe das Problem, dass meine Fortinet-Firewall gelegentlich 30% Paketverlust hat. Gelegentlich heisst, dass es meist klappt aber ab und zu ein paar Stunden das Surfen unmöglich wird, weil der Verbindungsaufbau dauernd abbricht.

Ich habe zum Test Pings von verschiedenen Clients abgesendet. Das Ergebnis war, dass intern alles läuft wie es soll und einzelne Pings, welche an google.de, heise.de oder facebook.com gehen einfach nicht zurückkommen. Die Latenzen sind stabil und die ttl varriiert auch nur zwischen einen Hop.
Ich habe mich auch direkt ans Modem gehängt und von dort aus getestet ob mir Pakete verloren gehen. Dort lief alles einwandfrei. Von der Fortinet über die CLI abgesendeten Pings gehen allerdings auch verloren. Das Kabel, welches ich zum testen direkt an dem Modem verwendet habe, ist das selbe welches in der Fortinet steckt.

Es handelt sich um eine Fortinet wifi 40C und ein Cisco EPC3212 Modem.

Der ISP ist Kabel Deutschland mit einer 100 Mbit/s Leitung. Es gab vorher die Probleme, dass Kabel Deutschland nicht die Bandbreite liefern konnte, die versprochen wurde. Dies ist mittlerweile gelöst. Meine Theorie ist, dass Kabel Deutschland QOS-Mechanismen verwendet und die Pakete deshalb verworfen werden. Bin aber kein QOS-Experte und weiß nichts über Kabel Deutschlands interne Architektur.

Hat vielleicht jemand eine Idee wo das Problem seinen Ursprung hat? Gibt es Kompaktibilitätsprobleme zwischen Fortinet und Cisco?

Gruß dq
Mitglied: aqui
30.05.2013, aktualisiert um 14:17 Uhr
Es könnte ein Autonegotiation Problem zwischen Modem Port und Firewall Port sein. Das kommt häufig mal vor zw. Fremdherstellern. Dadurch kommt es dann bei Traffic zu Kollisionen an diesem Port durch den Speed oder Duplex Mismatch, die genau das Fehlermuster zeigen wie bei dir.
Dadurch das du direkt einen Testrechner am Modem hast zum Pingen und das fehlerfrei rennt sieht es sehr nach diesem Problem aus.
Gleichzeitig zeigt es das es niemals QoS Probleme sein können, denn diese schliesst du damit ja faktisch aus.
Es ist aber klar und auch bekannt bei TV Kabelmodems bzw. Anschlüssen, das man sich die "letzte Meile" mit hunderten und mehr anderen Teilnehmer teilen muss. Du hast also rein nur einen physische 100 Mbit Connect Rate, was nachher als wirkliche Paket Forwarding Rate durch das Netz geht steht auf einem ganz anderen Blatt Papier und darüber wahrt der Kabelprovider auch striktes Stillschweigen.
Dieses Sharing bewirkt aber niemals das es bei extrem langsamen Pings im 1 Sekunden Rhythmus zu Paketverlusten kommt. Die hat man ja noch nicht einmal auf einer "Bauern DSL" Leitung mit 384 kBit/s.
Du kannst das Problem aber ganz einfach lösen indem du den Fortinet Port fest, statisch auf 100 Mbit, Fullduplex setzt und auch analog den Modemport auch fest auf 100Mbit, Fullduplex einstellst.
Damit sollte das Problem dann nicht mehr auftreten.
Bitte warten ..
Mitglied: dq28121989
30.05.2013 um 15:48 Uhr
Vielen Dank für die Antwort aqui. Daran habe ich noch nicht gedacht, sehr gute Idee.
Ich werde es testen und berichten.

Gruß dq
Bitte warten ..
Mitglied: MrNetman
30.05.2013 um 17:12 Uhr
Und das Modem ist kein reines Modem im herkömmlichen Sinne.
Es ist ein Router, der weitere Geräte mit Hilfe eines Switches ins Internet bringen kann.

Achte bei der Verbindung der Fortinet auch auf das Kabel (Crossover halb, crossover voll, gerades Patchkabel) und teste alle manuellen Konfigurationen auch auf die Geschwindigkeit hin. Duplex-Missmatch wird leider erst in den TCP-Schichten repariert. Der Geschwindigkeitseinbruch bei Vollast ist merklich, bei Teillast kaum zu erkennen.
Achtung:
FDX auf Auto = Missmatch
HDX auf Auto = ident aber nur 100Mbit/s halbduplex.
Gigabit Auto und Gigabit FDX vertragen sich gar nicht.

Gruß
Netman
Bitte warten ..
Mitglied: dq28121989
30.05.2013 um 17:17 Uhr
Vielen Dank für die Hinweise.
Bitte warten ..
Mitglied: dq28121989
01.06.2013 um 17:28 Uhr
Update: Es war wohl ein defektes Patch-Kabel ... Beide Seiten standen auf Auto und haben Fullduplex Gigabit-Lan ausgehandelt.

Gruß
dq
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen

Verständnisproblem Modem-Router-Firewall

Frage von nobo147Netzwerkgrundlagen9 Kommentare

Hallo. Ich glaube, ich habe nur ein kleines Verständisproblem. Mein Netzwerk: (mangels Visio nicht ganz state of the art ...

LAN, WAN, Wireless

Telekom VDSL - Welche Router Modem mit Firewall

Frage von deeko23LAN, WAN, Wireless8 Kommentare

Hallo ! Wie der Titel schon sagt möchte ich das Standard Modem/Router Gerät der Telekom ersetzen und gegen eins ...

Server

Wieviel Paketverlust im Internet ist normal

gelöst Frage von BoomBastiServer8 Kommentare

Hallo liebes Forum, wir haben eine Sicherheitsfirma, die über das Internet unsere Alarmanlage überwacht. Diese meldet nun seit einiger ...

Windows 10

Sporadisch BlueScreen

gelöst Frage von Finchen961988Windows 1011 Kommentare

Hallo liebe Leute, meine Verzweifelung ist mir gerade ins Gesicht geschrieben, ich habe das Problem das mein PC zwischendurch ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 8 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 14 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

Visual Studio
Singletone Objekt in Datei speichern
gelöst Frage von it4baerVisual Studio13 Kommentare

Hallo, ist es möglich ein Singleton-Objekt zu "serialisieren" und dann in eine Datei zu speichern um es später wieder ...