Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SQL-Server 2005 Problem mit ADO-.Net-Verbindung

Mitglied: kleinerbub

kleinerbub (Level 1) - Jetzt verbinden

12.12.2008, aktualisiert 12:43 Uhr, 8259 Aufrufe, 2 Kommentare

Ich habe ein Problem mit ner ADO.net-Verbindung. Dort wird das Passwort nicht gespeichert.

Folgendes Szenario: kleines SSIS-Paket mit einem Ziel (SQL-Server) und einer Quelle (Ingres-Datenbank im Netzwerk, per ODBC im System bekannt gemacht, VNODE angelegt mit PW, Verbindungstest funktioniert problemlos).
Die Daten sollen einfach von der Quelle geholt, aufs Ziel kopiert werden.
Das ganze klappt auch im BIDStudio. Wenn ich allerdings das Paket exportiere und im Server Manager als Auftrag ausführe, kommt ne Fehlermeldung (siehe Anhang)

Daraus nehme ich mir, dass er kein Passwort hat. Also hab ich im Auftrag bei der Quell-Connection den String bearbeitet und pwd=... hinzugefügt und siehe da es klappt.

Das Problem ist nur: Ich kann im BIDStudio auf und abspringen, er merkt sich dort einfach das Passwort nicht. Das Feld bleibt einfach leer. Is das n Bug oder mach ich irgendwas falsch?

SP2 hab ich übrigens schon installiert. (Vorher hat er nichmal ne Fehlerbeschreibung angezeigt)

Hoffe mir kann einer helfen.



Fehlerlog:

Datum,Quelle,Schweregrad,Schritt-ID,Server,Auftragsname,Schrittname,Benachrichtigungen,Meldung,Dauer,SQL-Schweregrad,SQL-Meldungs-ID,E-Mail an Operator,NET SEND an Operator,Pagernachricht an Operator,Versuchte Wiederholungen
12/12/2008 08:33:51,nt_wer,Fehler,1,WSD04,nt_wer,x1100pat,,Ausgeführt als Benutzer: 'WSD04\SYSTEM'.
...3042.00 für 32-Bit Copyright (C) Microsoft Corp 1984-2005. Alle Rechte vorbehalten. Gestartet:
08:33:51 Fehler: 2008-12-12 08:33:51.68 Code: 0xC0016016 Quelle: Beschreibung: Fehler beim
Entschlüsseln des geschützten XML-Knotens 'DTS:Password' (Fehlercode: 0x8009000B 'Schlüssel ist im
angegebenen Status nicht gültig.'). Möglicherweise verfügen Sie nicht über die Zugriffsrechte für diese
Informationen. Dieser Fehler tritt bei einem kryptografischen Fehler auf. Überprüfen Sie<c/> ob der
richtige Schlüssel verfügbar ist. Fehlerende Fehler: 2008-12-12 08:34:14.71 Code: 0xC0047062
Quelle: Datenflusstask DataReader-Quelle [1] Beschreibung: System.Data.Odbc.OdbcException: ERROR
[08004] [Ingres][Ingres 3.0 ODBC Driver][Ingres 3.0]User provided a vnode as part of the database name
(vnode::dbname)<c/> but login information for that vnode is missing. Enter login information for the vnode
using... Fehler beim Ausführen des Pa... Fehler bei Schritt.,00:00:23,0,0,,,,0
Mitglied: CT-pfado
12.12.2008 um 12:43 Uhr
Wie du aus der Fehlermeldung herauslesen kannst, ist es ein Berechtigungsproblem.

Bei SSIS musst du wenn du das Paket eingetragen hast, nochmals unter den Eigenschaften "Datenquellen" das Passwort für die Verbindungen in den Connection String eintragen. Dann kannst du das Paket auch erfolgreich starten.
Bitte warten ..
Mitglied: kleinerbub
19.01.2009 um 11:43 Uhr
Das wollte ich eben vermeiden, da es bei 100 Tabellen doch eher aufwändig ist. Ich habe mich nur gefragt, warum er das nicht übernimmt, obwohl ich das PW ja schon dem Paket mitgegeben habe.
Bitte warten ..
Ähnliche Inhalte
Windows Server
SQL Server 2005
gelöst Frage von Jan1986Windows Server4 Kommentare

Hallo zusammen, wir haben in unserem Unternehmen mittlerweile 2 Server auf denen wir verschiedene Server virtualisieren. 1 Server ist ...

Windows Server
SQL Server ODBC Verbindung
Frage von gookchannelWindows Server3 Kommentare

Hallo zusammen, ich habe eine SQL Server Datenbank unter einem anderen Namen wiederhergestellt. Ich würde nun gerne eine ODBC ...

Datenbanken

SQL 2008 Datenbankbackup in eine SQL 2005 Datenbank einfügen?

Frage von mymomoDatenbanken3 Kommentare

Moin! Ich muss bei einem Kunden ein aus SQL 2008 erstelltes Backup in eine SQL 2005 Datenbank einstellen. Wie ...

Windows Server

SQL 2005 zu 2008 SP2 Migration

gelöst Frage von pencilWindows Server6 Kommentare

Guten Tag Ich plane gerade eine Windows SQL Server Migration (2005 zu 2008). Ich habe vor, sämtliche DB's (3 ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 17 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 20 StundenAdministrator.de Feedback14 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Network
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Network15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Memory Cards
Vergessliche USB-Sticks?
Frage von hanheikMemory Cards14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...