Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Startskript läuft nicht innerhalb einer Batch

Mitglied: jimmyone

jimmyone (Level 1) - Jetzt verbinden

07.08.2008, aktualisiert 17:41 Uhr, 3458 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe gerade etwas Ärger mit einem Startskript.
Und zwar wird die über unsere Softwareverteilung (ADS) eine Software auf Rechner installiert. Um den Licensekey nicht manuell eingeben müssen habe ich ein .reg Script geschriben, welches unter Local_Machine in der Registry den entsprechenden Eintrag vornehmen soll...

Um aber nicht immer die Meldung zu haben, klicken Sie auf Ja zum hinzufügen habe ich eine Batch dazu gelegt, welche nach dem Muster: Regedit /s datei.reg fungiert.

Dummerweise klappt das aber nicht... Sprich das Batch wird nicht angewendet. Der Eintrag wird der Registry nicht hinzugefügt.
Lasse ich das Batch weg und setze nur den Eintrag für das .reg wird zwar vor der Benutzeranmeldung, die Meldung, ob ich die Infos zur Registry hinzufügen will eingeblendet, klicke ich aber da auf Ja dann sind die Infos in der Registry.

Warum geht denn das mit dem Batch nicht?

Danke für die Hilfe.

Viele Grüße
Jimmy
Mitglied: 60730
07.08.2008 um 16:37 Uhr
Servus,


Warum geht denn das mit dem Batch nicht?
komplizierte Frage, die sich durch ein weglassen des Parameters /s erklären würde.
Passt das Batch, kommt das Popup - passt es nicht - kommt ein weiteres, daß die .reg nicht gefunden wurde.

Wahrscheinlich passt es besser, wenn du regedit /s meinlaufwerk\mein Pfad\meinswimmingpool.reg schreibst...
Try it

Gruß
Bitte warten ..
Mitglied: jimmyone
07.08.2008 um 17:41 Uhr
Hi...

Joo bedankt.
Hattest recht mit dem UNC Pfad.

Und ich dachte, es wär egal, wenn das File im selben Ordner liegt.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Skript läuft merkwürdig.
Frage von pixel0815Batch & Shell15 Kommentare

Hallo zusammen, ich habe ein komisches Phänomen. Dieses unten stehende Skript läuft in einer Citrix Umgebung Dies dient dazu ...

Batch & Shell
Batch läuft nicht so rund
gelöst Frage von pixel0815Batch & Shell5 Kommentare

Hallo liebe Gemeinde, vielleicht weiß einer Rat warum der Befehl nicht ausgeführt wird? :O) Ausgabe Gruß Heiko

Batch & Shell
Homelaufwerke im Startskript zuweisen
Frage von SirTomBatch & Shell3 Kommentare

Hallo, ich möchte gerne die Homelaufwerke in einem Startskript (vbs, Windowsumgebung) zuweisen. Momentran sieht das so aus (nur Teile ...

Windows Server

Problem mit Startskript via Gruppenrichtlinie

gelöst Frage von ofodagWindows Server13 Kommentare

Hallo zusammen, also so langsam weiß ich nicht weiter. Folgende Umgebung, Windows Server 2012 R2 und Windows 7/10 Clients. ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 14 StundenHumor (lol)3 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 1 TagSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware16 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...

Windows Netzwerk
Backup über WAN
Frage von petereWindows Netzwerk11 Kommentare

Hallo, ich muss aus einem entfernten WAN (synchrone 1Gbit) Daten sichern. Dabei handelt es sich sowohl um wenige große ...