Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Stromausfall - boot failure - MBR, Board oder Raid-Controller defekt?

Mitglied: bitstash

bitstash (Level 1) - Jetzt verbinden

04.05.2009, aktualisiert 20:11 Uhr, 7127 Aufrufe, 7 Kommentare

Hallo zusammen,

wir hatten heute über mehrere Stunden einen Stromausfall, den die USV leider nicht mehr abdecken konnte. Ich hab es leider nicht rechtzeitig geschafft alle Systeme zu beenden, bevor die USV versagte.
Als dann irgendwann der Strom wieder kam, hörte ich auch schon die USV fiepen ... wunderlich. Hab dann wärend des Booten wie alle Server erneut ausfielen ... die Sicherung hat die zahlreichen Neustarts nicht mehr getragen und ist rausgesprungen! Als ich das Problem gelöst habe und unseren primären DC startetet, hing der Boot bei der Fehlermeldung "boot failure - press any key ...". Die Boot-Reihenfolge sieht wie folgt aus: 1. RAID 2. Netzwerkboot 3. Efi.
Er springt beim booten sofort zum PXE-E61 Error, sprich er übergeht das Booten vom Raid/HDD. Ich gehe stark davon aus das nicht der Stromausfall an sich das Problem war, sondern viel mehr der erneute Stromausfall (Sicherung) beim Booten des Server. Was kann da passiert sein? MBR kaputt? Hat es das Board hops genommen? Raid-Controller defekt (Kurzer etc.) ? Das Bios erkennt alle Komponenten, soweit ich das erkennen konnte, korrekt. Ich würd wohl zuerst versuchen über die Win2003 CD in der Console den MBR zu reparieren und bei Misslingen ggf. schauen ob ich die Partitionen mit Hilfe von Ubcd lesen kann. Ich hab nur etwas Angst etwas zu zerschießen (Raid5 mit ner Menge Daten) und wollt mich deshalb vorab hier informieren, was ich geschickter Weise tun sollte / beachten sollte. Danke für die Tipps!

Gruß
Mitglied: mrtux
04.05.2009 um 20:36 Uhr
Hi !

Zitat von bitstash:
Hallo zusammen,

wir hatten heute über mehrere Stunden einen Stromausfall, den
die USV leider nicht mehr abdecken konnte. Ich hab es leider nicht
rechtzeitig geschafft alle Systeme zu beenden, bevor die USV
versagte.

Ich frage mich als erstes, was ihr für eine USV habt, noch mit Kurbel hinten dran ?
Die ich bisher installiert habe, haben ein seriell oder Usb-Kabel mit dem man den Server und weitere PCs sauber herunterfahren kann und zwar bevor der USV der Saft ausgeht.

alle Server erneut ausfielen ... die Sicherung hat die zahlreichen
Neustarts nicht mehr getragen und ist rausgesprungen! Als ich das

Frage zwei, wer war euer "Elektriker" ? Hängen alle Server an einer Sicherung ?
Na bravo, absolut professionelle Elektroinstallation !

übergeht das Booten vom Raid/HDD. Ich gehe stark davon aus das
nicht der Stromausfall an sich das Problem war, sondern viel mehr der

Da kannst Du aber Gift drauf nehmen !

Frage drei, wer hat Eure IT-Anlage so versaubeutelt ? Das darf doch ned wahr sein. Hat die der Praktikant geplant ?

mit Hilfe von Ubcd lesen kann. Ich hab nur etwas Angst etwas zu
zerschießen (Raid5 mit ner Menge Daten) und wollt mich deshalb

Das hätte ich an Deiner Stelle auch und eine Datensicherung hast Du nicht oder ?

vorab hier informieren, was ich geschickter Weise tun sollte /
beachten sollte. Danke für die Tipps!

Das ist ein kluger Gedanke !

mrtux
Bitte warten ..
Mitglied: dog
05.05.2009 um 02:39 Uhr
Frage zwei, wer war euer "Elektriker" ? Hängen alle Server an einer Sicherung ?
Na bravo, absolut professionelle Elektroinstallation !

Das ist doch mehr oder minder normal :D
Irgendwann wachsen die IT-Systeme, man kauft sich eine größere USV, die eben auch mal 16A ziehen kann, ohne dass Kabel und Sicherungen angepasst werden. Im normalen Betrieb ist das ja kein Problem.
Direkt nach einen Stromausfall kommt es allerdings dann zu einer enormen Lastspitze, weil alle Server gleichzeitig starten und die USV auch noch ihre Akkus laden will - da sagt die Sicherung natürlich dann (berechtigterweise!) "Nein, Danke".
Darum kann man z.B. bei APC-USVs einstellen, dass die nach der Rückkehr des Stroms X Minuten warten sollen bis sie wieder Strom abgeben.

Aber an bitstash:

Bevor du mit irgendwelchen Reparaturversuchen beginnst starte den Server mit einer Acronis BartPE CD oder eine Ubuntu Live CD - Hauptsache der RAID-Controller wird unterstützt und mach ein RAW-Backup des RAIDs.
Unter Linux also z.B.
dd if=/dev/sda of=/mnt/usbdisk/backup.iso

Erst wenn du das hast und es dabei keinen Fehler gab darfst du auch etwas an den Daten auf der Platte ändern - alles andere ist grob fahrlässig, da in der Aufregung nach einem Crash immer die meisten Fehler passieren.
Übrigens kannst du auch das RAW-Backup 1:1 auf eine andere Festplatte machen und damit erst mal experimentieren, ob du das Problem gelöst bekommst.
Halte dir einfach eins im Hinterkopf: Je mehr du machst, umso unwahrscheinlicher wird es, dass ein Datenrettungslabor noch helfen kann.

Grüße

Max
Bitte warten ..
Mitglied: mrtux
05.05.2009 um 05:44 Uhr
Hi Dog !

Zitat von dog:
Direkt nach einen Stromausfall kommt es allerdings dann zu einer
enormen Lastspitze, weil alle Server gleichzeitig starten und die USV
auch noch ihre Akkus laden will - da sagt die Sicherung natürlich
dann (berechtigterweise!) "Nein, Danke".

Erzähl mir nix von Elektrotechnik, ich hatte auch mal einen ehrbaren Beruf, bevor ich in die Welt des Imaginären und Unfassbaren übersiedelte

Halte dir einfach eins im Hinterkopf: Je mehr du machst, umso
unwahrscheinlicher wird es, dass ein Datenrettungslabor noch helfen
kann.

Du bringst es auf den Punkt !


mrtux
Bitte warten ..
Mitglied: bitstash
05.05.2009 um 08:01 Uhr
Morgen,

sehe ich alles genauso. Max, das wär mein nächster Schritt gewesen -> Backup. Ich mache mich jetzt dran und guck was noch geht. Bis dato sieht es ganz danach aus, das der Contoller die angeschlossenen Festplatten nicht mehr erkennt, aber wie gesagt ich bin noch am Ursachen forschen. Ich meld mich später wieder, sobald ich neue Erkenntenisse habe ;)
Bitte warten ..
Mitglied: ahartmann
05.05.2009 um 09:26 Uhr
@mrtux: solche posts helfen ihm nach dem crash nicht sonderlich weiter! ein forum ist nicht dazu da, sich nach einem supergau über den admin lustig zu machen, ein gescheiter tipp wäre da hilfreicher gewesen.

@bitstash: viel erfolg .-)

ich mache es prinzipiell so, das ich von jedem server die systempartition als acronis image habe und die bewegungsdaten als tägliches acronis backup sichere
Bitte warten ..
Mitglied: ahartmann
06.05.2009 um 09:39 Uhr
@bitstash: wie ist es gelaufen?
Bitte warten ..
Mitglied: mrtux
06.05.2009 um 15:02 Uhr
Hi !

Zitat von ahartmann:
@mrtux: solche posts helfen ihm nach dem crash nicht sonderlich
über den admin lustig zu machen, ein gescheiter tipp wäre da

Ich habe mich nicht über ihn lustig gemacht, meinst Du ich hatte solche Situationen nicht auch schon ? Aber wenn jemand heute einen Server ohne Datensicherung betreibt, hat das nix mit Administration zu tun, mich würde das Schlamperei nennen.

Und jeder, wirklich jeder, der in so einer Situation schon war, hat dabei was gelernt, da schliesse ich mich ganz bestimmt nicht aus.

@bitstash: viel erfolg .-)
tägliches acronis backup sichere

Im Moment hilft ihm das auch nicht, von daher Nase fassen.

mrtux
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
Adaptec 6805 Raid Controller - defekt?
gelöst Frage von Axel90Festplatten, SSD, Raid15 Kommentare

Hi! ich habe gerade einen gebrauchten Adaptec 6805 in meinen Server eingebaut. Wenn ich den Server starte, leuchten alle ...

Festplatten, SSD, Raid

Mainboard defekt. Raid Controller auf anderesBoard

gelöst Frage von sjefkeFestplatten, SSD, Raid6 Kommentare

Hallo an allen, Bei mir ist ein Mainboard kaputt gegangen, kann ich den Raidcontroller einfach auf ein anderes Board ...

Windows Server

RAID einbinden - Konfiguration unbekannt - Board defekt

gelöst Frage von Jens1982Windows Server9 Kommentare

Hallo Leute, und zwar stehe ich von einem Problem. Ich würde gerne ein RAID einbinden. Es ist ein Hardware ...

Festplatten, SSD, Raid

RAID 10 Systemfestplatte vom Board Controller oder vom Perc h310 Controller?

Frage von babylon05Festplatten, SSD, Raid8 Kommentare

Hallo, Welches System bietet mir die bessere Performace an den internen Dell T20 Controller für ein RAID 10 für ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 1 TagHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Router & Routing
Mikrotik: Routing zwischen Interfaces mit Geräten ohne Gateway
Frage von TonLichtVideoRouter & Routing20 Kommentare

Hallo zusammen, ich komme aus dem Veranstaltungstechnik Bereich und habe zwei Netze um verschiedene Hardware zu Remoten. CONTROL1 192.168.1.0/24 ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware11 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement10 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...