Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Subst-Befehl in Batch-Datei wird anders behandelt trotz identischer Skripte und Server

Mitglied: Firebean

Firebean (Level 1) - Jetzt verbinden

16.05.2018 um 14:32 Uhr, 351 Aufrufe, 3 Kommentare

Liebe Mit-Administratorinnen und Mit-Administratoren,

ich habe da ein verblüffendes Phänomen, bei dem ich schlicht nicht mehr weiterkomme und euch daher hier um Hilfe ersuche. Wir setzen eine Reihe von Windows Server 2008 R2 64 Bit als Terminalserver ein, auf denen mittels einer Gruppenrichtlinie durch Anmeldeskripts verschiedene Laufwerke gemappt werden. Das klappt auch ganz hervorragend. Unter anderem wird in einem Skript mit der Befehlsfolge

If exist W: Subst W: /d
Subst W: %UserProfile%

der lokale Profilordner des Nutzers als Laufwerk W: substituiert. Der Zugriff auf die Terminalserver erfolgt mit der Citrix XenApp.

Nun zu meinem Phänomen: Ich habe zwei, in meinen Augen identische, Terminalserver eingerichtet, ebenfalls Windows Server 2008 R2 64 Bit. Hier soll bei der Anmeldung ebenfalls dieses Skript ausgeführt werden, damit auch hier der Profilordner des Users als Laufwerk W: substituiert wird. Auch hier funktioniert das soweit einwandfrei, allerdings nur, wenn der User in seinem AD-Objekt kein Homelaufwerk eingetragen hat. Ist das der Fall, wird nämlich nicht der lokale Profilordner substituiert, sondern eben jenes Homelaufwerk. Nehme ich den Eintrag im AD wieder raus, funktioniert es wieder, wie es soll.

Wieso funktioniert das auf den einen Servern problemlos, auch mit eingetragenen Homelaufwerken, auf den anderen, vermeintlich identischen Servern mit, bis auf die Skripte, vermeintlich identischen Gruppenrichtlinien, aber nicht?

Hat hier jemand eine Idee, woran das liegen könnte?
Mitglied: SlainteMhath
16.05.2018 um 16:38 Uhr
Moin,

Citrix XenApp
Version? Mit/ohne UPM? Mit WEM oder ohne?

Homelaufwerk
Gibt's so nicht. Die Felder nennen sich entweder "Basisorder" oder "Benutzerprofil" - welcher ist gemeint?

Und darf ich kurz noch nach dem Sinn fragen? Warum mounted ihr das Userprofile als Laufwerk?

lg,
Slainte
Bitte warten ..
Mitglied: Firebean
17.05.2018, aktualisiert um 07:18 Uhr
Wir nutzen das XenApp Plugin mit der Nummer 11.0.0.5357, ohne UPM oder WEM. Sorry für die unklare Ausdrucksweise, mit "Homelaufwerk" ist hier der Basisordner gemeint. Das Userprofil als Laufwerk zu mounten ist eine Vorgabe der verwendeten Fachanwendung und ist schon seit jeher so. Über Sinn oder Unsinn mag man sich natürlich streiten können, ich muss es jetzt allerdings erstmal so umsetzen.
Bitte warten ..
Mitglied: Firebean
18.05.2018, aktualisiert um 13:23 Uhr
Falls das zur Lösung beitragen könnte, lasse ich das Skript nach Anmeldung am Terminalserver per Doppelklick laufen, tut es, was es soll. Ebenso wenn ich die Befehle in die Eingabeaufforderung eingebe. Und doch wird, wenn das Skript als Anmeldeskript des Users über die Gruppenrichtlinie ausgeführt wird, statt C:\Users\%username% der Basisordner des AD-Objektes des Users gemountet.
Bitte warten ..
Ähnliche Inhalte
VB for Applications
VB Skript für mehrere Batch Befehle
gelöst Frage von freshman2017VB for Applications37 Kommentare

Hallo, zum Glück konntet Ihr mir schon sehr helfen, habe nun noch eine weitere Frage. Ich nutze derzeit ein ...

Windows Server

Subst Befehl als Admin WS2012R2 Terminalserver

Frage von HenrySchillerWindows Server4 Kommentare

Hallo liebe Community, ich habe hier bei uns in der Firma einen Windows Server 2012R2 Standard als WTS eingerichtet ...

Batch & Shell

Batch-Skript - Befehl ausführen wenn Laufwerksname verfügbar

gelöst Frage von Daniel183Batch & Shell2 Kommentare

Hi, ich habe im Moment ein Problem: Ich möchte einen Befehl ausführen lassen wenn ein bestimmter Laufwerksname verfügbar ist. ...

Windows 7

Batch Datei erzeugt bei jedem Befehl Schleife

gelöst Frage von FrashdWindows 72 Kommentare

Moin, wir haben Windows 7 prof. in einer Domäne. Ich habe eine Batch Datei geschrieben, die die Netzlaufwerke verbindet ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 16 StundenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 2 TagenHumor (lol)7 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 2 TagenExchange Server8 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 3 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
Windows Server
Server 2016 Autotiering Storage Space
Frage von HenereWindows Server10 Kommentare

Servus, ich habe jetzt ein StorageSpace auf einem Server 2016 in Betrieb zum Testen. 1x M2 mit 512GB (970pro) ...

Hyper-V
Hyper-V keinen Zugriff auf USB Gerät über USB Server
Frage von Barns83Hyper-V10 Kommentare

Normal bin ich ein stiller Leser und wühle mich im normal Fall durch Foren oder schau durch meine Bücher. ...

Netzwerke
SSH - Wieso werde ich nach VPN Verbindung rausgeschmissen?
Frage von VernoxVernaxNetzwerke10 Kommentare

Hallo, ich habe es endlich geschafft mein Handy mit einer VPN Verbindung an meinen Router anzuschließen. Nach der Login ...

Multimedia
Live TV mit Raspberry
Frage von honeybeeMultimedia9 Kommentare

Hallo, ich bin relativ neu im Umgang mit Raspberry und habe folgendes Problem: Ich habe keinen Fernsehanschluss über Kabel ...