Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SuSE 10 -> Epson AcuLaser 900N druckt zwar -> aber kein automatischer Start des Druckertreibers

Mitglied: 26774

26774 (Level 1)

03.04.2006, aktualisiert 14.04.2006, 5656 Aufrufe, 8 Kommentare

MoinsIch habe mir per folgendem Link/Workout meinen Epson Aculaser zum laufen gebracht ("Jaaaaaaaaaaa, er druckt!") :http://alc900-cups.sourceforge.net/Hiermit kann man ein Script ausführen , dass den passenden Treiber installiert und das geht auch ganz gut, wenn man ein bischen mit Cups fummelt und nicht einfach den Drucker auswählt, sondern Drucker und PPD separat (warum auch immer).Allerdings muss ich die Datei "install.sh" nach jedem Systemstart erneut ausführen, sie macht dann nichts anderes als die Vorinstallation zu überschreiben.Damit man das besser nachvollziehen kann, habe ich mal den Inhalt der shell nachfolgend reinkopiert:[code]VERWALTUNG:/home/svewil # /home/svewil/treiber/alc900-cups-0.11.1.i386/alc900-cups-0.11.1.i386/install.shI will now perform a standard test, whether your systemsupports the Linux "RUN-LEVELS" concept properly.This may take a while !Parsing the runlevel directoriesExamining runlevel 2 ........ done!Examining runlevel 3 ................. done!Examining runlevel 5 ................... done!stopping AcuLaser C900, please wait ....Stopping AcuLaser C900 () doneremoving previous installation ... done!installing driver ....... done!restarting the CUPS daemonShutting down cupsd doneStarting cupsd donesearching /etc/sudoers: ALL ALL = NOPASSWD: /usr/bin/alc900.wakeupThis "alc900.wakeup" entry was found in "/etc/sudoers"Therefore I will skip the configuration of "/etc/sudoers" enter a local interface connection If your printer interface is not in the list, and your printer model does not show up, it might be appropriate to switch on the printer first and enter "R" for "retry" ! 1) cups-client-only
    • 2) parport0
    -> 1Starting AcuLaser C900 (alc900.daemon ) doneStarting the AcuLaser C900 ...... done!gnome-cups-manager is starting up!setup a printer at the device URI "alc900://"You could also enter another device URI like: - ipp://xxx.xxx.xxx.xxx:631/EPSON_IPP_Printer - ipp://<ip-address-of-CUPS-server> - smb://<samba-share>The printer model is an EPSON AcuLaser C900 (alc900) [/code]Warum muss ich das jedesmal neu installieren und hat jemand eine Idee, wie ich das automatisieren kann?Ist sehr spezifisch weiss ich, deswegen erwarte ich jetzt auch nicht grade eine Lösung, aber vielleicht .....
Mitglied: Top44
08.04.2006 um 01:12 Uhr
Hi,

also folgende fragen währen erstmal zu klären, ist der drucker nach einem Neustart im Cups Interface zu sehen ??

Automatiseren kann man dass nur wenn du keine eingabe betätigen musst, ( oder dir jmd besorgen der es für die Programmiert ),

Automatischer Start :

1. Manuell: Dienste, die beim Boot automatisch starten sollen, sind über das Runlevel (im Konsolenmodus sollte das 3 sein) verdrahtet. Ein Link von "/etc/init.d/[Skript]" nach "/etc/init.d/rc3.d/[Skript]S[Nummer]" bzw. zum automatischen Stoppen nach "/etc/init.d/rc3.d/[Skript]K[Nummer]" reicht aus.

[Nummer] definiert einfach die Reihenfolge, in der die Dienste gestartet (niedrigste zuerst) bzw. gestoppt (höchste zuerst) werden.
Bitte warten ..
Mitglied: 26774
08.04.2006 um 07:24 Uhr
Da muss ich mal "forschen". Der Drucker ist im Interface zu sehen, aber er reagiert nicht.

Es gibt da wohl einen Deamon für den Drucker (alc900.deamon) der gestartet wird, wenn ich das install.sh neu ausführe. Aber ich kann nicht erlesen, WIE. Da steht nur ein Zahlencode dahinter (Bsp.: "[98253]").

Ich hab auch schon mal spasseshalber "alc900.deamon restart" und "alc900.deamon run" und so Zeug versucht, aber das ist wie Topfschlagen.

Deine Beschreibung muss ich mir mal genau anguggen, ich sach "Bescheid".

Danke für die"Spur"
Bitte warten ..
Mitglied: Top44
08.04.2006 um 11:33 Uhr
Hi,

unter welchem Anschluss hast du den Drucker laufen ?
Bitte warten ..
Mitglied: 26774
08.04.2006 um 11:42 Uhr
Als Netzwerkdrucker (Aculaser 900N) unter http://192.168.0.9:631/EPSON_IPP_Printer

Der dazugehörige Server läuft auf einem Windows Rechner und vermittelt die "Schnittstelle" als SMB Freigabe.

Spielt den die Schnittstelle eine Rolle?
Bitte warten ..
Mitglied: Top44
08.04.2006 um 13:30 Uhr
hi,

normal heißt der Pfad für den Drucker, http://IP/printers/drucker

Verusuch es mal so, aber was mich doch dann verwirrt wieso er dann beim ersten mal, bzw. bei der Installation druckt...

[EDIT] Versuch mal folgendes,

Drucker installieren, PC Herunterfahren, Drucker Ausschalten, PC Hochfahren warten bis er Richtig hochgefahren ist, und dann den drucker Einschalten, wenn dass Klappt ist die Cups Version irgendwie nicht in Ordnung, ich hatte dass Problem auch mal.

Wenn du normal Startest, zeigt CUPS den Drucker als Gestartet an oder Gestoppt.. ?
Bitte warten ..
Mitglied: ullsig
13.04.2006 um 15:29 Uhr
Hallo,

Den Daemon (alc900.daemon) kannst du mit
rcpipsplus restart
neu starten.

Die Datei
/var/log/alc900.log
zeigt dir dabei, was beim Starten des Daemons schiefgegangen sein könnte.
Ich habe auf Mandriva/Ubuntu/SuSE entwickelt, und da sollte der Treiber laufen.

Vielleicht versuchst du einfach mal die neuere Version (0.12) des Treibers auf

Gruss
Ullrich
Bitte warten ..
Mitglied: 26774
14.04.2006 um 15:18 Uhr
THX a lot!

"rcpipsplus restart" -> geht. Vielen Dank!

Die 0.12 Version ist drauf. Vielen Dank nochmal!
Bitte warten ..
Mitglied: ullsig
14.04.2006 um 20:43 Uhr
Danke fürs Feedback

Ciao
Bitte warten ..
Ähnliche Inhalte
Peripheriegeräte
Epson Perfection auf Windows 10
Frage von GrueneSosseMitSpeckPeripheriegeräte3 Kommentare

Hi, ich hab einen uralten Epson Perfection 1600 der unter Windows 7 mit einem gehackten Treiber vom Perfection 2400 ...

Drucker und Scanner

Bondrucker EPSON TM-T88III druckt nicht unter Word

gelöst Frage von Dirk-m1Drucker und Scanner1 Kommentar

Hallo, ich habe einen Epson TM-T88III Belegdrucker mit USB-Anschluss und möchte diesen unter Windows XP (SP3) mit MS Word ...

Windows 10

Windows 10 - Verknüpfung automatisch "an Start anheften"

gelöst Frage von adm2015Windows 1020 Kommentare

Gibt es eine Möglichkeit eine Verknüpfung direkt an das neue Windows 10 Startmenü anzuheften ohne dies manuell durchführen zu ...

Windows 10

Drucker (oder Windows?) unter Windows 10 druckt nicht

gelöst Frage von bytecounterWindows 104 Kommentare

Hallo zusammen, die Umgebung: 2 Rechner (2 Monate alt), jeweils Win 10 Home 1511, per LAN-Kabel im Netz 1 ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 2 TagenAusbildung35 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 4 TagenSpeicherkarten5 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 4 TagenSicherheit1 Kommentar

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 5 TagenHardware4 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Passwortwechsel Zeitpunkt festlegen
Frage von Looser27Windows Userverwaltung27 Kommentare

Guten Morgen liebe Kolleginnen und Kollegen, da es eine Userin in meinem Urlaub geschafft hat, sich vom AD vollständig ...

Windows Server
Probleme im AD am Außenstandort
gelöst Frage von emeriksWindows Server19 Kommentare

Hi, wir haben ein Problem mit AD und GPO am Außenstandort und ich stehe momentan mächtig auf dem Schlauch. ...

Windows 10
Windows 10 Spracherkennung - Eure Meinungen?
Frage von honeybeeWindows 1014 Kommentare

Hallo, wollte heute mal aus Neugier die Spracherkennung unter Windows 10 (Version 1803) ausprobieren und war mehr wie enttäuscht. ...

Switche und Hubs
POE-Switche
gelöst Frage von MiStSwitche und Hubs13 Kommentare

Guten Morgen, ich überlege ob ich in unserem Netzwerk die aktuellen Switche (D-LINK DGS-1210-28) durch PoE-Switche ersetzen soll. Der ...