Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

wenn sverweis stimmt naechste zelle pruefen und wenn das stimmt ausgabe von einem wert in einer anderen Zelle

Mitglied: keilers2k

keilers2k (Level 1) - Jetzt verbinden

13.01.2009, aktualisiert 11:57 Uhr, 6313 Aufrufe, 8 Kommentare

hallo leute,

ich brauche dringend eure hilfe. ich habe 2 tabellen, in der T1 in D11 sind materialnummern die mit T2 in A2:A65532 überprüft werden müssen, wenn der eintrag gefunden wurde soll er in T2 in D2:D65532 prüfen ob ein "J" drin steht, wenn ja soll er in T1 in BF11 den wert "E"
ausgeben, ansonsten brauch er nicht tun.

hier meine versuche

=WENN(SVERWEIS($D11='[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$A$65527;
UND('[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$D$2:$D$65527="J";"E";"")

=WENN('[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$D$2:$D$65527="J";
(WENN($D11='[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$A$65527;"E";""));"")

=WENN(UND('[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$D$2:$D$65527="J";
SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$A$65527;"E";"")));"")

=WENN($D11='[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$A$65527;
'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$D2="J";"E";"")

ich kann keine extra spalten einfuegen, also es muss irgendwie so gehn.

ich danke euch jetzt schon mal

gruss keiler
Mitglied: bastla
13.01.2009 um 17:19 Uhr
Hallo keilers2k und willkommen im Forum!

Soferne ich das richtig interpretiert habe, sollte die Formel etwa so lauten:
=WENN(NICHT(ISTFEHLER(SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$D$65532;4;0)));WENN(SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$D$65532;4;0)="J";"E";"");"")
Grüße
bastla
Bitte warten ..
Mitglied: Biber
13.01.2009 um 21:04 Uhr
Moin keilers2k und bastla,

die Fragestellung habe ich aber anders verstanden.

Bei mir wäre die Lösung
=WENN(ISTZAHL(VERWEIS(2;1/($D11='[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$A$65527&'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$D$2:$D$65527)));"E";"")
Erläuterung:
Bei meinen zaghaften Versuchen, mit Exceltabellen rumzualbern, habe ich die Funktion VERWEIS() als geeigneter befunden, die Übereinstimmung/Verkettung von MEHREREN Spalten [Hier: wenn "Tab2.SpalteA & Tab2SpalteB" ist gleich dem Inhalt von $D11] abzubildeten.
Wenn dieses konkatenierte Suchkriterium gefunden wird, dann hat das "VERWEIS(2;1/(kryptisches Geraffel))" den Wert 1.
Andernfalls #NV.

Einschränkung:
  • bei VERWEIS() müssen AFAIK beide beteiligten Tabellen offen sein.
  • und wenn die Suchspalte $D in der namenlosen Tabelle mit dem Suchkriterium leer ist, dann kommt auch "1" heraus.

@bastla
in Deiner Formel durchsuchst Du IMHO doch eine Matrix Tab2.Spalte $A$2 bis Tab2.$D$bisunten.
Wenn nun in den Spalten $C und $D etwas drinsteht...???

Grüße
Biber
Bitte warten ..
Mitglied: bastla
13.01.2009 um 21:34 Uhr
@Biber
SVERWEIS sucht nur in der ersten Spalte (hier: A) und liefert das Ergebnis aus der per Index (hier: 4 = D) angegebenen Spalte zurück - wenn also der Inhalt von Tab1.D11 in Spalte A gefunden wird (der letzte Parameter erzwingt übrigens, was bei VERWEIS IMHO nicht möglich ist, einen exakten - mit Ausnahme der Berücksichtigung von Groß-/Kleinschreibung - Vergleich), liefert der SVERWEIS den Wert aus Spalte D der gefundenen Zeile; wird D11 nicht gefunden, ist das Ergebnis #NV.

Grüße
bastla
Bitte warten ..
Mitglied: Biber
13.01.2009 um 21:51 Uhr
@bastla
Ahhh ja...
Wenn ich Excelformeln lang genug lese bzw. geduldig genug erklärt bekomme, dann verstehe ich sie auch beim 18ten oder 19ten Mal.

Okay, dann funktioniert Dein Ansatz auch.
Aber meiner ist volkswirtschaftlich vertretbarer, weil nur ein teurer VERWEIS()-Aufruf pro Feld gemacht wird und Du braucht zwei genau teure SVERWEISE() pro gefundenem Suchkriterium...

Grüße
Biber
Bitte warten ..
Mitglied: bastla
13.01.2009 um 22:05 Uhr
@Biber
... meiner ist volkswirtschaftlich vertretbarer ...
... allerdings mit einer gewissen Nonchalance: Wenn in Spalte A (die tunlichst sortiert sein sollte) ua die ArtNr 1462 und 1468 aufscheinen und nach 1466 gesucht wird, nimmt der VERWEIS einfach mal das nächstbeste Ergebnis (das wären dann die Daten für 1462) ...
Wenn ein #NV (für den Fall, dass der Inhalt von D11 in der Spalte A nicht gefunden wird) als Ergebnis der Formel nicht stören sollte (oder, als Hinweis auf die fehlerhafte ArtNr, sogar erwünscht wäre), würde übrigens auch
WENN(SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$D$65532;4;0)="J";"E";"")
genügen ...
Ansonsten muss ich gestehen, dass ich Deiner Formel nicht wirklich folgen kann - wo wird denn eigentlich der Vergleich mit dem "J" vorgenommen?

Grüße
bastla
Bitte warten ..
Mitglied: Biber
14.01.2009 um 09:55 Uhr
Moin bastla,

Ansonsten muss ich gestehen, dass ich Deiner Formel nicht wirklich folgen kann
Zu recht, zu recht....
- wo wird denn eigentlich der Vergleich mit dem "J" vorgenommen?
Gar nicht... ich hatte das Problem falsch vertanden.
Ich war (warum auch immer) davon ausgegangen, dass im Suchfeld ($D11) schon der konkatenierte Text "ArtNr+"J" steht, der in der anderen Tabelle auf zwei Spalten verteilt ist...

Also -> please ignore .... alles Grütze. Bzw. kurzweilige Diskussion, aber nicht zielführend.

Grüße
Biber
Bitte warten ..
Mitglied: keilers2k
14.01.2009 um 10:03 Uhr
hallo,

erstmal danke fuer eure antworten, aber die formeln funzen nicht.

@bastla
deine formel klingt gut aber ich bekomme keine ausgabe "E" obwohl in D ein "J" steht. habe deine mal geaendert und da bekomme ich ein "X"
=WENN(NICHT(ISTFEHLER(SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$D$65532;4;0)));WENN(SVERWEIS($D11;'[Baukastenstücklisten Mafago Stand 081208.xls]Test'!$A$2:$D$65532;4;0)="J";"E";"");"X")

was haltet ihr von der formel, hier bekomme ich aber "keine Nummer" obwohl ja das "J" da ist.
=WENN(ISTNV(SVERWEIS(D11;Tabelle2!A1:D65527;4;));"keine Nummer";WENN(SVERWEIS(D11;Tabelle2!A1:D65527;4;)="J";"E";""))

wenn ihr noch fragen zu meinem prob habt, fragt einfach. kann man das auch eber vba machen. davon hab ich aber keine ahnung.

danke
keiler
Bitte warten ..
Mitglied: bastla
14.01.2009 um 16:19 Uhr
Hallo keilers2k!

Sowohl Deine Version als auch meine Variante liefern eigentlich das selbe Ergebnis: Der Inhalt von D11 wird in A2:A65527 (oder A2:A65532 ) nicht gefunden.

Die Ursache könnten zB Leerzeichen am Ende der Nummern in D11 oder in Spalte A sein, wodurch trotz "optischer" Übereinstimmung die Inhalte eben nicht gleich sind. Ein Test mit einem Wert für D11, der aus der Spalte A kopiert wurde, sollte zeigen, dass beide Formeln grundsätzlich ok sind ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel SVERWEIS mit mehreren Ausgaben
Frage von PeronasMicrosoft Office

Hallo zusammen, hätte nochmal eine Frage zu einer Excelaufgabe. Und zwar habe ich 2 Tabellen. 1. Tabelle beinhaltet die ...

Microsoft Office

Excel Funktion 2 Zellen auf Gleichheit prüfen um aus Zelle 3 Wert zu übernehmen

Frage von Mirko74Microsoft Office6 Kommentare

Hallo und vielen Dank schon mal für Eure Hilfe. Ich habe folgendes Problem: Excel soll in der jeweiligen "ZelleB" ...

Microsoft Office

Wenn eine zelle einen bestimmten wert aus anderen zellen annimmt...

gelöst Frage von BerndVorwerkMicrosoft Office4 Kommentare

Hallo an alle, ich wende mich einmal mehr vertrauensvoll an euch: Wie muss die Funktion in Excel aussehen, wenn ...

Batch & Shell

PowerShell - Werte werden nicht ausgegeben und Formatierung Ausgabe

gelöst Frage von goodbytesBatch & Shell16 Kommentare

Hallo, diese Abfrage im PS-Fenster (Windows PowerShell ISE) gibt im PS-Fenster dieses Ergebnis zurück: Die gleiche Abfrage, nur mit ...

Neue Wissensbeiträge
iOS
IOS 11.2.6 verfügbar
Information von sabines vor 2 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 16 StundenSicherheit1 Kommentar

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server38 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless15 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...