Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Testumgebung im Produktivnetz einrichten

Mitglied: RicoPausB

RicoPausB (Level 1) - Jetzt verbinden

14.07.2011, aktualisiert 18.10.2012, 4463 Aufrufe, 7 Kommentare

Wir müssen den Internetzugang des Produktivnetzes in einer Testumgebung nutzen ...

... das scheitert aber an der Problematik, dass wir innerhalb der Testumgebung auch einen Windows 2003 R2 als DC benötigen, da wir das Produktivnetz 1:1 abbilden möchten.

Derzeitiger Lösungsansatz:

Wir haben im Produktivnetz (192.168.100.x) einen WRT54GL mit DD-WRT eingesetzt, der mit dem WAN-Port im Produktivnetz hängt und dessen LAN-Seite die Testumgebung (172.16.x.x) beinhalten soll.
Installieren wir nun in der Testumgebung den DC, so scheitert dies beim DCPROMO, da die Meldung kommt, dass die Domain bereits vorhanden ist.

Mein Verständnis vom Routing ist leider eher als "rudimentär" zu bezeichnen, weshalb es mir wohl auch ein Rätsel ist, wie der DC der Testumgebung den DC des Produktivnetzes überhaupt finden kann.
Generell würde ich vermuten, man müsste irgendwie die Kommunikation ins Produktivnetz unterbinden. Aber in diesem Netz ist ja auch der Router für den Zugang zum Internet vorhanden ...
Der würde dann ja auch nicht gefunden werden ...

Ich müste also irgendwie einrichten, dass aus der Testumgebung heraus das Produktivnetz bis auf den Router "gesperrt" wird ...

Geht das überhaupt mit dem WRT54GL mit DD-WRT?

Danke im voraus für alle Anregungen
Mitglied: aqui
14.07.2011, aktualisiert 18.10.2012
Ja, es kommt darauf an WIE bzw. in welchem Modus ihr den DD-WRT Router betreibt. Mit NAT (Adress Translation) am WAN Port oder ohne, also mit transparentem Routing.
Am Beispiel einer WLAN Kopplung 2er Netze kannst du das sehen:
https://www.administrator.de/wissen/mit-einem-wlan-zwei-ip-netzwerke-ver ...
Leider teilst du uns das in deiner etwas oberflächlichen Beschreibung nicht mit.
Mit NAT am WAN Port hat der Server im Produktivnetz keinerlei Möglichkeiten auf das Testnetz zuzugreifen da er die NAT Firewall dort nicht überwinden kann.
Wenn dann klappt das nur mit entsprechenden Port Forwarding Einträgen. Ohne diese ist das Testnetz vom Produktivnetz aus isoliert. Nicht aber in die andere Richtung. Alles was vom Testnetz ins Produktivnetz und Internet geht ist problemlos erreichbar.
Bitte warten ..
Mitglied: Haytech
14.07.2011 um 11:31 Uhr
Hallo RicoPausB,
Ihr habt dort ein Routingproblem normalerweise darf der 2. Server nichts von der Domäne erkennen wenn der Router korrekt eingestellt ist.

ihr wollt im Netz 2 (Eure Testumgebung auch zugriff aufs Internet - ich nehme an das der DD-WRT den Windows Server als DNS eingetragen hat. Hier muss die anfrage jedoch an den Provider DNS dann kann im Netz2 der Domänenname aus Netz 1 nicht aufgelöst werden.
Bitte warten ..
Mitglied: Chonta
14.07.2011 um 11:35 Uhr
Hallo,

ich gehe mal davon aus, das die Testumgebung virtuell sein wird.

1. Eine VM als Router einrichten (eine Netzwerkkarte im 192,168.100.x Netz die andere im 172.160.x.x)

2. Deinen Testrechnern eine Feste IP geben die im Testnetz ist und die IP des VM-Routers hat.

3. Dafür sorgen, das nur ein DNS aus der Testumgebung verwendet wird.

Umbedingt dafür sorgen, dass der Server in der Testumgebung nicht auch eimals über einen PoP3 Connector abrufen will oder versenden will sonst hast Du ein Problem.
Und wenn es eine 1:1 Umgebung werden soll, würde ich den jetzigen Server in eine VM konvertieren (gibt da Programme von z.B. VM-Ware für) oder wenn euer Backup das kann eine Wiederherstellung des Backups in eine VM (Guter Test ob das Backup auch was taugt und ob die Dienste alle laufen wie sie sollen.

Wenn Du den aktuellen Server in eine VM oder andere Hardware zurücksichert sogre dafür, das das Netzwerkkabel gezogen ist, damit Du dir nicht deine Produktivumgebung zerschießt.
Achso, wenn der Server zufällig aus DHCP ist, abstellen.

Gruß

Chonta
Bitte warten ..
Mitglied: RicoPausB
14.07.2011 um 11:58 Uhr
@aqui
Ja sry ... sehr oberflächliche Beschreibung ... mir fiel auf die schnelle nichts passenderes ein ;(
Und NAT ist am WAN-port an, so dass das produktivnetz eigentlich nicht "reinkommen" dürfte ...

@Haytech
da scheint der Hund begraben zu sein ;)
der Router hat am WAN-port "DHCP" aktiviert, so dass er natürlich die kompletten Einträge vom Produktivnetz bekommt ... wie dämlich, dass ich darauf nicht geachtet habe ...
werde das umgehend anpassen und den DNS mal komplett auf Provider-Daten setzen ...
Wahrscheinlich ist das problem dann schon behoben ...

@Chonta
du beschreinst schon zufällig genau das Schema, dass wir angehen wollten ;)
also mit router-vm und einem in eine VM konvertierten Server ;)

zusammen mit haytech's Hinweis auf den DNS-Einträg werde ich das mal angehen ...

DANKE an alle für eure Hilfe

Werde diesen Eintrag noch kommentieren ob's klappt ...

c ya

Rico
Bitte warten ..
Mitglied: Haytech
14.07.2011 um 13:27 Uhr
Na es ist doch sehr erfreulich das es jetzt klappen kann.

Für einen ESXi gibt es sehr gute Router VMs fertig zum downloaden.

meine Empfehlung: PFSense
Bitte warten ..
Mitglied: aqui
14.07.2011 um 18:22 Uhr
...oder Monowall
http://m0n0.ch/wall/downloads.php

Router in einer VM zu installieren ist aber höchst kontraproduktiv und man kann nur dringend davon abraten.
Zum einen ist der Sicherheitsaspekt zum anderen und das ist viel gravierender für dich ist die Funktion der gesamten Testumgebung von der Verfügbarkeit des ESXi abhängig.
Ein Grund warum man Routing Funktionen niemals in solche Systme integriert und immer extern realisiert. Mit deinem DD-WRT bist du eigentlich perfekt bedient, deshalb ist es eigentlich nicht nachvollziehbar warum du nun zur schlechteren Variante greifst ?!
Bitte warten ..
Mitglied: RicoPausB
04.08.2011 um 11:36 Uhr
Hat alles geklappt ...
Der geänderte DNS Eintrag im Router hat schon geholfen ...
Nichtsdestotrotz haben wir noch einmal einen test mit monowall gemacht ... auch top ...
Also beide Lösungen praktikabel.

Danke für die Hilfe
Bitte warten ..
Ähnliche Inhalte
Vmware

Testumgebung VM Workstation im Produktivnetz

gelöst Frage von pipen1976Vmware3 Kommentare

Hallo, ich habe mir mit VM Worstation 14 eine kleine Testumgebung auf einem Workstation PC erstellt. Der Host hängt ...

Virtualisierung

Performance der Testumgebung messen

Frage von KEFHVDIVirtualisierung5 Kommentare

Hallo, da ich demnächst die Performance meiner VMware Horizon Testumgebung testen möchte, ich aber noch keine Ahnung habe wie ...

Switche und Hubs

Cisco Switche für Testumgebung

gelöst Frage von griss2015Switche und Hubs21 Kommentare

Moin, würde mir gerne 2-3 Cisco Switche zulegen, um damit solche Theman wie VLAN, Routing zwischen VLANs, Access Listen, ...

Windows Update

WSUS - Updates in Testumgebung

gelöst Frage von MiStWindows Update3 Kommentare

Guten Morgen, Ich habe einen WSUS (Sever 2016) bei dem ich 2 Computergrppen erstellt habe - "Clients" und "Sever". ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...