Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Thinstation mit Openvpn funktioniert nicht

Mitglied: bollerbirne

bollerbirne (Level 1) - Jetzt verbinden

08.05.2010 um 21:11 Uhr, 3730 Aufrufe

Zum Einsatz kommt Thinstation-2.2.2d. Gebootet wird von CF-Karte. thinstation.conf.user wird problemlos eingelesen.

Hallo liebe Linuxfreunde,

ich beiße mir schon seit ein paar Tagen die Zähne an Thinstation aus. Mit stehen Windows XP Embedded als auch Thinstation Clients zur Verfügung. Vor ein paar Tagen habe ich auf einem XP-Emb. openvpn eingerichtet und war von den Möglichkeiten sofort begeistert (Aussenstellenanbindung etc.) Voller Freude habe ich im Thinstation Paket auch ein openvpn Client gefunden. Also aktiviert, config angepasst und build eingegeben. Aber Pustekuchen Ich bin den Standartweg gegangen und habe mir aus /conf/openvpn.conf.sample folgendes rauskopiert und in die thinstation.conf.buildtime (oder in thinstation.conf.user) eingetragen:
01.
# Thinstation config: 
02.
OPENVPN_SERVER="123.123.123.123" 
03.
OPENVPN_PORT="1195" 
04.
OPENVPN_PROTO="udp" 
05.
 
06.
# OpenVPN server config: 
07.
dev tap 
08.
server 10.8.0.0 255.255.255.0 
09.
push "route 192.168.17.0 255.255.255.0" 
10.
keepalive 10 60 
11.
# dh /etc/openvpn/dh.pem 
12.
#pkcs12 /etc/openvpn/server.p12 
13.
#persist-tun 
14.
# persist-key 
15.
#keysize 256 
16.
# comp-lzo 
17.
#verb 3
Leider bekomme ich folgende Fehlermeldungen (egal in welcher config ich die Einträge mache):
01.
/etc/rc0.d/S05network: /etc/thinstation.user: 337: dev: not found 
02.
/etc/rc0.d/S05network: /etc/thinstation.user: 338: server: not found 
03.
/etc/rc0.d/S05network: /etc/thinstation.user: 339: push: not found 
04.
/etc/rc0.d/S05network: /etc/thinstation.user: 340: keepalive: not found
ich denke das ich einen Denkfehler habe. Alle Configs sind ja nach dem Motto Variable=Wert aufgebaut. Nur bei dev, server, push ... nicht. Darf ich diese Werte nicht einfach so ausklammern? Muss ich sie evtl. mit in eine andere Zeile schreiben?

Was mich noch stutzig gemacht hat. Die /etc/init.d/openvpn war die einzige Datei die nicht ausführbar war sodass ich beim booten anfangs 'permission denied' Meldungen hatte. Das hatte ich bis ich vor dem 'build' die '/packages/openvpn/etc/init.d/openvpn' ausführbar gemacht habe. Ob das richtig ist weiß ich allerdings auch nicht?

Benutzt hier jemand Thinstation mit openvpn und kann mir einen Denkanstoß geben?

Viele Grüße, der langsam verzweifelnde Henne
Ähnliche Inhalte
Windows Netzwerk
OpenVPN als Service funktioniert nicht!
Frage von mike7050Windows Netzwerk6 Kommentare

Hallo, mein Vorhaben ist wie folgt: Ich möchte einen Windows 7 Prof 64bit PC über OpenVPN mit einem Strato ...

Router & Routing

OpenVPN funktioniert nach reboot nicht ohne manuellen Eingriff

Frage von cgicloudRouter & Routing1 Kommentar

Hallo zusammen, Setup: Windows Server 2012 als FUNKTIONIERENDER OpenVPN Server. Problem: Sobald der Server neu gestartet wird kann man ...

Netzwerkprotokolle

OpenVPN selbe config funktioniert an einem Rechner nicht

gelöst Frage von PharITNetzwerkprotokolle4 Kommentare

Hallo, hat jemand vielleicht noch eine Idee für mich? Ich nutze ein und dieselbe config Datei testweise an einem ...

Linux

Thinstation in VirtualBox startet nicht

Frage von the-buccaneerLinux2 Kommentare

Moin! Versuche, eine Thinstation 5.5.1 in der VirtualBox zu laufen zu bringen. Leider erfolglos Anforderungen nach umgesetzt. Sowohl die ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 10 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 11 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 14 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...