Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Trunk zwischen HP und Cisco

Mitglied: homermg

homermg (Level 2) - Jetzt verbinden

19.02.2015, aktualisiert 23.02.2015, 1171 Aufrufe, 8 Kommentare, 1 Danke

Hey Leute,

wir haben einen Hauptswitch (Cisco) und einen Etagenswitch HP 2530.
Die beiden habe ich mit 2x Glassfaserkabel verbunden und möchte die nun bündeln damit ich mehr Leitung habe.
Bei HP heißt es ja Trunk und bei Cisco glaube ich Aggrigation Mode oder so.
Naja ich kriege das nicht wirklich hin wenn ich auf dem HP nun auf den beiden Ports Trunk einschalte und einer Trunkguppe1 zuweise wird das gettagte VLAN rausgeschmissen und die beiden Ports sind dann als untagget gekennzeichnet.
Kann mir da jemand helfen?
Vielen Dank Leute!
Mitglied: Valexus
19.02.2015 um 15:10 Uhr
Moin,

ja na klar sind die Ports untagged. Du musst die VLANs natürlich auf den Trunk legen.
http://h30499.www3.hp.com/t5/ProCurve-ProVision-Based/ProCurve-2510-mul ...

VG
Valexus
Bitte warten ..
Mitglied: aqui
19.02.2015, aktualisiert um 20:56 Uhr
Hier kannst du nachlesen wie es geht:
https://www.administrator.de/wissen/netzwerk-management-server-raspberry ...

Ist zwar primär für einen Linux Host mit Bonding gedacht die Switch Konfigs auf HP und Cisco Seite ist aber dafür identisch wenn man die Switches direkt koppelt.
Kannst du also so direkt abtippen !

Bei einem tagged Port mit VLANs sieht das auf Cisco Seite so aus:
interface Port-channel1
description Cisco 2Port LAG
switchport mode trunk
switchport trunk allow vlan all
!
interface FastEthernet0/3
description Link 1 zum HP
switchport mode trunk
channel-group 1 mode active
switchport trunk allow vlan all
!
interface FastEthernet0/4
description Link 2 zum HP
switchport mode trunk
channel-group 1 mode active
switchport trunk allow vlan all


HP Gurke:
time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 1
name "LAG Uplink 1 zum Cisco"
interface 2
name "LAG Uplink 2 zum Cisco"
exit
!
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.254 255.255.255.0
exit
vlan 10
name "Firma"
untagged 10-11
tagged 1-2
exit
vlan 20
name "Clients"
untagged 12-13
tagged 1-2
exit
vlan 30
name "Server"
untagged 14-15
tagged 1-2
exit
!
trunk 1,2 trk1 LACP

Alternativsyntax nur für die Trunk Konfig:
trunk eth 1-2 trk1
interface eth 1-2 lacp active



Ein dringendes Wort der Warnung sofern du Spanning Tree verwendest:
Cisco nutzt im Default PVSTP+ (Per VLAN Spanning Tree) mit speziellen BPDU Mac Adressen. (01:00:0c:cc:cc:cd)
Billigheimer HP kann generell KEINE irgendwie geartete Art von PVST !! Sie supporten rein nur das steinzeitliche Global Spann oder MSTP.
Ferner können die billigen HPs sich, im Gegensatz zu anderen Herstellern, auch nicht automatisch auf die Cisco PVST+ Mac Adressen einstellen.
Sie sind deshalb also NICHT mit dem Cisco STP kompatibel und es kommt bei redundantem Design zu erheblichen Spanning Tree Komplikationen und damit zu nicht voraussehbaren Netzwerk Störungen solltest du auf beiden Seiten STP nutzen !!!
Beachte das.
Du hast 3 Optionen:
  • Die Cisco Seite auch auf das steinzeitliche Global Span konfigurieren.
  • HP und Cisco auf MSTP konfigurieren
  • Spanning Tree auf dem Koppel Link ganz abschalten auf beiden Seiten. Das birgt aber in einem redundanten Design die gravierende Gefahr eines Loops und damit völligen Netzwerk Stillstand.
Das solltest du besser immer im Hinterkopf behalten wenn du billige HPs in einem Cisco Umfeld einsetzt !
Bitte warten ..
Mitglied: homermg
20.02.2015 um 09:04 Uhr
super vielen Dank für die ausführliche Lösung!!!!1
Wie sieht es eigentlich aus wenn ich die beiden LVL's nicht bündele und einfach zwischen den beiden Switchen verbinde.
Was passiert dann geht ein Teil des Traffics über einen LVL und eine anderer Teil über den anderen? und wenn ein ausfällt dann geht alles über den anderen?
Vielen Dank!
Bitte warten ..
Mitglied: Valexus
20.02.2015, aktualisiert um 10:34 Uhr
Wie sieht es eigentlich aus wenn ich die beiden LVL's nicht bündele und einfach zwischen den beiden Switchen verbinde.
Wenn du die beiden nicht bündelst erzeugst du einen Loop und legst ohne STP im schlimmsten Fall dein ganzes Netzwerk lahm.
Wie aqui schon beschrieben hat musst du dich auf ein STP Verfahren einigen welches beide Switches können (MSTP).

Was passiert dann geht ein Teil des Traffics über einen LVL und eine anderer Teil über den anderen? und wenn ein ausfällt dann geht alles über den anderen?
Nein das funktioniert nur bei wenn du ein Port Trunking (LACP, IEEE 802.3ad) verwendest. Solange wie beide funktionieren läuft die Kommunikation über beide, sollte einer ausfallen läuft eine Leitung alleine weiter.
Wenn du nur 2 Switches miteinander verbinden willst, gibt es meiner Meinung nach nichts was gegen die Verwendung von LACP spricht.

Billigheimer HP kann generell KEINE irgendwie geartete Art von PVST !! Sie supporten rein nur das steinzeitliche Global Spann oder MSTP.
Gibt es überhaupt andere Hersteller außer Cisco wo PVST oder PVST+ zum Einsatz kommt? Soweit ich weis ist dies ein reines Cisco Protokoll.

VG
Valexus
Bitte warten ..
Mitglied: homermg
20.02.2015, aktualisiert um 10:45 Uhr
ah verstehe
reicht es denn wenn ich nur auf der HP Seite einen Trunk auf den beiden LVL's mache? oder ist es zwingend notwendig auch auf der Cisco Seite das gleiche zu machen?
PS: STP auf dem HP ist per default ausgeschaltet
Bitte warten ..
Mitglied: Valexus
20.02.2015 um 11:22 Uhr
Nein das reicht nicht, du musst das schon auf beiden Seiten einrichten.

VG
Valexus
Bitte warten ..
Mitglied: aqui
LÖSUNG 20.02.2015, aktualisiert 23.02.2015
Wie sieht es eigentlich aus wenn ich die beiden LVL's nicht bündele und einfach zwischen den beiden Switchen verbinde.
Das wäre fatal und ein großes Risiko, denn dann hättest du grundlegend gesehen erstmal ja ein Loop gesteckt der im Ethernet sofort tödlich ist ohne Spanning Tree !!
Mit Spanning Tree geht einer dieser Links dann in den STP Blocking Mode, so das nur einer dieser Links aktiv ist. Spanning Tree verhindert so den tödlichen Loop.
Willst du das mit den 2 Links also ohne Link Aggregation machen, ist ein sauber arbeitender und konfigurierter Spanning Tree zw. beiden Komponentendann für dich absolut zwingende Pflicht !!
Bedenke dann die oben genannten Probleme zw. dem Billigschrott von HP und Cisco. Wenn du das STPseitig nicht sauber anpasst riskierst du einen Stillstand im Netz.

Besser ist dann in der Tat immer eine Link Aggreagtion ! (802.3ad mit LACP)
Damit bist du Spanning Tree frei und hast zugleich noch die doppelte Bandbreite das immer BEIDE Links aktiv sind im Gegensatz zu einem STP Szenario !!
Fällt einer aus arbeitet der andere weiter. Du hast also auch noch ein Failover obendrein !!
Kollege Valexus hat das ja schon umfassend beantwortet...

P.S. Was bitte ist ein "LVL" ??? Lustiger Verteiler Link ??
Oder meintest du LWL wie LichtWellenLeiter ??
Bitte warten ..
Mitglied: homermg
23.02.2015 um 10:35 Uhr
super danke dir!
natürlich LWL
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

LACP Trunk mit VLANS zwischen HP und Cisco

gelöst Frage von 14116LAN, WAN, Wireless4 Kommentare

Ich habe hier den bestehenden LACP Trunk um ein VLAN 60 und um ein VLAN 80 zu erweitern. Ich ...

Netzwerkprotokolle

Problem bei VLAN Trunk mit LACP zwischen HP und Cisco

gelöst Frage von markuswoNetzwerkprotokolle11 Kommentare

Hallo zusammen, folgende situation: - Ubuntu server 14.04 mit DHCP für verschiedene Ranges - Cisco SG300 L3 Switch welcher ...

Switche und Hubs

Cisco trunk einstellen

gelöst Frage von homermgSwitche und Hubs11 Kommentare

Hey Leute, ich arbeite relativ selten mit unseren switchen und bin mir nun bei einer Sache nicht ganz sicher. ...

Voice over IP

Cisco-2951VSEC - Sipgate Trunk

Frage von Serial90Voice over IP1 Kommentar

Moin Moin, ich habe ein kleines Problem mit einen C2951 und sipgate. Und zwar habe ich bei Sipgate einen ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 10 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 10 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 1 TagSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
gelöst Frage von YellowcakeExchange Server22 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...