Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Typo3 Intranet für Domäne bereitstellen

Mitglied: breppe

breppe (Level 1) - Jetzt verbinden

31.05.2011 um 15:48 Uhr, 5317 Aufrufe, 5 Kommentare

Hallo,

ich habe auf einem Server Typo3 mit dem Windowsinstaller installiert. Habe mir auch schon eine kleine Seite erstellt. Läuft soweit alles wunderbar. Ein paar kleinere Probleme habe ich allerdings noch.

Das Intranet ist mittels http://10.10.10.10:8888 im kompletten Netzwerk erreichbar.

Ich hätte jetzt allerdings gerne, dass die User nicht immer diese IP eingeben müssen, weil sich die ja kein Mensch merken kann. Nun hätte ich auf dem DC (Windiws Server 2003) im DNS Dienst unter dem Forward-Lookupzonen --> Meine Domäne einen neuen Alias (CName) erstellt. Bei den Vollqualifizierten Domänennamen habe ich "intranet" angegeben. Folglicht lautet der Aliasname "intranet.meinedomäne.local". Als Vollqualifizierten Domänennamen der Zielhosts habe ich 10.10.10.10:8888 angegeben.
Leider funktioniert die Namensauflösung aber nicht. Was habe ich da falsch gemacht?

Das nächste ist, dass ich im Intranet einige Links wie z.B file:///C:/Datei.txt habe. Mit den Standardeinstellungen des IE kann ich diese Links nicht öffnen. Speichern "- ziel speichern unter" - funktioniert aber. Nun habe ich in den Sicherheitseinstellungen des IE unter "Sicherheit", "Lokales Intranet" die IP Adresse des Servers hinterlegt. Die Sicherheitsstufe habe ich testweise auch auf niedrig gestellt. Leider lassen sich diese Links trotzdem nicht öffnen.
Habt ihr eine Idee, an was das liegen kann? Google sagt mir leider zu diesem Thema auch nicht mehr.

Gruß
Mitglied: kopie0123
31.05.2011 um 16:00 Uhr
Hallo,

ersteinmal zur Namensauflösung: Das klappt nicht!

Du kannst nur auf eine IP umleiten.

Die Port Einstellungen müsstest auf dem Webserver machen. Warum läuft die seite nicht auf 80 oder 443?

Gruß
Bitte warten ..
Mitglied: breppe
31.05.2011 um 16:12 Uhr
Hallo,

ich hab da mehrere Seiten am laufen. Je nach Port gelange ich auf eine andere Seite. Hab ich da gar keine andere Möglichkeit mit DNS? Ansonsten muss ich das halt so umbiegen, dass ich das Intranet auf dem Server auf Port 80 laufen lasse.

Danke für deine Antwort!
Bitte warten ..
Mitglied: kopie0123
31.05.2011 um 16:42 Uhr
Hey, im DNS hast du keine Porteinstellungen.

Enweder "umbiegen" oder intranet.meinedomäne.local:8888

Gruß
Bitte warten ..
Mitglied: martin-s
31.05.2011 um 17:19 Uhr
Je nach dem welchen Webserver du einsetzt hast du folgende Möglichkeiten:

- Apache: Einen Virtuellen Host anlegen und als Servernamen "intranet" angeben.
- IIS: Analog einen Virtuellen Host anlegen. Hier heißt das aber Hostname.

LG
Martin
Bitte warten ..
Mitglied: blauschleiche
31.05.2011 um 17:54 Uhr
Hi,
gerade zu deinem Problem Nr. 1 gibt es ja etliche Lösungen die davon abhängen wie dein Kenntnisstand ist, wie versteckt die Sache sein soll und welche Webserver Software du verwendest.
1.
Einfachste Möglichkeit ist auf dem Webserver der auf Port 80 läuft eine Index Seite zu erstellen die durch einfache Links auf die verschiedenen "Intranets" weiterleitet. So müssen sich die User nichts merken und du brauchst nichts umzukonfigurieren.
2.
Es könnte auch sein dass du dein Typo3 zu einfach installiert hast. Typo3 verträgt durchaus eine base_url. Dadurch nimmt es nicht einen ganzen Port für sich in Anspruch sondern nur einen Pfad. z.B. http://10.10.10.10:8888/typo3 oder eben http://10.10.10.10/typo3 . Dadurch können mehrere Applikationen koexistieren.
3.
Du kannst auch auf dem Webserver am Port 80 auf einen Pfad z.B. /Typo3/ einen reverse proxy aufsetzen der auf den Server auf Port 8888 Umleitet. Aber unbedingt die gleiche base_url verwenden. Du solltest erst gar nicht versuchen von /typo3/ auf z.B. /mytypo3/ umzuleiten oder von /typo3/ auf / .
4.
Es gäbe sogar die Möglichkeit eine virtuelle Webserver Instanz zu konfigurieren die automatisch den Browser auf http://10.10.10.10:8888 umleitet per server side redirect. Dadurch würde der Browser von z.B. intranet1.meinedomäne.local auf http://10.10.10.10:8888 umgeleitet.
5.
Letztendlich gäbe es sogar die Möglichkeit per server side redirect nur den Ordner umzuleiten z.B. von intranet.meinedomäne.local/typo3 auf http://10.10.10.10:8888.
Bei den Lösungen 1,4 und 5 würde der User den Redirect bemerken. Schließlich landet er auf einer ganz anderen Seite als er angegeben hat.
Lösung 2 ist wohl die Sauberste. Lösung 3 bietet sich an wenn eine Application auf einem bestimmten Webserver nicht zur Mitarbeit zu bewegen ist aber auf einem anderen anstandslos läuft.

Ich hoffe sehr ich habe nicht all-zuviel Verwirrung gestiftet.
Gruß
Bitte warten ..
Ähnliche Inhalte
Informationsdienste

TomCat 7.0.42 Manager nur für das Intranet bereitstellen

Frage von FutschelInformationsdienste3 Kommentare

Hallo Mitstreiter, folgendes bereitet mir etwas Kopfzerbrechen. Wir wollen eine Webanwendung für die "Welt" bereitstellen. Diese läuft zurzeit nur ...

Windows 10

Microsoft Edge speichert Domänen credentials nicht für Lokales Intranet

Frage von NeoCrownWindows 102 Kommentare

Hallo Zusammen Ich versuche Informationen zu finden wie ich den Edge Browser (aktuellste Version) dazu bringe, mich nicht jedesmal ...

Vmware

OFV Bereitstellen

gelöst Frage von Florian86Vmware2 Kommentare

Hallo, Ich habe mir von einer Vsphere 5.5 Umgebung Virtuelle Maschinen exportiert. Diese wollte ich nun bei mir (Vsphere ...

CMS

Mögliches Sicherheitsleck in Typo3, Webcache

gelöst Frage von CoreknabeCMS4 Kommentare

Moin Wissende, leider ist mir keine passendere Titelzeile eingefallen und ich bin auch kein Experte auf diesem Gebiet. Ich ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 StundenGoogle Android

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 3 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 6 StundenMicrosoft2 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server36 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing15 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

CPU, RAM, Mainboards
32 gb RAM zu wenig?
Frage von pcguyCPU, RAM, Mainboards13 Kommentare

Hallo zusammen, mein PC verfügt über 32GB Ram. Nun kriege ich bei grossen Dateien im Illustrator die Fehlermeldung das ...