Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Typo3 LDAP-Server Konfigurations Fehler

Mitglied: duddits

duddits (Level 2) - Jetzt verbinden

03.09.2007, aktualisiert 13:24 Uhr, 8723 Aufrufe, 2 Kommentare

Hallo zusammen,

nach langen herum spielen, habe ich die PHP-LDAP-Erweiterung ans laufen bekommen.
Nun wollte ich, um meine FE-Benutzer bei Active Directory authentifizieren zu lassen die LDAP-Module von Typo3 nehmen.
Ich benutze also folgende Module:
ldap_lib
ldap_server
ldap_auth
ldap_sync

Alle in der Version 0.2.1 außer ldap_lib, welches es scheinbar nur in der Version 0.2.0 gibt.
Jedoch funktioniert das alles nicht so wie in der Doku beschrieben. Oder ich verstehe da Grundlegende Dinge falsch.

Hier mal ein paar Screenshots mit den Resultaten die ich habe. Zunächst ein mal der TS-Code der für die Konfiguration des LDAP-Servers eingesetzt wird:
http://pupilsearcher.pu.funpic.de/er2.JPG

Denn Code habe ich unter der Konfiguration wie im diesem Bild hier zu sehen eingefügt(unten unter Konfiguration:sad:
http://pupilsearcher.pu.funpic.de/er1.JPG

Im Template selber verwende ich keinen TS-Code der Bezug zum LDAP-Server hat, was mich ein wenig stutzig macht.

Weiterhin erhalte ich seltsame Fehlermeldungen, wenn ich mir mein bisheriges Frontend ansehe, welche ich vorher nicht hatte. Der Fehler ist erst seit dem Aktivieren der LDAP-PHP-Erweiterung sowie der Installation/ dem Laden der LDAP_Module(wurde beides in einem Zug realisiert) vorhanden.
http://pupilsearcher.pu.funpic.de/er5.JPG


Auch LDAP-Sync zeigt mir nichts an:
http://pupilsearcher.pu.funpic.de/er4.JPG

Auch seltsam ist, das der LDAP-Server nur unter dem Reiter Liste auf taucht, aber nicht wenn ich auf Bearbeiten unterm Reiter Seite gehe:
http://pupilsearcher.pu.funpic.de/er3.JPG

Wie könnte ich testen ob es nur daran liegt, das ich falsche Informationen im LDAP-Server Modul angegeben habe?

Über Vorschläge, Hilfe oder Tipps etc. würde ich sehr freuen. Habe auch schon die Forensuche verwendet, doch nichts brachte mich zur erhofften Lösung.

Gruß
duddits
Mitglied: duddits
03.09.2007 um 10:33 Uhr
Hallo zusammen,

ich habe mal weiter herum probiert und dachte mir, ich versuche einfach ein kleines pp script zu schreiben, mit dem ich teste ob eine Verbindung überhaupt möglich ist.
Hier der Code:
01.
<?php 
02.
function test($username, $password
03.
04.
  $ds = ldap_connect("ip meines ad server"); 
05.
  echo $ds."\n<br>"
06.
  if ($ds
07.
08.
    $authenticated = false; 
09.
    $bind = ldap_bind($ds, $username, $password); 
10.
    if ($bind
11.
12.
      $authenticated = true; 
13.
14.
    ldap_close($ds); 
15.
    return $authenticated
16.
17.
  else 
18.
19.
    $err = 'Verbindung zum LDAP-Server nicht möglich: ' . 'ip meines ad server'
20.
    throw new Exception($err); 
21.
22.
23.
 
24.
if(test("Administrator","geheim")){ 
25.
echo "Verbindung mit Active Directory erfolgreich hergestellt\n"
26.
}else
27.
echo "Fehler bei der der Verbindung\n"
28.
29.
?>

Nun erhalte ich beim Script die ganze Zeit folgendes:

Resource id #2
Fehler bei der der Verbindung


Die Meldung Ressource id scheint mir aber weiter normal, das es ja mit hiermit vergleichbar ist:
http://www.faq-datenbank.de/_5783_artikel_001004_36_de.html

Aber sobald ich das Scrpt nochmals Aufrufe sieht es wie folgt aus:
Resource id #1
Fehler bei der der Verbindung

Es sollte eigl. auch eine Verbindung mit dem Server möglich sein. Benutzername, wie auch Passwort sind richtig, genauso wie auch der Server.

Ich bin ratlos.

Gruß
Daniel
Bitte warten ..
Mitglied: duddits
03.09.2007 um 13:24 Uhr
Hallo zusammen,

Ich konnte das Problem beheben. Der Fehler ist so simpel das man wahrscheinlich deshalb nicht sofort darauf kommt.
Nunja die Lösung ist, nicht den Benutzername einzugeben, sondern Benutzername@Domain.

Gruß
Daniel
Bitte warten ..
Ähnliche Inhalte
Voice over IP
LDAP-Server hilfe
Frage von SteffenEK72Voice over IP

Hallo zusammen, ich habe auf dem Synology Nas einen LDAP-Server laufen, möchte gerne das bei uns im Netzwerk ein ...

Linux
Master-Slave LDAP Server
Frage von schneerunzelLinux

Hallo, ich bin gerade dabei eine Slave LDAP Server aufzusetzen (Master habe ich schon). Hat jemand von euch eine ...

Windows 7

Patchday - Januar 2016 - Fehler bei der Konfiguration

Frage von Jannis92Windows 79 Kommentare

Hallo zusammen, ich bin ein bisschen verwundert, dass laut dem WWW keine issues zu dem Januar Patchday bestehen. Wir ...

SAN, NAS, DAS

Iomega ix2-200 fehler konfiguration

Frage von Asker06SAN, NAS, DAS

Guten Tag, ich würde gerne wieder mein iomega ix2-200 in betrieb nehmen. Beim Versuch es zu konfigurieren (Schritt 1 ...

Neue Wissensbeiträge
Vmware
VMware Updates gegen L1 Lücke
Information von sabines vor 2 StundenVmware

Für die Vmware Produkte vCenter Server, ESXi, Workstation und Fusion stehe Updates bereit um die L1 Lücke zu schließen. ...

Drucker und Scanner
HP-MF-Drucker per Fax angreifbsr
Information von Lochkartenstanzer vor 2 TagenDrucker und Scanner3 Kommentare

Endlich eine sinnvolle Verwendung für Faxe: Damit kann man offensichtlich den Drucker übernehmen. lks

Router & Routing

Das pfSense Buch ist jetzt für jeden kostenlos zu beziehen

Tipp von magicteddy vor 2 TagenRouter & Routing2 Kommentare

Bisher war das Buch nur für zahlende Unterstützer verfügbar, jetzt steht für Jedermann kostenlos zur Verfügung. Siehe auch The ...

Firewall

Möglicherweise neue Sicherheitslücke in Mikrotik-Firmware

Information von LordGurke vor 4 TagenFirewall3 Kommentare

Hallo zusammen, vor ein paar Monaten gab es ja bereits eine Sicherheitslücke in der Firmware von Mikrotik-Routern, über welche ...

Heiß diskutierte Inhalte
Windows 10
WIN 10 1803 - LTE Stick kein Internetzugriff
Frage von killtecWindows 1023 Kommentare

Hallo, ich habe mit einem Windows 10 1803 Probleme mit einem LTE-Stick. Das gleiche Problem ist bei mehreren Rechnern ...

Datenbanken
MySQL Datenbank Import Aufgabe für mehrere .csv dateien
gelöst Frage von Marcel1989Datenbanken19 Kommentare

Hi, ich komm nicht weiter. Ich hab auf einem Windows Server 2012 r2 eine MariaDB/MySQL laufen. Nun soll diese ...

CPU, RAM, Mainboards
Xeon E5620: noch schnell genug?
Frage von ahussainCPU, RAM, Mainboards19 Kommentare

Hallo allerseits, ich habe die Möglichkeit, aus Restbeständen einen Tower mit Xeon E5620 CPU und 24 GB RAM zu ...

Batch & Shell
Windows Task per Batch hinzufügen für wöchentlichen Reboot
gelöst Frage von KusimirBatch & Shell15 Kommentare

Hallo, ich würde gern per Batch auf mehreren PC's (Windows 10) einen Reboot hinzufügen als geplante Task der jede ...