Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Ubuntu OpenVPN Server Tunnel steht, aber warum ist kein Ping möglich?

Mitglied: 3faltigkeit

3faltigkeit (Level 1) - Jetzt verbinden

28.11.2011, aktualisiert 18.10.2012, 7952 Aufrufe, 5 Kommentare

Hallo zusammen,
ich bastle bei mir privat an meinem kleinen Ubuntu Server rum und habe mir nun dort einen OpenVPN Server installiert und laut dem Wiki konfiguriert.
Ich habe mich strikt an die Anleitung gehalten und möchte auch nicht das LAN mit einbeziehen,
sondern wirklich nur von einem Client auf den Server zugreifen.
Also der Tunnel wird aufgebaut und der Client bekommt auch eine IP (10.8.0.6). Allerdings ist es nicht möglich, den Server (tun0 = 10.8.0.1) anzupingen.
Es ist so, dass beim ping befehl keinerlei Antwort zurück kommt. Erst wenn ich den Tunnel schließe, bekomme ich als Antwort: destination unreachable.

Als Randbemerkung wäre noch zu bemerken, dass der Ubuntu VPN Server nicht das Standard Gateway
im Netz ist sondern ein Speedport W700V (IP: 192.168.1.254),
an dem man keine statischen Routen eintragen kann.

Kurz zur IP Konfiguration des Servers:
eth0 = 192.168.2.1
wlan0= 192.168.1.253
tun0= 10.8.0.1

GW, DNS = 192.168.1.254 (Speedport)

Es ist so, das an der eth0 Schnittstelle ein Rechner mit defekten WLAN hängt,
der die WLAN Schnittstelle des Ubuntu Servers für den Internetzugriff nutzt.
Also ist FORWARDING und NAT Konfiguriert (iptables). Hierbei hatte ich mich an aquis Anleitung gehalten:
https://www.administrator.de/index.php?content=56073

Also ich vermute, dass beim Pingen die Pakete schon beim Server ankommen, aber diese Ihren Weg nicht zurück finden und sonstwo landen, eventuell beim Speedport.
Ich habe allerdings keine Ahnung wie ich das mit dem Zugriff auf die 10.8.0.1 hinbekommen kann. Ich habe auch bei Google noch keine pasende Lösung für mich gefunden.
Also falls jemand eine Idee zur Problemlösung hat dann immer her damit. Aber wie gesagt ist ein Privater Bastelrechner - von daher nicht so dringend.
Aber trotzdem schon mal vielen Dank im Voraus.

Grüße
Mitglied: kingkong
28.11.2011 um 23:25 Uhr
Eine Frage vorweg: Warum machst Du für den kabelgebundenen Rechner NAT auf der Ubuntu-Kiste? Ein einfaches Forwarding müsste doch reichen, sodass sich der Rechner dann auch im selben Netz wie der Server selbst befindet...

Was Dein eigentliches Problem angeht: Von wo aus greifst Du denn auf den OpenVPN-Server zu? Soll heißen, hängt der Client an einem anderen DSL-Anschluss? Oder befindet sich der Client im .1er-Netz (also dem lokalen WLAN)?
Und auch wenn Du Dich strikt an das Tutorial gehalten hast wäre es vielleicht ganz hilfreich, erstens das Log für die Verbindung und zweitens die Konfigurationen für Client und Server zu sehen (bitte in <code> - Tags!).

In Abhängigkeit Deiner Antworten habe ich evtl. noch weitere Fragen...

Grüße, kingkong
Bitte warten ..
Mitglied: aqui
29.11.2011, aktualisiert 18.10.2012
Wie sieht dein Szenario aus in Verbindung mit dem Router ?? So:
https://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Genau DAS wäre wichtig zu wissen ?!
Hilfreich wäre auch die Konfig Datei des OpenVPN Servers und mal ein Output des Logs vom Client beim Connect ?! Leider fehlt das alles hier, was eine sinnvolle Hilfestellung nicht gerade einfacher macht

Halte dich genau an dieses OpenVPN Tutorial:
https://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Das beschreibt die Einrichtung Schritt für Schritt und auch den Betrieb hinter einem NAT Router wie deiner Speedport Gurke. (Siehe oben) Ob DD-WRT, pfSense oder Ubuntu spielt dabei keinerlei Rolle, denn die Installation von OpenVPN ist auf allen Plattformen immer gleich !
Wichtig was zu beachten ist für den ersten Test:
  • Der Ubuntu sollte 2 NICs haben
  • Schalte zum ersten Test immer die Firewall auf dem Ubuntu generell AUS um hier nicht weitere Fallen zu legen ! Kann man später wenn alles klappt wieder aktivieren.
  • Zum Testen kannst du den Client der sich einwählt auch erstmal nur auf der NIC connecten lassen die später zum SP geht. Damit simulierst du ja quasi den remoten Zugang auf den OpenVPN Server. Vergiss dann später nicht den Port UDP 1194 (OpenVPN) im SP auf die lokale IP Adresse der am SP angeschlossenen NIC am Server weiterzuleiten !
Im Grunde ein sehr simples Szenario was eigentlich sofort mit 3 Mausklicks zum Fliegen kommt....wenn man denn weiss was man macht ?!
Bitte warten ..
Mitglied: 3faltigkeit
29.11.2011 um 10:54 Uhr
Hey,
danke schon mal für eure schnellen Antworten. Ich werde meine Konfiguration noch mal mit der Anleitung gegenprüfen und mal schauen... und Anschließend dann die confs hier posten. Ich bin nur die nächsten paar Tage nicht zu Hause,
daher wird es sicherlich so Ende der Woche sein bis ich mich hier zurück melde.

Vielen Dank und bis später dann

Grüße
Bitte warten ..
Mitglied: 3faltigkeit
29.11.2011 um 11:44 Uhr
Ich hab gerade noch schnell mittels befehl: sudo ufw disable die Firewall deaktiviert. Naja jetzt gehts auch^^. Durch mein ohne hin schon vorhandenes Forwarding komme ich auch an die interne Adresse 192.168.1.253, wenn der Tunnel aufgebaut ist. Klappt sogar mit meinem Android Handy wunderbar. Sorry, ich wusste echt nicht, das bei Ubuntu Server standardmäßig eine Firewall aktiv ist.

vielen Dank für die Unterstützung
Bitte warten ..
Mitglied: aqui
29.11.2011 um 16:42 Uhr
Ist bei jeder Linux Distro so (bei Winblows ja auch) und wird auch beim Installieren immer abgefragt !
Zum Testen kannst du sie erstmal auslassen aber später solltest du sie entsprechend anpassen, das deine IP Netze und Ports entsprechend durchgehen und dann wieder starten.
Gut wenns nun klappt...!
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Openvpn kein ping auf openvpn server möglich

gelöst Frage von kohle1957LAN, WAN, Wireless4 Kommentare

Mein Server ist ein Windows 2012 Standard hinter einen Kabel Deutschland modem interne ip 192.168.0.200 Habe 2 virtuelle Maschinen ...

Netzwerkmanagement

Openvpn als IPv6 tunnel

Frage von tommy1735Netzwerkmanagement2 Kommentare

Guten Tag Da ich unitymedia nutze und nur eine IPv4 habe und somit nicht auf IPv6 verbinden kann möchte ...

Verschlüsselung & Zertifikate

OpenVPN lässt keine Daten durch den Tunnel

gelöst Frage von MeerwasserVerschlüsselung & Zertifikate3 Kommentare

Hallo, ich habe ein OpenVPN auf Windows 8.1 installiert. Ich kann mich auch problemlos zum Server verbinden. Ich bekommen ...

Router & Routing

Ping über mehrere VPN Tunnel

gelöst Frage von derhalfRouter & Routing28 Kommentare

Hallo zusammen ich habe noch eine dringliche Frage: Wie bekomme ich einen Ping über 2 VPN Tunnel hin? Folgende ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 StundeHumor (lol)

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 14 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 14 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 17 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...