Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Ubuntu Updates in VirtualBox nicht möglich

Mitglied: AndyAh

AndyAh (Level 2) - Jetzt verbinden

07.10.2013, aktualisiert 12:01 Uhr, 2812 Aufrufe, 14 Kommentare

Hi NG,

ich habe ein Problem mit Ubuntu in der VirtualBox. Die Netzwerkeinstellung der virtuellen Maschine ist auf Netzwerkbrücke gestellt. Trotzdem kann ich aus dem Internet keine Updates und Software installieren, wenn in der /etc/network/interfaces die ETH0 Schnittstelle auf static mit den entsprechenden (korrekren) IP-Einstellungen eingestellt ist. Über die DHCP Einstellung funktioniert es.

Woran liegt das?

Gruß
Andy
Mitglied: ticuta1
07.10.2013 um 12:01 Uhr
An (interne )IP Konfiguration der Virtualbox
LG,
ticuta1
Bitte warten ..
Mitglied: AndyAh
07.10.2013 um 12:10 Uhr
Hi ticuta1,

könntest du das Ganze evtl. präzisieren? Wo soll welche Einstellung hin?

Gruß
Andy
Bitte warten ..
Mitglied: holyone
07.10.2013 um 12:19 Uhr
Hallo,
du musst bei VirtualBox im Netzwerkbereich "NAT" auswählen.
Und in der VM selber den DNS-Server eintragen. Dann sollten die Updates eigentlich fluppen.
Bitte warten ..
Mitglied: Chonta
07.10.2013, aktualisiert um 14:24 Uhr
Hallo,

das muss auch mit Netzwerkbrücke gehen.
Hat die VM mit festen IP überhaupt Netzwerk?
Ist eth0 oben oder unten?
Konfigurationsfehler in der Datei?
Netzwerk neu gestartet?
Fehlt für den Neustart ein auto eth0 in der /etc/network/interfaces ?
Sind DNS Server und Gateway auch gesetzt?

Gruß

Chonta
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 15:00 Uhr
ifconfig -a?
netstat -r?
cat /etc/resolv.conf?

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 16:59 Uhr
Zitat von holyone:
du musst bei VirtualBox im Netzwerkbereich "NAT" auswählen.

Warum? es funktioniert ja in seinem bridged-Nertzwerk wenn er DHCP auswählt. Das ist eher ein Hinweis, daß die statischen Einträge nicht stimmen. Deswegen meine Nachfrage nach den verschiedenen Einstellungen. Wenn man die bei DHCP und bei statischer Konfiguration vergleicht, sollte es eigentlich direkt ins Auge springen.

lks

PS: Eine genauere fehlermeldung als "geht nicht" wäre hilfreich.
Bitte warten ..
Mitglied: Lochkartenstanzer
07.10.2013, aktualisiert um 17:01 Uhr
Zitat von AndyAh:
Woran liegt das?

Noch ein wenig Kristalllkugel:

  • IP-Adresse/Maske falsch?
  • Default route falsch?
  • Nameserver falsch?

lks
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:13 Uhr
Zitat von Lochkartenstanzer:
> Zitat von AndyAh:
> ----
> Woran liegt das?

Noch ein wenig Kristalllkugel:

  • IP-Adresse/Maske falsch?
Nein
* Default route falsch?
Nein
* Nameserver falsch?
In den Beispielen im Internet habe ich keine Nameserver-Einträge gefunden. Wie wüden diese dann lauten?



lks

Gruß
Andy
Bitte warten ..
Mitglied: Chonta
08.10.2013 um 08:23 Uhr
Hallo,

z.B. so

auto eth0
iface eth0 inet static
address 192.168.1.58
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255
dns-nameservers 66.212.63.228 66.212.48.10

http://askubuntu.com/questions/143819/how-do-i-configure-my-static-dns- ...

Natürlich ans eigene netz anzupassen.
Du sagst zwar zu IP falsch, Nein, aber hast die Fragen nach ifconfig all nicht beantwortet und auch nicht ob der Server mit seiner Statischen IP überhaupt in deinem eigenen Netz erreichbar ist oder nicht.
Kann der mit der statischen IP einen ping auf 8.8.8.8 absetzen? Wenn ja DNS Problem. Wenn nein ist überhaupt eth0 gestartet?

Gruß

Chonta
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:28 Uhr
Hi Chonta,

danke für den Tipp. Werde es mal ausprobieren. Die Frage nach der ifconfig kann ich dir zzt. leider nicht beantworten, da ich an einem anderen Rechner sitze. Ich kann mich leider mit meinem Win 8 Hostsystem nicht bei Administrator.de anmelden.

Gruß
Andy
Bitte warten ..
Mitglied: Chonta
08.10.2013 um 08:37 Uhr
Hallo,

kommt der Host auch nicht ins Netzwerk?
Du versuchst bei der IPconfiguration aber nicht der VM dieselbe IP wie dem HOST zu geben oder?

Gruß

Chonta
Bitte warten ..
Mitglied: AndyAh
08.10.2013 um 08:44 Uhr
Hi,

der Host kommt ansonsten ins Internet. Ob VM und HOST dieselbe IP haben, muß ich überprüfen, da der Host über DHCP läuft.

Gruß
Andy
Bitte warten ..
Mitglied: Lochkartenstanzer
08.10.2013 um 08:45 Uhr
Zitat von AndyAh:
Hi Chonta,

danke für den Tipp. Werde es mal ausprobieren. Die Frage nach der ifconfig kann ich dir zzt. leider nicht beantworten, da ich
an einem anderen Rechner sitze. Ich kann mich leider mit meinem Win 8 Hostsystem nicht bei Administrator.de anmelden.

putty funktioniert auch unter Win8.

Wenn Du einacfh die drei Fragen beantworten würdest, jeweils für DHCP udn für statische Adressvergabe, würde man recht schnell sehen, wo das Problem liegt.

lks
Bitte warten ..
Mitglied: AndyAh
17.10.2013 um 08:19 Uhr
Hi,

hab's jetzt hinbekommen! Ich habe eine 2. Netzwerkkarte für den DHCP konfiguriert.

Gruß
Andy
Bitte warten ..
Ähnliche Inhalte
Virtualisierung

Virtualbox startet nicht auf Ubuntu 18.04 - Deinstallation

gelöst Frage von wusa88Virtualisierung7 Kommentare

Hallo Zusammen, ich wollte auf einem Ubuntu 18.04, Virtualbox installieren. Habe mich vorerst an diese Anleitung gehalten.: Allerdings war ...

Windows 7

Virtualbox Win7 keine Maus und tastatur nach update

Frage von Lebowski23Windows 71 Kommentar

Hallo, ich habe einen Windows 7 (32bit) Installation in Virtualbox, die auch gut funktioniert habe. Nun habe ich auf ...

Ubuntu

Update auf Ubuntu schlägt fehl

Frage von Philipp711Ubuntu3 Kommentare

Hallo Leute, ich betreibe einen kleinen Nextcloud-Server auf einem Ubuntu 16.04.3 LTS (Linux 4.4.0-104-generic). Der Standardprozedere zum Update des ...

Ubuntu

Ubuntu unter ESX - Netzwerkverbindung nicht möglich

gelöst Frage von echo11Ubuntu8 Kommentare

Guten Abend zusammen, ich bin relativ wenig bewandert, was Linux angeht, möchte aber für einen Test-Webserver ein Ubuntu 14.04 ...

Neue Wissensbeiträge
Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 11 StundenHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Sicherheit

Oracle gibt kritische Updates für diverse Produkte frei (16. Oktober 2018)

Information von kgborn vor 22 StundenSicherheit

Oracle hat zum 16. Oktober 2018 eine ganze Reihe an kritischen Updates für seine Produkte freigegeben. Eine Kurzübersicht mit ...

Windows 10
FYI: Fristen beim Windows 10 Downgrade-Recht
Information von kgborn vor 22 StundenWindows 101 Kommentar

Möglicherweise ist das bei euch bekannt - ich habe es gerade aus einem Newsletter eines OEMs herausgefischt. Beim Downgrade-Recht ...

CMS
Freie Wähler Bayern MySQL PW online
Information von sabines vor 1 TagCMS6 Kommentare

Die Typo3 Installation der Freien Wähler Bayern scheint wohl längere Zeit nicht mehr angefasst und/oder fehlkonfiguriert zu sein. Nach ...

Heiß diskutierte Inhalte
Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1021 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Internet
Ist diese URL denkbar (Syntax)?
gelöst Frage von departure69Internet17 Kommentare

Hallo. Der Sohn eines Arbeitskollegen hat im Gymnasium EDV-Unterricht. Leider hat er in der letzten Klassenarbeit einen Fünfer geschrieben. ...

Exchange Server
Outlook Anywhere - Anmeldefenster muss mit Domain gefüllt werden
Frage von leon123Exchange Server16 Kommentare

Hallo zusammen, ich habe relativ erfolgreich einen Exchange 2016 aufgesetzt, sowie ein SAN-Zertifikat eingespielt und Outlook Anywhere aktiviert. Beim ...

Debian
Linux debian 9 Installation
Frage von Green14Debian15 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...