Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Ungewollte Lücken-Abstände in der Menüleiste mit IExplorer

Mitglied: Franzmann

Franzmann (Level 1) - Jetzt verbinden

11.11.2006, aktualisiert 18.11.2006, 3775 Aufrufe, 5 Kommentare

Hallo,
ich habe eine Menüleiste erstellt und auch funktioniert.
Diese wird mit Mozilla Firefox richtig dargestellt.
Nur unter MS Internet Explorer bekomme ich zwischen die Menüpunkte automatische Platzlücken.
Kann mir jemand sagen wie ich mein Menü für beide Browser kompatibel bekomme
und gleich aussehen lasse.
Hoffe die Erklärung war einigermaßen hilfreich, anbei der Quellcode:

Schnipp --->

<html>

<head>
<title>Menuleiste</title>
</head>

<body>

<style type="text/css">
ul#navigation {
width: 12em;
}
li {
list-style: none;
background-color: #ff0000;
border-top: solid 1px #E5E5E5;
text-align: left;
margin: 0;
}
li a {
display: block;
text-decoration: none;
padding: .25em;
border-bottom: 1px solid #E5E5E5;
border-right: 1px solid #ff0000;
}
a:link, a:visited { color: #ffffff; }
a:hover, a:active { color: #ffffff; }
a:hover { background-color: #FF9999; }
p a:link, p a:visited { color: #000; }
</style>

<td bgcolor="#ffffff" valign="top" height="155" width="194">
<table border="0" cellpadding="1" cellspacing="1" width="97%" bgcolor="#000000">
<tr>
<td bgcolor="ff0000" width="100%"> <center>
<p align="left"><font size="2" face="Verdana" color="white">NAVIGATION</font><font size="2" face="Verdana" color="white">
</font></p>
</center>
</td>
</tr>

<tr>
<td bgcolor="#FFFFFF" width="190">



<li><a href="index.htm">HOME</a></li>
<li><a href="2.htm">UNTERNEHMEN</a></li>

<li id="youarehere"><a href="/3.htm">PRODUKTE</a></li>
<li><a href="4.htm">SHOP</a></li>

<li id="youarehere"><a href="5.htm">KONTAKT</a></li>
<li><a href="6.htm">IMPRESSUM</a></li>

</td>
</tr>
</table>

</body>

</html>

<--- Schnapp
Mitglied: Mitchell
11.11.2006 um 14:36 Uhr
Probier's mal so:

01.
<html> 
02.
 
03.
<head> 
04.
<title>Menuleiste</title> 
05.
</head> 
06.
 
07.
<body> 
08.
 
09.
<style type="text/css">  
10.
ul#navigation {  
11.
width: 12em;  
12.
}  
13.
li {  
14.
list-style: none;  
15.
background-color: #ff0000;  
16.
border-top: solid 1px #E5E5E5;  
17.
text-align: left;  
18.
margin: 0;  
19.
}  
20.
li a {  
21.
display: block;  
22.
text-decoration: none;  
23.
padding: .25em;  
24.
border-bottom: 1px solid #E5E5E5;  
25.
border-right: 1px solid #ff0000;  
26.
}  
27.
a:link, a:visited { color: #ffffff; }  
28.
a:hover, a:active { color: #ffffff; }  
29.
a:hover { background-color: #FF9999; }  
30.
p a:link, p a:visited { color: #000; }  
31.
</style> 
32.
 
33.
<td bgcolor="#ffffff" valign="top" height="155" width="194">  
34.
<table border="0" cellpadding="1" cellspacing="1" width="97%" bgcolor="#000000">  
35.
<tr>  
36.
<td bgcolor="ff0000" width="100%"> <center>  
37.
<p align="left"><font size="2" face="Verdana" color="white">NAVIGATION</font><font size="2" face="Verdana" color="white">  
38.
</font></p>  
39.
</center>  
40.
</td>  
41.
</tr>  
42.
 
43.
<tr>  
44.
<td bgcolor="#FFFFFF" width="190">  
45.
 
46.
 
47.
<li><a href="index.htm">HOME</a></li><li><a href="2.htm">UNTERNEHMEN</a></li><li id="youarehere"><a href="/3.htm">PRODUKTE</a></li><li><a href="4.htm">SHOP</a></li><li id="youarehere"><a href="5.htm">KONTAKT</a></li><li><a href="6.htm">IMPRESSUM</a></li></td>  
48.
</tr>  
49.
</table> 
50.
 
51.
</body> 
52.
 
53.
</html>
Die Listings müssen einfach direkt aneinander stehen. Leider habe ich jetzt kein Firefox, um es auch da zu testen. Beim IE klappt's.

Mfg

Mitchell
Bitte warten ..
Mitglied: Franzmann
11.11.2006 um 15:36 Uhr
Hey,
yo super klappt 1A !! Danke !
Jetzt habe ich nur noch das Problem das es linksbündig sein muss.
Also "Home" soll genau unter "Navigation" stehen.
Hast du ne Idee ?
Bitte warten ..
Mitglied: Mitchell
13.11.2006 um 07:38 Uhr
kanns hier leider nicht ausprobieren. Du musst also entweder warten, bis ich wieder zu Hause bin (am Wochenende) oder es antworten andere


Mfg

Mitchell
Bitte warten ..
Mitglied: Franzmann
13.11.2006 um 07:52 Uhr
...warte ;D ...
Bitte warten ..
Mitglied: Mitchell
18.11.2006 um 17:51 Uhr
so....da bin ich

Erstmal: Es funktioniert auf jedenfall mit einer Tabelle, allerdings nicht in deinem Code. Da ich mich aber leider zu wenig mit HTML auskenne, musst du da nochmal ran.

Hier also meine Lösung (mit einem Teil von deinem Code):

01.
<td bgcolor="#ffffff" valign="top" height="155" width="194">  
02.
<table border="0" cellpadding="1" cellspacing="1" width="97%" bgcolor="#000000">  
03.
<tr>  
04.
<td bgcolor="ff0000" width="100%"> <center>  
05.
<p align="left"><font size="2" face="Verdana" color="white">NAVIGATION</font><font size="2" face="Verdana" color="white">  
06.
</font></p>  
07.
</center>  
08.
</td>  
09.
</tr>  
10.
 
11.
<tr>  
12.
<td bgcolor="#FFFFFF" width="190">  
13.
 
14.
 
15.
<table><a href="index.htm">HOME</a></table><table><a href="2.htm">UNTERNEHMEN</a></table><table><a href="/3.htm"></table><table>PRODUKTE</a></table><table><a href="4.htm">SHOP</a></table><table></a></table><table><a href="5.htm">KONTAKT</table><table></a></table><tabel><a href="6.htm">IMPRESSUM</table></a></td> 
16.
</tr>
du siehst, ich habe statt einer Liste eine Tabelle geschrieben. Wenn ich diese allerdings in deinen Code einfüge (sieht dann so aus),

01.
<html> 
02.
 
03.
<head> 
04.
<title>Menuleiste</title> 
05.
</head> 
06.
 
07.
<body> 
08.
 
09.
<style type="text/css">  
10.
ul#navigation {  
11.
width: 12em;  
12.
}  
13.
li {  
14.
list-style: none;  
15.
background-color: #ff0000;  
16.
border-top: solid 1px #E5E5E5;  
17.
text-align: left;  
18.
margin: 0;  
19.
}  
20.
li a {  
21.
display: block;  
22.
text-decoration: none;  
23.
padding: .25em;  
24.
border-bottom: 1px solid #E5E5E5;  
25.
border-right: 1px solid #ff0000;  
26.
}  
27.
a:link, a:visited { color: #ffffff; }  
28.
a:hover, a:active { color: #ffffff; }  
29.
a:hover { background-color: #FF9999; }  
30.
p a:link, p a:visited { color: #000; }  
31.
</style> 
32.
 
33.
<td bgcolor="#ffffff" valign="top" height="155" width="194">  
34.
<table border="0" cellpadding="1" cellspacing="1" width="97%" bgcolor="#000000">  
35.
<tr>  
36.
<td bgcolor="ff0000" width="100%"> <center>  
37.
<p align="left"><font size="2" face="Verdana" color="white">NAVIGATION</font><font size="2" face="Verdana" color="white">  
38.
</font></p>  
39.
</center>  
40.
</td>  
41.
</tr>  
42.
 
43.
<tr>  
44.
<td bgcolor="#FFFFFF" width="190">  
45.
 
46.
 
47.
<table><a href="index.htm">HOME</a></table><table><a href="2.htm">UNTERNEHMEN</a></table><table><a href="/3.htm"></table><table>PRODUKTE</a></table><table><a href="4.htm">SHOP</a></table><table></a></table><table><a href="5.htm">KONTAKT</table><table></a></table><tabel><a href="6.htm">IMPRESSUM</table></a></td> 
48.
</tr> 
49.
 
50.
</body> 
51.
 
52.
</html>
zeigt der IE mir nur eine leere Tabelle an. Das selbe habe ich auch wieder mit deiner Liste probiert, kommt aber das selbe bei raus.

Sorry, dass ich dir nicht helfen kann, aber ich lerne selber erst richtig HTML . Werde aber, wenn ich Zeit finde, mir das ganze nochmal angucken. Solltest du in der Zeit die Lösung gefunden haben, wär ich froh, wenn du sie mir mitteilen würdest.

Mfg

Mitchell
Bitte warten ..
Ähnliche Inhalte
Windows 10
Systemsymbole Abstand
Frage von AnfaengerCHWindows 102 Kommentare

Hallo Habe Win 10 Pro/64 und in der Tastleiste "zucken" die Systemsymbole ständig zusammen und auseinander. D.h. sie waagrechten ...

Microsoft Office

Bei allen excel files ist die menüleiste gesperrt!?

Frage von GeforceMicrosoft Office1 Kommentar

guten morgen zusammen, bei meinem Excel kommt es oft vor, dass man in den Zeilen arbeiten kann die Menüleiste ...

Windows Installation

Libreoffice nach installation keine menüleiste

Frage von oskarmaderWindows Installation6 Kommentare

Guten Abend, habe heute mein Notebook neu aufgesetzt nach der libreoffice installation ist mir aufgefallen das die Menuleiste fehlt. ...

Hardware

Abstand Server - USV

gelöst Frage von RG2525Hardware2 Kommentare

Hallo, In einem Serverschrank liegen ganz unten 2 Stück USV und gleich darüber ein Server mit 9x 2,5 HDs. ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 2 TagenPeripheriegeräte2 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 3 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 3 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 5 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Router & Routing
Routing Problem mit Kaskade FritzBox und pfsense zugeriff nur von der firewall auf die clients und 0.0.0.0
Frage von ukl1967Router & Routing23 Kommentare

Hallo, ich habe ein an sich triviales Problem elches ich allerdings nicht gelöst bekomme. NAS 10.5.10.53 Mein Netz baut ...

LAN, WAN, Wireless
HP Probook 470 G4 - abbrechende Downloads
Frage von joern1LAN, WAN, Wireless19 Kommentare

Folgendes Problem, für einen Tipp wäre ich dankbar: Bei WLAN-Verbindung zum Internet (nicht LAN) kommt es bei etwas größeren ...

Server-Hardware
Einsteigerfragen zu HP ProLiant DL380p Gen 8
gelöst Frage von brain2011Server-Hardware14 Kommentare

Hallo, ich habe mir einen HP ProLiant DL380p Gen 8 zugelegt, um mich grundlegend mit dieser Geräteklasse und der ...

Server-Hardware
DL380p Gen8 LEDs Laufwerksaktivität funktionieren nicht
Frage von Cisco7971Server-Hardware12 Kommentare

Hallo zusammen, ich habe hier ein seltsames Problem: Die LEDs an den Smart Carriern, die bei Laufwerksaktivität rotieren, tun ...