Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Useradd Problem

Mitglied: lighningcrow

lighningcrow (Level 1) - Jetzt verbinden

05.10.2009 um 19:44 Uhr, 6203 Aufrufe, 11 Kommentare

useradd: Can´t get unique uid in range 0 - 0.

Hallo Leutz,

ich hab da mal eine Frage.

Bin gerade dabei einen Linux Server (Testumgebung Suse 11.0)aufzusetzten. (Ist mein erstes mal ).

Habe bereits Scalix Installiert, und wollte mal zum rumspielen OTRS aufsetzen. Und siehe da ich bekomme Obigen Fehler zugeschmissen.

useradd: Can´t get unique uid in range 0 - 0.

Da habe ich versucht manuell einen ueser einzurichten (über die Konsole) und siehe da ich erhalte die gleiche Fehlermeldung.

Über Yast kann ich Benutzer einrichten.

Kann mir jemand sagen wo der Hund begraben liegt, oder wenigsten verraten wie ich hinter des Rätsels lösung komme???

Wie gesagt ist mein erster eigener Susi.

Kommissar Google habe ich schon befragt. Bis jetzt noch nichts gefunden.

LGLC
Mitglied: masterG
05.10.2009 um 20:52 Uhr
Wie hast du den probiert in der Konsole einen User anzulegen?
Bitte warten ..
Mitglied: lighningcrow
06.10.2009 um 12:42 Uhr
Mit

useradd -d /opt/otrs/ -c 'OTRS user' otrs

(aus http://doc.otrs.org/1.3/en/html/install-cli.html kopiert)

auch bei anderen Benutzernamen das gleiche Phänomen.

Weiß allerdings jetzt nicht auswendig die Optionen von useradd

LGLC
Bitte warten ..
Mitglied: lighningcrow
06.10.2009 um 18:21 Uhr
Supi hat mir weitergeholfen.

Habe dem User einfach die UID 0 verpasst (useradd -u 0 -o)

LGLC
Bitte warten ..
Mitglied: Guenni
06.10.2009 um 19:06 Uhr
Hi lighningcrow,

Habe dem User einfach die UID 0 verpasst (useradd -u 0 -o)

Ob man das als gelungen bezeichnen kann . . . ;-(

Die ID 0 ist die ID von root, dem Systemadministrator. Und wenn du einem

User mal eben diese ID verpasst, hat auch er Administrationsrechte.

Gruß
Günni
Bitte warten ..
Mitglied: Biber
06.10.2009 um 19:30 Uhr
... ergänzend dazu, bevor der nächste Versuch auch wieder knapp daneben geht:
eigentlich sollten alle UIDs im Bereich 0 bis 100 nicht ohne Not vergeben werden, da das nach weitestgehend so verstandenem gentlemen agreement immer Systemaccounts sind und keine interaktiv angemeldeten User.

Gib ihm die UID 567 oder 666 oder was immer du dir leicht merken kannst und was dir wieder einfällt.

Grüße
Biber
Bitte warten ..
Mitglied: Guenni
06.10.2009 um 20:03 Uhr
Zitat von Biber:
... ergänzend dazu, bevor der nächste Versuch auch wieder
knapp daneben geht:

Kurze Zwischenfrage:

Hi Biber, bist du nebenbei Ghostwriter im Comedy/Kabarett ? Wenn ich manchmal deine Kommentare lese,

könnt ich mich abrollen. Solltest du vielleicht als zweites Standbein ins Auge fassen.

. . . aber weiter geht's:

eigentlich sollten alle UIDs im Bereich 0 bis 100
nicht ohne Not vergeben werden, da das nach weitestgehend so
verstandenem gentlemen agreement immer
Systemaccounts sind und keine interaktiv angemeldeten User.

. . . Und das noch nebenbei.

Gruß
Günni
Bitte warten ..
Mitglied: Biber
06.10.2009 um 20:52 Uhr
<OT>
Moin Günni,

Solltest du vielleicht als zweites Standbein ins Auge fassen
Sagen wir so:
Ein zweites Standbein wäre schon nicht schlecht.
Besonders seit mir mein Arzt gesagt hat, wenn ich nicht langsam mit dem Rauchen aufhöre, müsste ich bald kürzertreten.

Ich mag ja solche Wortspiele...

Grüße
Biber
</OT>
Bitte warten ..
Mitglied: lighningcrow
07.10.2009 um 22:17 Uhr
Hmmm...

Nach der Fehlermeldung bin ich davon ausgegangen das der OTRS Account UID 0 haben MUSS...

War das Falsch???

Wenn Ja wie ändere ich das...

STOP nich verraten ich schau mal selbst nach... (ist kein Produktiv System da kann ich noch Spielen )

LGLC

ps: Wie Gesagt bin dabei mich n bissl in die Materie einzuarbeiten.
Bitte warten ..
Mitglied: lighningcrow
08.10.2009 um 17:24 Uhr
So, habe per Usermod die UID auf 111 geändert bis jetzt habe ich noch keine Probleme festgestellt.
Bitte warten ..
Mitglied: Guenni
08.10.2009 um 19:49 Uhr
Hi,

deine erste Fehlermeldung lautete useradd: Can´t get unique uid in range 0 - 0.

Heißt, die uid 0 ist schon vergeben und zwar an root, dem Administrator von S.u.s.e.

Wenn du User anlegst und gibst ihnen ebenfalls die uid 0, so haben diese uneingeschränkt

Zugriff auf alles, weil die uid 0 sie ebenfalls zu Admins macht.

Das muß nicht falsch sein, ich kann natürlich vertrauenswürdige Personen zu Admins machen,

sollte aber nicht die Regel sein.

Gruß
Günni
Bitte warten ..
Ähnliche Inhalte
Server
Problem PHP5.4 Update nun ein Problem
Frage von vServerServer4 Kommentare

Hallo, habe heute auch PHP 5.4 Updatet, nun erhalte ich folgende Meldung: PHP-Quelltext Würde gerne noch auf PHP5.5 ...

Windows Tools
Problem mit excel
Frage von bertaschweigerWindows Tools2 Kommentare

ich habe da mal ein Problem: Excel 2013 / 365 setzt einen Blattschutz, welcher die Zellenbearbeitung (Eingabe) bei ungeschützten ...

PHP
Problem mit php
Frage von jensgebkenPHP4 Kommentare

hallo gemeinschaft ein bekannter hat mir ein kleines script geschrieben in diesem code weerden die variaben f eine sql ...

Windows 10
Großes Problem!
gelöst Frage von L.0.B.0.TWindows 1022 Kommentare

Ich habe Windows im sicheren Modus gestartet, alles läuft normal ausser das nur cmd gestartet wir und ich keine ...

Neue Wissensbeiträge
Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 2 StundenMicrosoft2 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 20 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 1 TagiOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server30 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless25 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...