Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Verbinden und Konfigurieren von 4 Cisco-Routern und 4 PCs

Mitglied: cain99

cain99 (Level 1) - Jetzt verbinden

05.03.2008, aktualisiert 10.03.2008, 8302 Aufrufe, 16 Kommentare

Hallo zusammen
also ich habe im rahmen meiner ausbildung den auftrag bekommen 4 ciscorouter der 2600 serie zu verbinden. Jedoch solln wir uns das wissen dazu aus büchern etc suchen aber ich habe nichts passendes gefunden
Am schluss soll es so aussehen das die 4 router über die seriellen kabel miteinander verbunden sind sprich router 1 mit router 2 , router 2 mit router 3 und router 3 mit router 4.
das klappt auch wunderbar jedoch soll an jedem router noch 1 pc mit win xp angeschlossen werden und diese sollen auch sich gegenseitig anpingen können. das mag zwar eine banale aufgabe sein jedoch steh ich hier aufm schlau und bastel seit 2,5 tagen daran rum und komm nicht weiter. hat jemand villeicht eine lösung?
google brachte leider auch nicht den gewünschten erfolg
also was muss ich den schnittstellen zuweisen, was den pcs und was brauch der router sonst noch an infos
bin in sachen cisco noch nen kleener noob
Mitglied: Dani
06.03.2008 um 14:10 Uhr
Hi cain99,
du erwaretest aber nicht von uns, dass wir die config der Router für dich niederschreiben?! Soweit ich das lese, solltest du dir das wissen selber erarbeiten.

...sprich router 1 mit router 2 , router 2 mit router 3 und router 3 mit router 4.
das klappt auch wunderbar
D.h?! Du kannst von Router 1 den Router 4 pingen?! Da müsstest du min. das Routingprotokoll "RIP" aktivert haben. Oder hast du alle 4 Maschinen in einen IP-Bereich (z.B. 192.168.123.0) gepackt?!

Also ich kenne die Aufgabe so, dass immer eine Verbindung ROuter-Router oder Router-Computer in einem eigenen Subnetz ist.

Router1-Router2
192.168.1.0/30

Router2-Router3
192.168.2.0/30

Router3-Router4
192.168.3.0/30

Router1-Computer
192.168.10.0/30

Router2-Computer
192.168.20.0/30

Router3-Computer
192.168.30.0/30

Router4-Computer
192.168.40.0/30


Das wäre die einfach Aufgabestellung...das kann man naürlich noch stufenweiße erhöhen. Damit jetzt der Computer 1 Router 4 piungen kann, müsste man das Routingprotokoll RIP oder OSPF konfigurieren. BGP würde da keinen Sinn machen!


Grüße
Dani
Bitte warten ..
Mitglied: cain99
06.03.2008 um 18:14 Uhr
also die sache is die ich habe die router untereinander mit seriellen kabeln verbunden und kann auch die schnittstellen gegeneinander anpingen so wie es mir beliebt jedoch möchte ich von pc 1 zu pc 2 pingen.
geht das nich auch mit ner statischen route ? oder muss dazu ein routingprotokoll verwendet?
und ist es eigentlich wichtige welche ip die rechner haben oder is das beliebig
schön dank schonma für die erste antwort


mfg chris
Bitte warten ..
Mitglied: Dani
06.03.2008 um 18:25 Uhr
geht das nich auch mit ner statischen route ? oder muss dazu ein routingprotokoll
verwendet?
Klar, kann man das auch mit statischen Routen machen...aber da kannst du ziemlich vertun. Denn wenn du mal ne Schleife hast, wirst du irre.
Der Vorteil von RIPv1 ist eben, du berauchst nicht viel konfigurieren und du brauchst die keine Gedanken machen, wo du was hinrouten möchtest, was bei stat. Routen der Fall ist.

Die Verbindungsart (Serial, Fibre, Ethernet) spiel keine Rolle!

und ist es eigentlich wichtige welche ip die rechner haben oder is das beliebig
Solltest aber wissen, IP-Adresse spielen keine Rolle. Höchstens es gibt Vorgaben bzw. Einschränkungen, etc...


Grüße
Dani
Bitte warten ..
Mitglied: cain99
06.03.2008 um 18:35 Uhr
ich dachte mir das statisch villeicht von vorteil wäre das ja "nur" 4 router sind
ich hatte es ja auch schonmal mit RIP versucht der hat auch ne route gefunden aber es konnten sich die rechner trotzdem nich untereinander anpingen geschweige denn im netzwerk sehen
Bitte warten ..
Mitglied: cain99
07.03.2008 um 08:25 Uhr
so ich hab hier jetzt mal 2 konfigs der router hier gepostet die sind zu testzwecken ob es geht

router 1 :

San-Jose#show config
Host4
Using 827 out of 29688 bytest4(config)#C 192.168.3
!
version 12.2
Ho
service timestamps debug uptime
Host4(conf
service timestamps log uptime
Host4(config
no service password-encryption-
Host4(config)#ip
!o
hostname San-Jose
!H
!t
ip subnet-zero E - EGPy
!
!
!
!
!
!
interface FastEthernet0/0s Nameal
ip address 192.168.1.1 255.255.255.0
0 connec
Host4(con
no keepalive
1
duplex auto
Host4
speed auto odrIS-IS
!
interface Serial0/0
Host4(config)
ip address 20.0.0.1 255.0.0.0
Host4(config)#
!
interface Serial0/1nfig)#otocolsnfigur
no ip address
shutdownfig)#s
!
interface Serial0/2ot

shutdown
!
interface BRI1/1- periodic d
no ip address
Host
shutdownc
!
interface BRI1/3
no ip address
shutdown
!
router rip
network 10.0.0.0
network 20.0.0.0
!
ip classless
ip route 192.168.2.0 255.255.255.0 10.10.10.2
ip http server
ip pim bidir-enable
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

San-Jose#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
                • - candidate default, U - per-user static route, o - ODR
                P - periodic downloaded static route

                Gateway of last resort is not set

                C 20.0.0.0/8 is directly connected, Serial0/0
                R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:10, Serial0/0
                C 192.168.0.0/20 is directly connected, FastEthernet0/0








                router 2 :

                Using 600 out of 29688 bytes
                !
                version 12.2
                service timestamps debug uptime
                service timestamps log uptime
                no service password-encryption
                !
                hostname San-Marino
                !
                !
                ip subnet-zero
                !
                !
                !
                !
                !
                !
                interface FastEthernet0/0
                ip address 30.0.0.1 255.0.0.0
                no keepalive
                duplex auto
                speed auto
                !
                interface BRI0/0
                no ip address
                shutdown
                !
                interface Serial0/0
                ip address 20.0.0.2 255.0.0.0
                no fair-queue
                clockrate 64000
                !
                interface Serial0/1
                no ip address
                shutdown
                !
                router rip
                network 20.0.0.0
                network 30.0.0.0
                network 40.0.0.0
                !
                ip classless
                ip http server
                ip pim bidir-enable
                !!
                !
                line con 0
                line aux 0
                line vty 0 4
                !
                !
                end


                San-Marino#show ip route
                Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
                D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
                i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
                              • - candidate default, U - per-user static route, o - ODR
                              P - periodic downloaded static route

                              Gateway of last resort is not set

                              C 20.0.0.0/8 is directly connected, Serial0/0
                              C 30.0.0.0/8 is directly connected, FastEthernet0/0
Bitte warten ..
Mitglied: cain99
07.03.2008 um 08:29 Uhr
ich versteh das nicht ..... wieso hat das RIP von router 1 die route erkannt und router 2 nicht?
Bitte warten ..
Mitglied: Dani
07.03.2008 um 13:27 Uhr
Hi!
Also ich habe mir heute und gestern mal die Konfigs angsehen....ich will dir nicht zu Nahe treten aber kann es sein, dass du keinen Plan von RIP und Subnetting hast?!

Hier mal ein Beispiel für ein RIP an Hand von meinem Beispiel oben:
01.
router rip 
02.
network 192.168.1.0 
03.
network 192.168.2.0 
04.
network 192.168.3.0 
05.
network 192.168.10.0 
06.
network 192.168.20.0 
07.
network 192.168.30.0 
08.
network 192.168.40.0
Soweit ich weiß, musst du bei RIPv1 auf die Subnetzmaske achten. Sprich es gibt ja Netzwerkklassen (A,B,C,D,E). Je nach Adressbereich bei dir, müssen an den Interfacen die Subnetzmaske angepasst werden.


Grüße
Dani

Ich empfehle dir mal die englische Doku zu RIPv1 & RIPv2.
Bitte warten ..
Mitglied: cain99
07.03.2008 um 14:07 Uhr
jetzt seh ich noch mehr fragezeichen...also wenn ich show ip route eingeb dann kann ich alle netze sehn in der routingtabelle also müsste doch theoretisch das anpingen der rechner untereinander funktionieren.
denn wie gesagt die einzelnden schnittstellen ob nu seriell oder fastethernet kann ich ja anpingen also warum die rechner nit?
subnetting an sich hatte ich ausführlich gelernt jedoch RIP warn das meine erste versuche und ich habe zur sicherheit alle verwendeten netze ins protokoll eingetragen (ich hoffe das beeinträchtigt es nicht) wobei ich weiß das nicht alle hineingehören jedoch bevor was fehlt lieber etwas mehr
Bitte warten ..
Mitglied: Dani
07.03.2008 um 16:09 Uhr
Ähm...also hast du auch wirklich an den Clients mögliche Firewalls (z.B. Windows-Firewall dekativiert bzw. ICMP Pakete zugelassen)?! Ansonsten wird das pingen schwer.

Kannst du nun vom Router 1 den Router 4 anpingen? Geht aus deiner Aussage nicht klar hervor. Fakt ist, dass RIPv1 auf die Netzklasse + Subnetzmaske achtet. Vllt. mal ein Beispiel:

10.0.0.0 255.255.0.0 => geht nicht
10.0.0.0 255.0.0.0 => geht

172.16.23.0 255.255.255.0 => geht nicht
172.16.23.0 255.255.0.0 => geht


Gruß
Dani
Bitte warten ..
Mitglied: Dani
07.03.2008 um 16:35 Uhr
Hi,
also ich habe eben deinen Konstellation im PaketTracer von Cisco nachgebaut und funktioniert auf Anhieb alles ohne Probleme. Wenn du willst, kann ich dir die Datei zur Verfügung stellen. Brauchst natürlioch den PaketTracer....


Grüße
Dani
Bitte warten ..
Mitglied: cain99
07.03.2008 um 17:09 Uhr
also ja ich kann von router 1 den router 4 anpingen und auch alle anderen.
als netze habe ich jetzt 10.0.0.1 bis 70.0.0.1 jeweils mit der sbnm 255.0.0.0
nur nochmal zur info

achso? bei dir gings gleich? das ist eigenartig villeicht muss ich die router mal reseten
wäre super wenn du das zur vergügung stellen würdest.

mfg chris
Bitte warten ..
Mitglied: aqui
08.03.2008 um 10:23 Uhr
RIP Version 1 ist ein sehr schlechtes Routing Protokoll was aus den Kindertagen des Networking kommt, denn RIP 1 kann nicht mit Subnetzmasken umgehen. Fazit dein IP Design muss immer auf festen Class A, B oder C Adressen basieren. Wenn du Subnetze nutzen willst, dann sollte man wenn man dynamsich Routet besser RIP Version 2 nehmen oder ein anderes dyn. Routing Protokoll wie z.B. OSPF was die 2600er auch supporten !
RIPv1 kann dann eigentlich nur noch verwendet werden um solche Banalnetze im Labor aufzubauen deshalb ist es für dein testnetz erstmal ok muss nur richtig konfiguriert werden, was bei dir nicht der Fall ist.
Du hast einen Kardinalsfehler bekangen in deiner Konfig denn du darfst im Router im RIP Prozess immer nur die Netze eintragen die der Router auch lokal selber hat.
Niemals aber Netze die er selber nicht hat...das wäre ja auch kompletter Unsinn, denn er würde Netze verbreiten an die Nachbarn die er selber nicht bedienen kann. Routertechnisch gesehen vollkommener Blödsinn und eigentlich ein Indiz das du nicht richtig verstanden hast wie IP Routing eigentlich wirklich funktioniert...sorry ! (Von "kleinen" Noob kann da nicht mehr die Rede sein...)

Beispiel:
Angenommen dein Router 1 hat auf dem Ethernet das Netz 192.168.1.0/24 und auf dem seriellen Interface das Netzwerk 10.0.0.0/8 dann darf nur diese Konfig im RIP Router stehen:


router rip
network 192.168.1.0
network 10.0.0.0


Nichts anderes bzw. keine anderen Netze mehr !!!

Natürlich funktioniert das alles auch sehr einfach mit banalen statischen Routen wie du an dieser Zeichnung sehen kannst:


b753c5faaa51332c5baef14a7fff3814-4netze - Klicke auf das Bild, um es zu vergrößern


Damit dein Ping funktioniert musst du natürlich darauf achten, das du in den Firewall Einstellungen der PCs (erweiterte Eigenschaften -> ICMP) einen Haken bei der Antwort auf eingehende Echo reply Packete gesetzt hast !!!
Ebenso muss natürlich die Firewall geöffnet werden für die anderen Netze. Für kleine Noobs ist das schon eine Herausforderung so das diese für solche Tests ggf. erstmal einfacherweise die Firewall abschalten sollten
Bitte warten ..
Mitglied: cain99
08.03.2008 um 11:41 Uhr
also is es mit statischen routen doch einfacher wie ich es oben erwähnt habe?!
das rip einen "dummes"protokoll ist habe ich irgendwo schonma gelesen aber das es auch netze die es selbst nicht direkt an ihm angeschlossen verbreitet wusste ich nich... ich dachte der irgnoriert die
aber vielen dank für die lösung ich werds ma am montag nachbauen

mfg chris
Bitte warten ..
Mitglied: aqui
08.03.2008 um 12:52 Uhr
Ob es einfacher ist kannst nur DU selber entscheiden und nicht das Forum. Für den einen ist es einfacher schnell RIP oder OSPF aufzusetzen der andere hat lieber statische Netze.
Das hängt letztlich von deinem persönlichen Noobfaktor ab
Bitte warten ..
Mitglied: cain99
10.03.2008 um 08:56 Uhr
viel dank für die lösung
mit hilfe der skizze geht jetzt alles wunderbar
Bitte warten ..
Mitglied: aqui
10.03.2008 um 15:38 Uhr
Klasse, dann bitte
https://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Cisco Switch 1812 Konfigurieren
Frage von OsiMacSwitche und Hubs2 Kommentare

Hallo, ich habe einen alten Cisco Switch /Router 1812 von einem Kollegen bekommen. Jetzt wollte ich den gerne Konfigurieren. ...

Netzwerkmanagement
2 Cisco Switche verbinden
gelöst Frage von twicefaceNetzwerkmanagement8 Kommentare

Hallo allerseits, ich beschäftige mich seit kurzem mit Cisco Switchen (wie man sicher an meinen letzten Fragen merkt). ich ...

Netzwerke
CISCO und HP mit VLAN verbinden
gelöst Frage von apranetNetzwerke2 Kommentare

Guten Tag zusammen, unser Netzwerk ist in den letzten Monaten was traffic angeht gestiegen. Jetzt wollen wir VLANs erstellen ...

Router & Routing
Router einrichten und Konfigurieren
gelöst Frage von Fitzel69Router & Routing19 Kommentare

Hallo zusammen, vorweg, ich bin Anfänger und Laie Ich habe einen Router von T-Plink. mit desen Hilfe will ich ...

Neue Wissensbeiträge
E-Mail
Email-Apps und Verhalten bei Pop3
Erfahrungsbericht von kfranzk vor 15 StundenE-Mail3 Kommentare

Hallo Freunde, da mir mein diesbezüglicher Faden als gelöst markiert wurde, muss ich hier neu aufsetzen. Ich arbeite bewusst ...

Hyper-V

Optimiertes Ubuntu per Microsoft Hyper-V-Schnellerstellung verfügbar

Anleitung von Frank vor 16 StundenHyper-V

Für Microsofts Virtualisierungssoftware Hyper-V ist ab sofort auch ein optimiertes Ubuntu 18.04.1 LTS verfügbar. In der "Hyper-V-Schnellerstellung" App, die ...

Sicherheits-Tools

Trend Micro WorryFree Business Security (WFBS) 10 - neuer Patch 1470 verfügbar

Tipp von VGem-e vor 20 StundenSicherheits-Tools1 Kommentar

Servus, mal sehen, ob mit Patch 1470, zu finden unter dann die angeblich fehlerhafte Funktion, die unter W10 im ...

Server-Hardware

Lösung für Ersatz eines defekter Raid-Controllers

Anleitung von wellknown vor 1 TagServer-Hardware3 Kommentare

Hallo, da ich nichts gefunden habe und selbst eine Lösung brauchte, hier eine kleine Anleitung für alle die vor ...

Heiß diskutierte Inhalte
Windows Server
Mit der alten Domäneprofil anmelden ohne Server
gelöst Frage von SyosseWindows Server37 Kommentare

Hallo Jungs Folgendes Szenario: Ich habe bei einem sehr kleinen Unternehmen (2Personen) den Server migriert, soweit hat alles geklappt. ...

Sicherheits-Tools
Virenprogramm lässt Programme nicht starten
Frage von SurferGirlSicherheits-Tools23 Kommentare

Hallo, ich bin neu hier, ich hoffe ich habe die richtige Rubrik gewählt. Falls nicht, tut es mir leid. ...

Windows Server
Kann DNS-Einträge nicht finden
gelöst Frage von BPeterWindows Server19 Kommentare

Hallo, wenn ich folgenden Befehl absetze, bekomme ich eine Liste zurück mit allen Einträgen der DNS-Zone. Wenn ich aber ...

Windows Server
SQL Server Instanz (Eplan) auf WIN 2008 RC2 Server frisst RAM ohne Limit
Frage von derinderinderinWindows Server17 Kommentare

Hallo Zusammen, Wir haben hier einen Windows 2008 RC2 Server. Darauf läuft ein SQL Server Express 2014 Version 12.0.4232.0. ...