Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Keine Verbindung trotz Port-Forwarding ?!

Mitglied: IceT3e3a

IceT3e3a (Level 1) - Jetzt verbinden

23.03.2011 um 19:32 Uhr, 7322 Aufrufe, 10 Kommentare

Nach langem erfolglosem Suchen nach einer Antwort für meine Frage, bin ich letztenendes hier gelandet...ich hoffe, hier kann mir jemand helfen.

Hey...

Ich habe vor zwei Wochen eine Anwendung geschrieben, die auf eine Verbindung wartet. Wenn eine Verbindung gefunden wurde, wird der Benutzer darüber informiert!

Ich habe verschiedene Testläufe gemacht und mich über den Telnet-Client mit meinem Programm, dem ich die (!) statische IPv4-Addresse 192.168.1.119 meines Rechners und den Port 2222 zugewiesen habe, über eben diese IP verbunden! Dies funktionierte auch wie geplant!

Nun wollte ich mich allerdings auch über die externe IP, die ich über den No-Ip host: icebridge.no-ip.biz update, meines Modems (Alice WLAN 1211) mit der Anwendung verbinden. Für diesen Zweck habe ich unter Port-Forwarding
(siehe Bild) die nötigen Ports geöffnet und die Verbindung auf meine Interne IP umgeleitet!
Leider bleibt dieser Verbindungs-Versuch ohne Erfolg...

Mich würde nun interessieren, wieso das so ist, und was ich tun muss, damit ich mich über meine externe IP mit dem Programm verbinden kann...

Hier noch ein paar screens von meinen Versuchen:

59e6e9b1a3edbe572a8a424a9559bc35 - Klicke auf das Bild, um es zu vergrößern

c7e95484059b85bf734ed8d12f08827c - Klicke auf das Bild, um es zu vergrößern

b687e5403dad8910a24c3e4b0c66541e - Klicke auf das Bild, um es zu vergrößern
Mitglied: StefanKittel
23.03.2011 um 19:58 Uhr
Hallo,
was sagt denn Deine Firewall (Windows oder sonstige dazu?)
Evtl. läßt sie nur lokale Verbindungen auf unbekannten Ports durch.
Stefan
Bitte warten ..
Mitglied: IceT3e3a
23.03.2011 um 20:24 Uhr
Ich habe nur die Windows-Firewall aktiviert und die hat die Verbindung zuerst geblockt und mich auf meine Anwendung aufmerksam gemacht! Ich habe die Verbindung dann in die Firewall eingetragen, seitdem meldete sich die Firewall nicht mehr zu Wort.

Edit: Ich habe die Firewall gerade einmal ausgeschaltet, funktioniert trotzdem nicht!
Bitte warten ..
Mitglied: Pjordorf
23.03.2011 um 20:43 Uhr
Hallo,

Zitat von IceT3e3a:
Leider bleibt dieser Verbindungs-Versuch ohne Erfolg...
Ist die IP korrekt aufgelöst und zeigt auch deinen Router?
Windows Firewall darf auch anfragen von AUSSERHALB seines Netzwerks annehmen?

Gruß,
Peter
Bitte warten ..
Mitglied: IceT3e3a
23.03.2011 um 20:50 Uhr
Wenn ich blabla.no-ip.biz in telnet enfüge (ohne Port angabe) und ich mich verbinde, komme ich in das Hauptmenü von meinem Modem, folglich muss die IP richtig sein!

Und wenn ich die Firewall ausgeschaltet habe, ändert sich dennoch nix an der situation...also spielt es keine Rolle, ob die Firewall Verbindungen von außen zulässt. oder?
Bitte warten ..
Mitglied: Pjordorf
23.03.2011 um 21:23 Uhr
Hallo,

Zitat von IceT3e3a:
meinem Modem, folglich muss die IP richtig sein!
War auch nur eine Frage ob...

Firewall Verbindungen von außen zulässt. oder?
Auch hier nur eine frage ob...

Wenn also deine externe IP (FQDN) richtig ist, deine Portweiterleitung im Router korrekt vorgenommen wurde und deine Lokale Firewall nicht blockt, sollte der aufruf telnet blbla.nicht hindert, sollte der Aufruf "telnet blabla.no-ip.biz:2222" Funktionieren. was sagt dein Router Firewall log? Werden die Pakete weitergeleitet? hast du deine Windows Firewall mal auf blocken gestellt und dir das protokoll angeschaut ob die Anfragen dann auch tatsächlich geblockt werden? Hast du mal am PC mit einem Netzwerkmonitor (Net Monitor 3.4 von MS oder Wireschark) mal geschaut was an deinem PC ankommt? Wird auf die richtige IP weitergeleitet?

Gruß,
Peter
Bitte warten ..
Mitglied: 98701
24.03.2011 um 10:33 Uhr
Hi,

funktioniert es denn wenn du die externe IP-Adresse benutzt?

z.b. 212.54.122.66 2222

Schöne Grüße
Bitte warten ..
Mitglied: Arch-Stanton
24.03.2011 um 10:54 Uhr
hast Du Dich von intern auf den no-ip-host geschaltet, oder von einem externen Anschluß? Von intern kannst Du nicht von außen rein und auf den port zugreifen.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: Yali0n
24.03.2011 um 12:06 Uhr
Hi!

Was noch nicht gefragt wurde ...

Werden vom ISP alle Ports durchgereicht?
Bei Privaten anschlüssen gibts teilweise ab modem ein /24, wobei darauf geachtet werden sollte, dass am Router/Firewall auch die forwarding-adresse eingetragen ist ...

Gruß
Yali0n
Bitte warten ..
Mitglied: IceT3e3a
24.03.2011 um 17:54 Uhr
@Arch -Stanton Ui...Das wusste ich nicht!

Ich habe mich von intern verbunden. Also muss ich mich von einem anderen Netzwerk aus über meine externe IP verbinden, um eine Verbindung zu bekommen?
Bitte warten ..
Mitglied: IceT3e3a
24.03.2011 um 17:59 Uhr
@Pjordorf Danke für deine Bemühung, aber ich glaube ich habe bereits die Lösung...mein Fehler war, dass ich mich von meinem Netzwerk aus (also intern) über die externe IP meines modems verbinden wollte, das hatte wohl nicht geklappt!

@98701 Auch wenn ich nur meine externe IP (also 22.11.33.44 2222) angebe, klappt es nicht!

@Yali0n Ich denke schon...

Ich werde demnächst einmal probieren, mich über ein anderes Netzwerk über meine externe IP mich mit meiner Anwendung zu verbinden...
Danke für eure Hilfe...
Bitte warten ..
Ähnliche Inhalte
Server

SSH-Verbindung zum Server ohne Port-Forwarding

Frage von FeveniusServer14 Kommentare

Hallo! Ich bin momentan in folgender Situation: Rechner A befindet sich in einem Netzwerk, bei dem ich kein Port-Forwarding ...

Firewall

2x Port forwarding auf Port 80

gelöst Frage von letstryandfindoutFirewall7 Kommentare

Hallo zusammen, ich habe eine m0n0wall am laufen bei der ich HTTP und HTTPS auf eine IP durchgeschleift habte. ...

Router & Routing

PfSense Port Forwarding - Problem

gelöst Frage von noizedeRouter & Routing17 Kommentare

Liebes Forum! Ich kämpfe seit Tagen mit einem Port Forwarding auf meiner pfSense zu meiner Visualisierung auf einem Smart ...

Firewall

Wie richte ich Port Forwarding auf der Sonicwall ein?

gelöst Frage von AzubineFirewall7 Kommentare

Hallo, ich scheitere an der Port-Weiterleitungseinrichtung an der SonicWall- Vielleicht kennt diese Firewall ja hier jemand und kann mir ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 17 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 20 StundenAdministrator.de Feedback14 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 2 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Network
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Network15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Memory Cards
Vergessliche USB-Sticks?
Frage von hanheikMemory Cards14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Hyper-V
Hyper-V mit altem XEON-Server. Was ist falsch?
Frage von LollipopHyper-V11 Kommentare

Hallo Bin etwas frustriert. Kleinbetrieb, ca. 15 PC's, 2 Stk. Server mit einigen virtuellen PC's für Fernwartung, VaultServer für ...