Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verliere Session Daten nach kurzer Zeit

Mitglied: atomx

atomx (Level 1) - Jetzt verbinden

14.06.2007, aktualisiert 29.03.2008, 2824 Aufrufe, 1 Kommentar

Ich registriere ein per $_GET übergebenes Datum in die Session. Warte ich kurz und fahre dann zur nächsten Seite fort verliere ich das zuvor registrierte Datum aus der Session.

Ich registiere ein Datum in die Session das ich zuvor per $_GET übergeben habe. Wenn ich !sofort! auf die nächste Seite gehe werden alle Daten übertragen. Warte ich jedoch kurz (>1min) verliere ich auf mysteriöse Weise das zuvor registrierte Datum wieder.

Hier der Code in dem registriert wird.
01.
if($_GET['frma']>0) 
02.
03.
	$frma = $_GET['frma']; 
04.
	$_SESSION['frma'] = $frma; 
05.
06.
 
07.
if (!$_SESSION['frma']) 
08.
09.
	xtc_redirect(xtc_href_link(FILENAME_CREATE_FRMA)); 
10.
}
Im weiteren Code ist kein Anhaltspunkt zu finden.

Liegt es vll an den php Einstellungen?
ich nutze Apache (xampp) und php 5.1.4.

Dieses Problem tritt nur lokal auf, auf einem externen Webserver läuft das Ganze einwandfrei.
Jedoch sind auch die lokalen Session Einstellungen und timeouts jenseits von 5min...

Vielleicht hatte ja hier jemand schon mal ähnliche Probleme oder Vorschläge.

Vielen dank im voraus

Jens
Mitglied: Spackenbremse
29.03.2008 um 20:26 Uhr
Hallo.

Schau mal in der Server.ini Datei. Villeciht findet sich da was von Sessions. Ich benutze lokal auch das XAMPP, bei mir hab ich die SESSIONS aber noch nach stunden

Kleiner Tipp für den Code:
Du hast bei der ersten IF-Abfrage ein "Um-die-Ecke-Denker"
Einfacher, übersichtlicher und schneller zu Programmieren wäre:
01.
if($_GET['firma']>0) 
02.
03.
$_SESSION['firma'] = $_GET['firma']; 
04.
05.
.....
Ich denke, wenn das Problem aber nur Lokal auftritt, kann man es ggf. so gut es geht ignorieren.

mfg
Spackenbremse
Bitte warten ..
Ähnliche Inhalte
Windows Server
Citrix-Session auf RDS-Session-Host
Frage von BirdyBWindows Server3 Kommentare

Hallo zusammen, ich habe da gerade ein recht komisches Setup und bräuchte mal Meinungen und Ratschläge Bei uns arbeiten ...

Vmware

VMs verlieren zufällig Netzwerkverbindung

Frage von OniChanVmware3 Kommentare

Servus zusammen, wir haben das "lustige" Phänomen, dass auf mehreren ESX Hosts (nicht in einem Cluster, kein vMotion) zufällige ...

Netzwerkmanagement

Verliere Netzlaufwerke in unregelmäßigen abständen

Frage von malkieNetzwerkmanagement11 Kommentare

Hallo, wir haben seit einigen Woche folgendes Problem beim Kunden. Folgende Infrastruktur 1 Server 2012 Synology 4 Windows 7 ...

Vmware

VMWare 6 verliere Verbindung zu Lun

gelöst Frage von Pageman262Vmware8 Kommentare

Hallo liebe Leute, ich bin am Ende meiner Weisheit. Ich habe 3 Hosts (1 VM6 uns 2 VM3). Ausserdem ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 2 TagenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 2 TagenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 3 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein interessanter Beitrag dazu: Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10 Anscheinend ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 3 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1015 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL14 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)11 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs11 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...