Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verwendung von Agestore

Mitglied: steirom

steirom (Level 1) - Jetzt verbinden

23.11.2011, aktualisiert 22:04 Uhr, 2001 Aufrufe, 5 Kommentare

Agestore funktioniert nicht so wie beschrieben

Guten Abend,

kennt bzw. nutzt jemand Agestore aus den Debugging Tools von Microsoft? Habe mir das Programm und die Anleitungen von Microsoft heruntergeladen. Leider funktioniert das Programm nicht so wie gewünscht.

Vielleicht kurz zur Erklärung. Agestore ist ein Commandline-Tool zur Überprüfung und Leerung von Verzeichnissen anhand bestimmter Kriterien (z.B. lösche alle Dateien die älter als 30 Tage sind oder lösche die jeweils älteste Datei, wenn nicht mindesten xxx MB Platz im Verzeichnis vorhanden sind).
Ich möchte das Programm vorgelagert zu einer Datensicherung nutzen, um sicherzustellen, dass immer genug Platz für die nächste Sicherung vorhanden ist.

Mit dem Befehl: agestore X:\ -size=1073741824 soll eigentlich bewirken, dass Agestore prüft, ob mindestens 1000MB freier Speicherplatz auf Verzeichnis X:\ vorhanden, wenn nicht soll mit den ältesten Dateien begonnen werden zu löschen, bis mindestens 1000MB freier Speicherplatz zur Verfügung stehen.

1. Bei einem Test mit 1500MB freiem Speicherplatz gibt Agestore folgende Meldung vor dem Start aus: "X: contains 0 bytes, 1073741824 bytes is desired, are you sure you want to delete files in X:? (y/n)"

2. Bei einem Test mit 500MB freiem Speicherplatz gibt Agestore dieselbe Meldung vor dem Start aus, macht aber letztendlich nichts, sodass meine Datensicherung wegen zu wenig Speicherplatz abbricht.

Was bedeutet "Contains 0 Bytes"? und warum möchte Agestore im ersten Beispiel Dateien löschen, wenn genug Speicherplatz vorhanden ist und warum löscht Agestore nicht, wenn es notwendig ist?


Viele Grüße
Robert
Mitglied: Indrador
24.11.2011 um 08:04 Uhr
Guten Morgen,

Versuch mal bitte folgenden Befehl:

agestore x:\ -size=1073741824 -l

mit dem -l schalter erzeugt das Programm eine Fileliste, die er löschen würde. Kommt da irgendwas raus?

Gruß
Bitte warten ..
Mitglied: steirom
24.11.2011 um 10:42 Uhr
Hallo Indrador,

es kommt genau dieselbe Meldung wie oben geschrieben, unabhängig davon ob genügend oder zu wenig Platz frei ist. Wenn zu wenig Patz ist, müsste Agestore ja tätig werden, gibt aber keine zu löschenden Dateien aus und löscht dann natürlich auch nichts. Mein Sicherungsprogramm bricht dann logischerweise mit Fehler ab, da nicht genügend Platz im Ziel frei ist.
Bitte warten ..
Mitglied: Indrador
24.11.2011 um 15:43 Uhr
Zitat von steirom:
Hallo Indrador,

es kommt genau dieselbe Meldung wie oben geschrieben, unabhängig davon ob genügend oder zu wenig Platz frei ist. Wenn
zu wenig Patz ist, müsste Agestore ja tätig werden, gibt aber keine zu löschenden Dateien aus und löscht dann
natürlich auch nichts. Mein Sicherungsprogramm bricht dann logischerweise mit Fehler ab, da nicht genügend Platz im Ziel
frei ist.

Eine Idee hätte ich noch, hast du files auf x:\ liegen oder liegen die in Subdirectories?
Wenn die Dateien nicht plan auf X:\ liegen musst du -s benutzen
agestore x:\ -size=1073741824 -s

http://msdn.microsoft.com/en-us/library/ff538006%28v=vs.85%29.aspx

Gruß
Bitte warten ..
Mitglied: steirom
24.11.2011 um 16:33 Uhr
Hallo Indrador,

hab die Parameter alle schon durch. Dachte auch schon die Files müssen in einem Unterverzeichnis liegen, hat aber aich nicht geholfen.

Grüße
Robert
Bitte warten ..
Mitglied: Indrador
25.11.2011 um 09:00 Uhr
Zitat von steirom:
Hallo Indrador,

hab die Parameter alle schon durch. Dachte auch schon die Files müssen in einem Unterverzeichnis liegen, hat aber aich nicht
geholfen.

Grüße
Robert

Hi Robert,

hmmmm das ist wirklich faszinierend, bei mir funktioniert es tadellos, allerdings auf Laufwerk
D:\ mit Unterordnern aber das sollte keinen Unterschied machen.

Da bin ich leider grade ratlos.

Gruß
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Verwendung Twinax
gelöst Frage von Philipp711Switche und Hubs5 Kommentare

Hallo, dies ist eine Anschlussfrage an folgenden Eintrag: Kurzfassung: Wir planen einen neuen Hyper-V-Cluster mit 3 Nodes und einem ...

Windows Server

Verwendung lokal angeschlossener Geräte

Frage von raba34Windows Server17 Kommentare

Liebe Gemeinde, ich möchte in einer RDP-Sitzung (PC mit Windows 10 Pro -> Windows Server 2012 R2) die Verwendung ...

Batch & Shell

Stringsoperation unter Verwendung von Variablen

gelöst Frage von tegwertBatch & Shell1 Kommentar

Hallo zusammen! Mit folgendem Script verändere ich den Inhalt einer Variable : Das Ergebnis "istein" wird korrekt ausgegeben. Nun ...

Windows 10

JAVA Verwendung protokollieren

Frage von lcer00Windows 102 Kommentare

Hallo zusammen, Bin gerade beim aufräumen. Kann man ermitteln, wer zum Teufel das auf dem PC installierte Java nutzt ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 6 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 7 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 10 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...