Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VLAN Konfiguration Verständnis

Mitglied: kalle007

kalle007 (Level 1) - Jetzt verbinden

05.07.2011, aktualisiert 18.10.2012, 16096 Aufrufe, 4 Kommentare, 1 Danke

Hallo Administrator Forum,

ich habe einige Fragen an euch. Ich hoffe Ihr könnt mir behilflich sein.

Ich habe noch nicht sehr viel mit VLANS gearbeitet und habe eine Verständnis Frage an euch.

Ich habe bis jetzt mit HP Switchen gearbeitet. Dort ist die Syntax recht einfach.

Wenn man ein Port antagged haben möchte, geht man in das gewünschte VLAN und schreibt " untagged 1-3, 5-10" oder das selbe mit tagged.

Aber wir haben jetzt ein Cisco Switch bekommen. Dort ist das bisschen anders.

Ich habe auch ein bisschen bei Cisco gelesen aber irgendwie verstehe ich das nicht ganz.

Kann mir vielleicht jemand in kurzen Worten erklären was folgende Befehle bedeuten.

switchport mode trunk
switchport access vlan 2
switchport trunk allowed vlan 4
switchport mode access
no switchport access vlan 1
switchport trunk pruning vlan 2
switchport trunk native vlan 3
!


Wann ist ein Port untagged bzw /tagged ?
Mitglied: aqui
05.07.2011, aktualisiert 18.10.2012
switchport mode trunk
A: Damit wird dieser Port ein Port der alle VLANs aus der VLAN Database dort tagged überträgt !

switchport access vlan 2
A: Dieser Port arbeitet untagged in VLAN 2

switchport trunk allowed vlan 4
A: Auf diesem Port werden ausschliesslich tagged Frames aus dem VLAN 4 übertragen alle anderen VLANs nicht

no switchport access vlan 1
A: VLAN 1 untagged Access wird abgeschaltet (ist immer per Default dran)

switchport trunk pruning vlan 2
A: An diesem Trunk wird alles außer VLAN 2 tagged übertragen, Das "inverse" zu "allowed vlan 4"

switchport trunk native vlan 3
A: An diesem Trunk Port (tagged Port) wird alles was untagged reinkommt ins VLAN 3 geforwardet statt ins VLAN 1 (was der Default wäre).

Zu deiner Frage wann ein Port tagged oder untagged ist:
Bei einem switchport trunk Kommando ist es immer tagged ! switchport access xy oder switchport mode access ist er immer untagged. (Siehe auch u.a. Command Line Reference) !
Alle detailierten Beschreibungen zu diesen Kommandos findest du im Switch Command Line Reference auf der Cisco Webseite z.b.:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/rele ...

Eine vergleichende HP zu Cisco Konfig findest du u.a. auch hier im Forum unter:
https://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
und
https://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...

Ein Beispiel für einen HP Zu Cisco Kopplung sähe dann so aus:

948de2822c40710812e53fa19a07420f - Klicke auf das Bild, um es zu vergrößern

Die dazu korrespondierenden Switch Konfigs:
Cisco Switch:
Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface FastEthernet0/24
description Tagged Link zum HP Procurve
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
description Enduser Ports in VLAN 1
switchport access vlan 1
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Ports in VLAN 2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/12
description Enduser Ports in VLAN 3
switchport access vlan 3
spanning-tree portfast
!

HP ProCurve Switch:
HP_Switch#

time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 24
name "VLAN Tagged Link zum Cisco Switch"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.254 255.255.255.0
exit
vlan 2
name "VLAN-2"
untagged 11
tagged 24
exit
vlan 3
name "VLAN-3"
untagged 12
tagged 24
exit

ACHTUNG: Es lautert noch eine sehr gefährliche Falle im Detail wenn du gerade mit HP Produkten ein redundantes Szenario aufbaust mit Spanning Tree !!
Cisco hat per Default PVSTP+ aktiviert. Ein per VLAN Spanning Tree verfahren was andere BPDU Multicast Mac Adressen benutzt als der Rest der Switchwelt. Viele andere Premium Switchhersteller (wie z.B. Brocade, Extreme usw.) passen sich dem an wenn sie Cisco BPDUs an einem Link sehen. Nicht aber HP, die nur ein einfaches und primitives Single Span Verfahren global über alle VLANs implementiert haben !
HP supportet in seinem ProCurve Billigsektor generell KEIN per VLAN Spanning Tree Verfahren PVSTP oder PVSTP+ und in redundanten Netzwerk Designs kommt es somit immer zu ernsthaften STP Problemen mit teilweise nicht funktionierenden Netzen wenn man unwissentlich diese STP Verfahren mischt !!
Hier hilft dann nur STP auf dem HP generell auszuschalten und es vom Cisco "durchzuschleifen" oder sich auf das kleinste Gemeinsame zu einigen, das ist MSTP (Multiple Spanning Tree) was Cisco und HP supporten. Vorsicht aber auch hier: Nicht alle Billigst Procurves von HP supporten MSTP ! Also immer "Augen auf" in redundanten Designs mit gemischter HP / Cisco Hardware oder generell nicht Cisco PVSTP+ konformen Switches mit Cisco Switch HW !
Ein redundantes Szenario sieht z.B. so aus:

cbd02541153fdaf4376026b03fd512a5-switchnetz - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: kalle007
05.07.2011 um 13:27 Uhr
Hallo aqui,

verdammt, das war mal eine ausführliche Antwort. Jetzt sind alle meine Fragen beantwortet. Ich danke dir...

Der Beitrag ist dann gelöst...
Bitte warten ..
Mitglied: kalle007
11.07.2011 um 15:52 Uhr
Hallo aqui,

ich hätte doch nochmal eine Frage an dich, jetzt ist noch ein alter Netgear Switch aufgetaucht.
Dort habe ich folgendes:

switchport access vlan untagged 5
switchport access vlan untagged 101
switchport access vlan tagged 102
switchport access native 5

die letzte Zeile wäre mein Problem, dort steht jetzt anstatt Trunk | access, also wieder anders wie bei einem Cisco.

switchport trunk native vlan
switchport access native 5

Was hätte das für eine Bedeutung ?
Bitte warten ..
Mitglied: aqui
11.07.2011 um 22:09 Uhr
Normalerweise hängt an einen Trunk also an einem Port wo getaggte VLANs draufhängen IMMER das default VLAN untagged mit drauf.
Sprich: alle Pakete die untagged an diesem Port ankommen werden ins Default VLAN geforwardet. In der Regel ist das immer das VLAN 1 wenn man nichts anderes konfiguriert.

Mit dem o.a. Kommando switchport access native 5 werden alle untagged Packete an diesem Port statt ins VLAN 1 dann ins VLAN 5 geforwardet !
switchport trunk native vlan bedeutet nur das überhaupt an diesem tagged Port untagged Frames verstanden werden. Wäre das nicht da würde der Switch untagged Paketet vollkommen ignorieren am tagged Port !
Eigentlich ganz easy...
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen

Verständnis Frage VLAN und default VLAN , tagged und untagged

gelöst Frage von DerHahntrutNetzwerkgrundlagen6 Kommentare

Hallo Ich habe eine Frage zu VLAN bzw default VLAN. Beispielszenario: 2 Switches werden mit 3 VLAN verbunden. Trunk ...

LAN, WAN, Wireless

Konfiguration von VLANs

gelöst Frage von eisenbiegerLAN, WAN, Wireless5 Kommentare

Hallo, ich habe mich gerade erst hier registriert, da ich gerade nicht mehr weiter komme. Bereits früher habe ich ...

LAN, WAN, Wireless

Frage zur VLAN Konfiguration

Frage von HamsertLAN, WAN, Wireless8 Kommentare

Hallo liebe Kollegen, da VLANs für mich (wie für Frau Merkel das Internet ;-)) noch völliges Neuland sind wende ...

Router & Routing

VLAN Konfiguration über Telnet

Frage von d3rChri5Router & Routing1 Kommentar

Hallo liebe Community, ich habe aus Leistungsgründen auf einen Router der Firma Linksys (WRT320N) gewechselt. Die Standard Router Software ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs9 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Debian
Wie finde ich den betroffenen user
Frage von ProtectedDebian8 Kommentare

Hallo, Wie kann ich den User finden der dies verursacht hat? Betriebsystem ist Debian 7 your Server/Customer with the ...

Voice over IP
Vodafone IP Anlagenanschluss - TK-Anlage einrichten
Frage von BytedreherVoice over IP8 Kommentare

Moin Zusammen, wir hatten gestern bei uns die Umstellung auf den neuen IP Anschluss bei Vodafone. Vodafone IP Anlagenanschluss ...