Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VLAN Konfigurations-Problem

Mitglied: Vmwaretester

Vmwaretester (Level 1) - Jetzt verbinden

08.10.2013 um 10:56 Uhr, 2106 Aufrufe, 8 Kommentare, 1 Danke

Hallo zusammen!

ich habe ein Problem mit der Konfiguration von VLANs. Etwas vereinfacht dargestellt habe ich einen Switch mit 48 Ports (Dell 5548) und eine Firewall.
Der Switche soll folgende Konfiguration bekommen:

Port 1 bis 41 = Default VLAN ID 1
Port 42 = VLAN ID 2
Port 43 bis 48 = VLAN ID 3 und VLAN ID 3

Der Port 42 hängt an einer Firewall die wiederum keine gettagten Packete erwartet, da an dem Firewall-Port kein VLAN konfiguriert ist

Nun sollen Pakete mit der VLAN ID 2 von den Ports 43-48 über den Port 42 zur Firewall gelangen.

Konfiguriert habe ich auf den Ports 43- 48 Tagged VLAN ID 2 und ID 3 (Dell Einstellung: generell)

Eigentlich müsste ich den Port 42 als Untagged mit VLAN ID 2 konfigurieren, aber ich kann dann nicht zwischen Port 42 und den Ports 43-38 einen Ping-Test machen. Erst wenn ich den Port 42 auf tagged VLAN ID2 setzte, kann zwischen den Ports pingen, aber dann kommen scheinbar meine Pakete nicht zur Firewall.

Habe ich eine Denkfehler gemacht?
Mitglied: Yannosch
08.10.2013 um 11:14 Uhr
Merken musst du dir folgende Regel: TAGGED -> TAGGED ; UNTAGGED ->UNTAGGED ...
Sollte es eine Portbasierende VLAN Geschichte sein (und danach sieht es aus) macht das TAGGEN von Pakten nur Sinn wenn du einen sogenannten Trunkport betreibst, sprich: Ein Port über den mehrere VLAN's laufen die Gegenstelle, Beispielweise ein Layer 3 Switch oder Router muss ebenfalls ein trunk, mit den selben VLAN'S haben.

Was hängt denn bei dir an Port 43-48 tagged ? .... Also Pakete von welchem Device sind zu erwarten ?
Bitte warten ..
Mitglied: Vmwaretester
08.10.2013, aktualisiert um 11:49 Uhr
Hallo Yannosch, Danke für Deine Antwort. Im Grunde genommen baue ich eine Konfiguration eines HP-Switches (2900-24G) nach, der ersetzt werden soll.
Dort war der Firewallport (Port 17) auf Untagged VLAN ID 2 gesetzt und die Port2 18-20 haben Tagged VLAN ID 2 und VLAN ID 3

An den Dell Ports 43-48 (bzw. bei HP 18-20) liegen VMWare ESX-Server und zwar die Netzwerkkarten einer DMZ mit VLAN ID 2 und VLAN ID 3. Die VLAN ID 3 soll nur zwischen den Ports 43-48 verfügbar sein (das funktioniert). Über die VLAN ID 2 soll von den VmWareServern SMTP-Traffic über Port 42 an die Firewall gesendet werden.

Wenn ich Deine Regel so interpretiere, dass Tagged nur über Tagged Ports geht, frage ich mich allerdings wie das bisher mit dem HP funktioniert?
Bitte warten ..
Mitglied: Yannosch
08.10.2013, aktualisiert um 12:01 Uhr
Vielleicht irgendwo ein geringfügiger Unterschied in der Konfiguration ... also angenommen:

SWTICH A (port 48, vlan 1,3,8,10 tagged) SWITCH B (port 47, vlan 1,3,8,10 tagged)
[x_x_x_x_x_x_]----------------------------------------------[x_x_x_x_x_x_]

Wenn nun also ein Kabel zwischen Switch A p. 48 und Switch B p.47 liegt dann müssen die Pakete getagged werden auf beiden Seiten.
Sollte also ein mit vlan 3 getaggtes Packet von Switch A zu Switch B gesendet werden, dann kann das Paket auf Switch B NURNOCH von den Ports verarbeitet werden die das VLAN 3 als untagged drinhaben ...

Ich glaube du musst die Logik dahinter nochmal genauer durchleuchten ...

Liebe Grüße von
Y@nnosch!
Bitte warten ..
Mitglied: Vmwaretester
08.10.2013, aktualisiert um 12:15 Uhr
Hm, weiß jetzt auch nicht so recht weiter.
Mal grundsätzlich gefragt, wenn meine Firewall, die auf Port 42 liegt, keine getaggten Pakete erwartet, dann müsste ich den Port 42 doch auf Untagged stellen, oder?
Bitte warten ..
Mitglied: Yannosch
08.10.2013, aktualisiert um 12:47 Uhr
Meines Wissens nach schon ... Probieren geht über studieren ...
Stell den Port mal auf Untagged und sag mir dann ob es funktioniert ...

Liebe Grüße von
Y@nnosch!
Bitte warten ..
Mitglied: Vmwaretester
08.10.2013, aktualisiert um 12:58 Uhr
Unttaged hatte ich den Port 42 schon gestellt, aber dann funktionierte eben das Pingen zwischen den Ports 42 und 43-48 nicht mehr (was bei der Einstallung Tagged funktioniert). Dell unterscheidet allerdings auch noch den "Port VLAN Mode". Hier gibt es noch Einstellungen u.A. zwischen "General" und "Access". Vielleicht liegt hier das Problem?

Probieren kann ich es erst wieder die Tage
Bitte warten ..
Mitglied: Yannosch
08.10.2013 um 13:27 Uhr
Höchstwarscheinlich, weil du meiner Meinung nach versuchst das ganze VLAN basierend zu machen ... Dann müsste Port VLAN aktiviert sein ... aber dann wird es wieder gerätespezifisch ... Probiers nochmal aus und spiel halt ein wenig mit den Parametern ...

Meld' dich mal

Liebe Grüße von
Y@nnosch!
Bitte warten ..
Mitglied: holyone
08.10.2013 um 13:35 Uhr
Hallo,
schau dir mal das Manual des Switches genauer an.
Und gucke mal was die Modes und die restlichen Einstellungen genau machen. Dann gehe logisch vor und versuche das was du über VLANs weißt in DELL-Sprache umzusetzen.

Hier z.B. ein Absatz zum General Mode aus dem Manual:
Ports set to General mode may be members of multiple VLANs. Each of these VLANs may be configured to be tagged or untagged. This setting applies to transmitted frames. Incoming untagged frames are classified into the VLAN whose VID is the currently configured PVID.

RTFM ist bei VLAN konfigurationen in heterogenen Netzwerk-Infrastrukturen immer angebracht.

Also mein Rat:
Lies dir die VLAN-Konfigurationsmöglichkeiten im Handbuch des Switches genau durch.

Gruß,
holyone
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Problem mit der VLAN Konfiguration
Frage von Maik20LAN, WAN, Wireless4 Kommentare

Hallo, ich sitze gerade vor meiner ersten VLAN-Konfiguration und brauche eure Hilfe. Kurz zur Infrastruktur: Switch 1: TP-Link SG2424 ...

LAN, WAN, Wireless
Konfiguration von VLANs
gelöst Frage von eisenbiegerLAN, WAN, Wireless5 Kommentare

Hallo, ich habe mich gerade erst hier registriert, da ich gerade nicht mehr weiter komme. Bereits früher habe ich ...

LAN, WAN, Wireless
Frage zur VLAN Konfiguration
Frage von HamsertLAN, WAN, Wireless8 Kommentare

Hallo liebe Kollegen, da VLANs für mich (wie für Frau Merkel das Internet ;-)) noch völliges Neuland sind wende ...

Netzwerkmanagement
VLAN Konfiguration Gast-WLAN
gelöst Frage von gt1988tgNetzwerkmanagement2 Kommentare

Guten Tag! Wir haben ein Netzwerk mit der IP 10.0.0.1/21. Es sind Netgear Managed Switche vorhanden. Der Internetzugang geschieht ...

Neue Wissensbeiträge
Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 2 TagenAusbildung35 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 4 TagenSpeicherkarten5 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 4 TagenSicherheit1 Kommentar

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 5 TagenHardware4 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Passwortwechsel Zeitpunkt festlegen
Frage von Looser27Windows Userverwaltung27 Kommentare

Guten Morgen liebe Kolleginnen und Kollegen, da es eine Userin in meinem Urlaub geschafft hat, sich vom AD vollständig ...

Windows Server
Probleme im AD am Außenstandort
gelöst Frage von emeriksWindows Server19 Kommentare

Hi, wir haben ein Problem mit AD und GPO am Außenstandort und ich stehe momentan mächtig auf dem Schlauch. ...

Switche und Hubs
POE-Switche
gelöst Frage von MiStSwitche und Hubs13 Kommentare

Guten Morgen, ich überlege ob ich in unserem Netzwerk die aktuellen Switche (D-LINK DGS-1210-28) durch PoE-Switche ersetzen soll. Der ...

Windows Server
DNS - Bedingte Weiterleitung
gelöst Frage von m8ichaelWindows Server11 Kommentare

Guten Tag zusammen, ich stehe gerade bzgl. einer bedingten DNS-Weiterleitung etwas auf dem Schlauch: Ich möchte, dass für bestimmte ...