Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

W2K-Client und NT 4-Server: IFMEMBER funktioniert nicht

Mitglied: K3

K3 (Level 1) - Jetzt verbinden

28.12.2004, aktualisiert 16:07 Uhr, 8482 Aufrufe, 7 Kommentare

Folgendes Problem habe ich:

In einem NT 4-Netz sollen die NT-Clients auf W2K aufgerüstet werden. Einen habe ich jetzt probehalber umgestellt.

Mittels einer Batch-Datei und dem Befehl "IFMEMBER" werden den Benutzern in Abhängigkeit ihrer Gruppenzugehörigkeit Laufwerke auf dem NT-Server gemappt.

Auf den NT-Clients funktioniert das vorzüglich.

Der W2K-Client erkennt aber diesen Befehl nicht, wenn sich eine normaler Domänen-Benutzer anmeldet. Die Fehlermeldung lautet etwa: "Befehl nicht bekannt oder falsch geschrieben".

Seltsamerweise funktioniert das Mappen aber problemlos, wenn ich mich als Domänen-Admin anmelde.

Zunächst dachte ich, daß es daran liegt, daß ich den Befehl "IFMEMBER" nicht installiert hatte. Dies habe ich nachgeholt, aber ohne Ergebnis.

Hat jemand eine Idee, wo der Fehler liegen könnte?

Hinzufügen muß ich noch, daß ich mich bisher nicht mit der Administration von W2K-Netzen befaßt habe, da das NT-Netz bisher problemlos lief und ich deshalb keine Notwendigkeit zu einer Änderung sah.

Vielen Dank für Tips,

K3
Mitglied: Atti58
28.12.2004 um 13:01 Uhr
... Du solltest uns schon mal die gesamte Zeile Deines Batchaufrufes zu Verfüguing stellen, so werden wir Dir nur bedingt helfen können ...

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 14:57 Uhr
Bitte:

ECHO OFF
REM Nachfolgend werden die Laufwerksverbindungen beim Start
REM in Abhaengigkeit von der Gruppenzugehoerigkeit gesetzt.

IFMEMBER ADMINISTRATOREN
if not errorlevel 1 goto weiter
IF EXIST V: NET USE V: /DELETE
NET USE V: \\NEU01\C$ /PERSISTENT:NO

:weiter
IFMEMBER Benutzer
if not errorlevel 1 goto weiter
IF EXIST Z: NET USE Z: /DELETE
NET USE Z: \\NEU01\ALLE_USER /PERSISTENT:NO

:weiter
IFMEMBER DATENBANKEN
if not errorlevel 1 goto weiter
IF EXIST Y: NET USE Y: /DELETE
NET USE Y: \\NEU01\DATENBANKEN$ /PERSISTENT:NO

usw.

:weiter

REM Ende der Datei


Der Pfad auf dem NT-Server ist:

\\WINNT\System32\Repl\Import\Scripts\LWV.BAT


Benötigt Ihr noch weitere Informationen?

K3
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 15:09 Uhr
Das ist doch schon ein wenig mehr , jetzt sollten wir herausbekommen, wann Deine Fehlermeldung erzeugt wird. Nimm einfach mal nur die ersten beiden Teile in eine eigene Batch:

REM ECHO OFF
REM Nachfolgend werden die Laufwerksverbindungen beim Start
REM in Abhaengigkeit von der Gruppenzugehoerigkeit gesetzt.

IFMEMBER ADMINISTRATOREN
pause
if not errorlevel 1 goto weiter
pause
IF EXIST V: NET USE V: /DELETE
pause
NET USE V: \\NEU01\C$ /PERSISTENT:NO
pause

:weiter
IFMEMBER Benutzer
pause
if not errorlevel 1 goto weiter
pause
IF EXIST Z: NET USE Z: /DELETE
pause
NET USE Z: \\NEU01\ALLE_USER /PERSISTENT:NO
pause

:weiter


mache eine Eingabeaufforderung auf und starte diesen neuen Batch-File dort und sage mir, an welcher Stelle die Fehlermeldung kommt,

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 15:30 Uhr
Direkt am Anfang kommt die Fehlermeldung "Der Befehl "IFMEMBER" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Das läuft dann so weiter.
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 15:46 Uhr
... da müsste man nun wissen, was dieses Tool so macht und welche "Vorgaben" es finden muss - bist Du sicher, dass das Programm Win2k-geeignet ist? Hast Du schon mal nach einer neueren Version gesucht?

In welchem Verzeichnis liegt denn "IFMEMBER" - kopiere es doch mal nach C:\Winnt\system32" wenn es unter Win2k funktioniert, solte es hier garantiert gefunden werden ...

Gruß

Atti
Bitte warten ..
Mitglied: K3
28.12.2004 um 15:57 Uhr
Hei, genau das war das Problem!

Das Programm IFMEMBER.EXE stand unter C:\Programme\ResourceKit... usw.!

Da hat W2K es nicht gefunden.

Ich habe es gemäß Deinem Rat nach C:\Winnt\system32 kopiert und siehe da: Jetzt geht es!

Vielen Dank! Du hast mir sehr geholfen!

Viele Grüße,

K3
Bitte warten ..
Mitglied: Atti58
28.12.2004 um 16:07 Uhr
... gut Ding will Weile haben , es war zwar eine nicht ganz einfache Geburt, danke aber auch an Dich, dass Du den Erfolg bestätigst,

guten Rutsch,

Atti
Bitte warten ..
Ähnliche Inhalte
Windows Server

Vom Server auf Client drucken, funktioniert nicht

Frage von StewieWindows Server6 Kommentare

Hallo Admins, ich habe folgendes Problem. Wir haben einen Windows Server 2016 (Datacenter) über 1und1 gemietet. Jetzt will ich ...

Virtualisierung

4 Server auf einen Server realisieren

gelöst Frage von UsogulVirtualisierung11 Kommentare

Hallo zusammen! Zuerst einmal möchte ich kurz erwähnen, dass ich kein ausgebildeter bzw. qualifizierter Administrator bin. Ich betreue unser ...

Windows Server

Faxserver funktioniert vom Client aus nicht richtig

Frage von CharlyXLWindows Server9 Kommentare

Hallo zusammen, ich habe einen Windows Server 2012 R2, ohne Domäne und ein paar Clients. Auf dem Server hab ...

Backup

Amanda-Client unter Ubuntu funktioniert nicht

gelöst Frage von PertinaxoBackup1 Kommentar

Guten Tag zusammen, ich habe ein kleines Problem mit der Einrichtung des "amanda-client" auf Ubuntu Ebene. Unser Amanda Backup ...

Neue Wissensbeiträge
Windows Server

SBS 2011: Installation von KB4457144 schlägt beim Reboot fehl - Von Dienst gesperrte Schriftart ursächlich

Tipp von the-buccaneer vor 4 StundenWindows Server

Moinsen zusammen! Das hat mich einige graue Haare gekostet: Ein SBS 2011 weigerte sich schon im August, das monatl. ...

Windows Netzwerk
Browser-Lags und IPv6
Erfahrungsbericht von NixVerstehen vor 10 StundenWindows Netzwerk1 Kommentar

Hallo zusammen, wir betreiben als kleines Speditionsunternehmen ein überschaubares Windows-Netzwerk mit Win10-Clients sowie einem Server 2016 Essentials als "eierlegende ...

Humor (lol)

Erstaunlich, Windows mit extremer Laufzeit (Server) lol

Tipp von mathu vor 12 StundenHumor (lol)5 Kommentare

Was es so alles gibt. :-)

Windows Netzwerk

CGM Praxisarchiv funktioniert auf Clients nach Update auf 4.14 nicht mehr

Tipp von MOS6581 vor 1 TagWindows Netzwerk

Moin, ein Kunde setzt das CGM-Praxisarchiv ein. Mehrplatzinstallation mit SQL-Server. Nachdem letzte Woche auf die 4.14 aktualisiert wurde, funktionierte ...

Heiß diskutierte Inhalte
Hyper-V
Windows Serer 2016 Standard virtualisieren
gelöst Frage von fritte87Hyper-V33 Kommentare

Hallo zusammen, ich muss für eine kleine Firma ein entsprechendes neues kleines Konzept bauen. Ich habe einen Server Standard ...

LAN, WAN, Wireless
Kombiniere mehrere 4G Router zu einem Netzwerk - Anwendung kleine LAN (10-20 Leute)
Frage von HulkTheHeroLAN, WAN, Wireless24 Kommentare

Guten Mittag liebes Administrator - Fourm, ich hoffe ich habe das richtige Thema ausgewählt - ansonsten bitte gerne verschieben ...

Windows Server
Fileserver von 2012 R2 auf 2012R2
gelöst Frage von ThabeusWindows Server23 Kommentare

Moin moin, leider war in der Vergangenheit der Fokus des Betriebs nicht auf Langfristigkeit ausgelegt. Daher stehe ich jetzt ...

Router & Routing
Größere Zahl VPN-Verbindungen mit Fritz-Box einrichten
Frage von miscmikeRouter & Routing15 Kommentare

Hallo Zusammen, ich supporte verschiedene Kunden mit bestehenden LAN-LAN-Kopplungen via FritzBox (7490, FritzOS 7.01) . Anwendungen sind z.B. Kaspersky-KSC ...