Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

W2K3-Userscript kopiert Starmenüeintrage ins falsche Profil (trotz %username%)

Mitglied: Labamba0704

Labamba0704 (Level 1) - Jetzt verbinden

25.07.2006, aktualisiert 27.07.2006, 3981 Aufrufe, 8 Kommentare

Hallo.

Ich weise den Benutzern auf meinem windwos 2003 Server per GPO Scripte zu. Im folgenden sieht das script so aus:

xcopy "\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk" "C:\Dokumente und Einstellungen\%username%\Startmen\GFUB\INFO\" /y /i


trotzdem haben die Benutzer keinen Eintrag im Startmenü. ein gpresult auf den Clients zeigt an das die GPO angewendet wird.
An einem Clientcomputer findet man auch unter dokumente und Einstellungen und dann im entsprechenden Profil den startmenüeintrag.

anscheinend ist das startmenü nicht dasselbe was der user eigentlich benutzt.

Als Zusatzinfo: Es ist eine Domäne, wir haben servergespeicherte Profile und die Benutzer können manuell Einträge im Startmenü ändern,löschen,etc.

Einzig bei meinem Rechner klappen die Startmenüscripteinträge

Jemand eine Idee???
Mitglied: Dani
25.07.2006 um 14:30 Uhr
Hi,
könnte an diesem UNC Pfad liegen (\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk").
Hast du das xcopy mal per Hand eingeben bzw. probiert?!


Gruß
Dani
Bitte warten ..
Mitglied: Labamba0704
25.07.2006 um 15:34 Uhr
Führe ich das Script manuell aus (Doppelklick) dann macht er das was ich will.

Was genau meinst du mit dem UNC-Pfad?Was könnte den da nicht stimmen?

Groß/Kleinschreibung beachten oder sowas? Gebe ich den Pfad im Browser ein, komme ich auch zu der Verknüpfung
Bitte warten ..
Mitglied: rc-computer
25.07.2006 um 15:49 Uhr
Koennte es sein das bis zum ausfuehren deiner xcopy sache noch keines der Laufwerke gemappt ist!?

Mit freundlichen Gruessen
- Johannes Matjeschk
Bitte warten ..
Mitglied: Biber
25.07.2006 um 19:18 Uhr
Moin Labamba074,

dumme Frage zu "anscheinend ist das startmenü nicht dasselbe was der user eigentlich benutzt."..
Wieso lässt Du Windows das nicht selbst herausfinden, was das richtige Verzeichnis ist?
Kopiere doch nach "%userprofile%\Startmenü".

Zweitens... wenn das per Doppelklick klappt, aber nicht als Batch, deutet es darauf hin, dass Windows (mit Codepage 1252) und CMD.exe (mit Codepage 850) mit dem "ü" in "Startmenü" eventuell untergehen.
Setz doch mal vor deinen "XCOPY"-Einzeiler mal ein "CHCP 1252" aus Spass.

Drittens ... leite die Ausgabe von XCOPY doch um in eine Logdatei auf dem Server.. im Erfolgs- und im Misserfolgsfall.

Beispiel:
...
chcp 1252
xcopy ....quell-Link.. "%userprofile%\Startmenü\Bla\" >>serverxy\logs\myclients.log
echo %date% %computername% %username% xCopy-Ergebnis: [%errorlevel%]>>serverxy\logs\myclients.log
....

Gruß
Biber
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 09:25 Uhr
Hallo,

ich habe das Script jetzt mit %userprofile% abgeändert. Gab keinerlei Veränderungen zu vorher mit %username% (ausser das der pfad im script logischerweise etwas kürzer ist)

CHCP 1252 habe ich nun auch vorran gestellt, sowie die ausgabe von xcopy umgeleitet in eine log datei.

Es ist weiterhin alles wie zuvor. in der logdatei gibt es keine fehlermeldung.

Melde ich mich an (Userkennung gfub1012) steht in der logdatei:

27.07.2006 CFBK0032 gfub1012 xCopy-Ergebnis: [0]
\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk
1 Datei(en) kopiert

Melde ich mich als ein User an für den ebenfalls die Gruppenrichtlinie mit den script gilt (mit gpresult überprüft) bekommt er dieselbe meldung nur mit seiner kennung halt (statt gfub1012 kommt gfub1002).


Das kuriose ist das der 1002 Benutzer unter dokumente und einstellungen usw den gewünschten ordner im startmenü hat, also wird korrekt kopiert von dem script. der ordnername lautet:

c:\dokument.....usw\gfub1002\Startmenü\GFUB

Trtozdem ist dieser Eintrag nicht in seinem Startmenü drin. ein Echo %userprofile% sagt c:\doku...usw\gfub1002, also passt das eigentlich. Trotzdem ist nichts im Startmenü (wenn man auf start klickt) zu sehen.


melde ich mich an (gfub1012) habe ich unter c:\dokumen...usw ebenfalls die korrekten einträge (nur mit gfub1012 halt). bei mir hingegen steht der Eintrag GFUB in meinem startmenü, wenn ich auf start klicke.


ich weis nicht mehr weiter. normalerweise gehe ich davon aus das wenn ich als benutzer xyz angemeldet bin, die einträge unter c:\doku..usw\xyz\startmenü für den user xyz gelten.


INTERESSANTER NACHTRAG!!!

ich habe gerade das script mal kurz abgeändert, also den eintrag startmenü gegen desktop getauscht und siehe da, bei allen von der gpo betroffenen usern wird der ordner auf den desktop kopiert. also kann man schonmal sagen das es am startmenü liegt, oder?

ich freue mich auf eure meinungen
Bitte warten ..
Mitglied: Biber
27.07.2006 um 09:37 Uhr
..dann ist es ein Zeichensatz-Problem wie vermutet. (das "ü" in Startmenü")

Ändere bitte mal den Zilepfad um in:
"%userprofile%\Startm~1\bla"

[sieht zwar krank aus, könnte aber helfen.]

Wenn das hilft, dann solltest Du mal in der Mittagspause am CMD-Prompt testen, wie denn dort der Ordner "Startmenü" angezeigt wird. Also ein "DIR %userprofile%\*" eingeben.
Und dann mit CHCP 850/ CHCP1252/ probieren, mit welchem Zeichensatz ein "ü" statt einer hochgestellten Drei angezeigt wird.

Gruß
Biber
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 10:10 Uhr
ich weis nicht was du mit cmd-prompt meinst. aber ich habe auf dem server per konsole (cmd) mir die schreibweise von startmenü angeschaut. wurde überall mit korrekten ü angezeigt.

ebenso habe ich das per cmd an einem client getestet, dasselbe ergebnis, alles korrekt mit ü.

ich bin aber auf ein interessantes detail gestoßen.

alle user wo das script nicht zu klappen scheint haben in ihrem profil ordner neben dem ordner startmenü noch einen ordner start menu.

ich hingegen (bei dem das script korrekt ausgeführt wird) habe nur einen startmenü ordner.

habe bereits versucht den star menu ordner zu löschen, der kommt aber immer wieder.

gibt es eine saubere lösung windows davon zu überzeugen nur noch ein startmenü zu nehmen?
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 17:11 Uhr
alles gelöst.

mann muss unter HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

den eintrag Start Menu entsprechend abändern.

danke an alle, nun klappts
Bitte warten ..
Ähnliche Inhalte
Microsoft Office

Text nach Änderungen im Änderungsmodus weg und falscher username

Frage von wasserfrauMicrosoft Office1 Kommentar

Fakt: Existierende Word-Datei wird von einem user im Änderungsmodus verändert (Text hinzugefügt, Text gelöscht). Am nächsten Tag wird gleiches ...

Cluster

Terminalserverfarm zieht falsche Profile

gelöst Frage von Dante2191Cluster4 Kommentare

Hallo zusammen, folgendes: Wir würden in der Firma gerne eine Windows Server 2008 R2 - Terminalserverfarm nutzen. Die Profile ...

Batch & Shell

Username Kontrolle

gelöst Frage von MaxophoniBatch & Shell3 Kommentare

Hallo, ich bin gerade dabei ein Batch Programm zu schreiben. Ich möchte das gleich am Anfang der Benutzername abgefragt ...

C und C++

Spoof Username

gelöst Frage von CloudyC und C++9 Kommentare

Hallo, ich habe hier eine Blöde Software, die rum zickt, falls sie ein anderer Benutzer aufmacht (Sich der Username ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 2 TagenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 4 TagenHumor (lol)10 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 4 TagenExchange Server9 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 5 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
E-Mail
Deutsche e-Mail Adresse auf iPhone in Katar. Nur Probleme
gelöst Frage von vanTastE-Mail32 Kommentare

Moin, ich habe hier in Deutschland auf einem Exchange 2013 eine e-Mail Adresse (name@domain.de) für einen Kollegen in Katar ...

Windows Server
Domäne beitreten nicht möglich, unter VMWare windows Server 2016 Core
Frage von AmanuelWindows Server21 Kommentare

Ich habe auf meinem Mac unter VMWare Windows Server 2016 Core und Windows Server 2016 Desktopversion installiert. Beide Systeme ...

Windows Server
Server verliert Dateien und Ordner
gelöst Frage von routeserverWindows Server18 Kommentare

Hallo Freunde, ich habe hier ein Problem, das mich an meine Grenzen treibt und ich würde gerne wissen, ob ...

Windows Tools
User Self Service und Client Management
Frage von OrkansonWindows Tools14 Kommentare

Hallo zusammen, ich hab ein paar verschiedene Fragen: 1. Was benutzt ihr um Software im Unternehmen zu verteilen? 2. ...