Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WAMP-Installation und MediaWiki 1.20.3 - quälend langsam!

Mitglied: docMario

docMario (Level 1) - Jetzt verbinden

04.04.2013 um 21:40 Uhr, 3488 Aufrufe, 1 Kommentar

Hallo allerseits, als "EDV-Beauftragter" darf ich unser kleines Intranet pflegen. Seit 4 Jahren verrichteten MediaWiki 1.12 und der damals aktuelle XAMPP ganz ordentlich ihren Dienst. Aus diversen Gründen sollte das System nun auf den aktuellen Stand gebracht werden... Leider kriege ich aber die Software nicht ans Laufen ( Ich bin inzwischen am Verzweifeln und hoffe, dass mir hier jemand helfen kann!

Testsystem(e): Windows 8, Windows 7 und Windows XP. Installation auf USB-Stick bzw. portabler Festplatte.
Produktivsystem: Windows Server 2003, SP2 (IIS ausgeschaltet), 4GB RAM


Folgende Installation habe ich neu aufgesetzt: XAMPP 1.8.1 und MediaWiki 1.20.3.

Im Testbetrieb dauerte der Seitenaufbau schon für das "jungfräuliche" MediaWiki teilweise bis zu 5 Sekunden. Nachdem ich die alte MediaWiki Datenbank (collation UTF8_general_ci) über die Kommandozeile exportiert und wieder in die neue Datenbank importiert hatte, alle Plugins aktiviert und die Mediendateien kopiert waren, ging der Seitenaufbau ganz in die Knie...
für bestimmte Artikel und insbesondere beim Abruf von Bild-Dateien (z.B. mit der Adresse localhost/wiki/Bild:xyz.jpg) brauchte MediaWiki teilweise >30 Sekunden! Während dieser Zeit meldete der Browser nur "warten auf localhost..."
Es wurde kein Fehler gemeldet, die Serverlast lag bei ca. 1%. Es ist, als ob der Seitenaufbau über 20 Sekunden einfach "einfriert" und dann normal weiter abläuft...
Ping auf localhost ist <1ms(!). Das Studium der Error- und Debug-Logs brachte mich auch nicht weiter.

Folgendes habe ich zur Problemlösung schon probiert:
- sämtliche Anleitungen/Howtos/troubleshootings gelesen zu den Stichworten: Mediawiki, XAMPP, MySQL, langsam
- in der mysql.ini eingetragen: bind 127.0.0.1
- in der hosts Datei eingetragen: localhost 127.0.0.1
- überall relative Pfade, bzw. überall absolute Pfade angegeben
- MySQL und Apache als Service laufen lassen
- PHP als Modul laufen lassen
- XCache eingeschaltet, ausgeschaltet, neu konfiguriert (neueste XCacheBagOfStuff.php aus dem aktuellen MW-Snapshot geladen)
- XAMPP mit Installer diverse Male neu installiert, MediaWiki neu installiert ... wieder das gleiche Problem
- WampServer2 installiert, MediaWiki drauf ... wieder 30s für den Seitenaufbau
- UniformServer -"- installert .... gleiches Problem
- Aktuellste stable Versionen von MySQL und PHP einzeln heruntergeladen, manuell alles sauber konfiguriert... ohne Verbesserung...

Ich werde bald wahnsinnig!!!

Hat jemand noch einen Tipp für mich, was bei o.g. Konfigurationen schief gelaufen sein könnte?!
Ist der Fehler in der Kombination schon bekannt?

PS: heute Abend bin ich zufällig auf die Distribution "BitNami Stack" (WAMP/MediaWiki) gestoßen, die sich problemlos installieren lies und auf dem Testsystem mit "meinem" Wiki flott läuft.. ich frage mich also, was dort anders konfiguriert ist?!


Vielen Dank im Voraus für die Hilfe!
Herzliche Grüße, docMario
Mitglied: docMario
05.04.2013 um 14:50 Uhr
Ich habe die Lösung gefunden!!! Manchmal sieht man auch den Wald voller Bäume nicht...
Es gab kein Problem mit der Server-Installation, sondern mit der Grundeinstellung

$wgUseInstantCommons=true;

auf dem Testserver ergab dies keinen Fehler, aber auf dem Produktivsystem führte wohl regelmäßig die Abfrage der commons-Server ins Leere und MediaWiki wartete bis zum Timeout auf das Ergebnis...

Nachdem ich $wgUseInstantCommons auf false gesetzt hatte, lief das System wie am Schnürchen...

Naja, jetzt kenne ich den Server immerhin in- und auswändig.
Gruss, Mario
Bitte warten ..
Ähnliche Inhalte
Notebook & Zubehör

ältere HP 8430 Laptops gleichzeitig quälend langsam

gelöst Frage von 114068Notebook & Zubehör3 Kommentare

Hallo, bei 4 Mitarbeitern sind plötzlich deren ältere HP 8430 Laptops quälend langsam. Da die Dinger unabhängig voneinander (und ...

Outlook & Mail

Outlook 2010 nach Installation von Teamviewer langsam

gelöst Frage von CrofexOutlook & Mail6 Kommentare

Hallöchen Wir haben folgende Konstellation: Exch 2013, CAS und DB auf getrennten Servern in Coexistenz mit Exch 2007 da ...

Exchange Server

Workstations sehr langsam nach Installation Server2012 mit Exchange2013

Frage von stefanbifiExchange Server24 Kommentare

Hallo Nach Umstellung von SBS2008 mit Exchange2007 auf Server2012 und Exchange2013 sind die angeschlossenen Workstations (10 Stk.) sehr langsam. ...

Apache Server

Upload Problematik Mediawiki+Apache+PHP

Frage von m3n7orApache Server4 Kommentare

Hallo zusammen, ich beobachte aktuell auf unserem Webserver folgendes Problem. Wenn jemand in einem unserer Wikis eine bestimmte Bild-Datei ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)8 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...