Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Webdav-Einrichtung Server 2008 R2 IIS 7.5

Mitglied: Xaero1982

Xaero1982 (Level 4) - Jetzt verbinden

23.08.2011 um 15:44 Uhr, 19055 Aufrufe, 7 Kommentare

Moin Zusammen,

ich bin gerade am rumbasteln und möchte Testweise einen IIS 7.5 mit Webdav einrichten.

IIS 7.5 + Webdav sind ja beim R2 dabei, also nur als Rolle hinzugefügt.

Dann habe ich mich weiter gehangelt an dieser Anleitung.

Dann habe ich mal im IIS Manager unterhalb der Default Web Site ein virtuelles Verzeichnis angelegt, welches auf den physikalischen Pfad c:\Test verweist.
Dort habe ich einfach mal zum Testen ein paar Daten hinein kopiert und die Verzeichnissuche aktiviert.

Nun bekomm ich ich sowohl über:

Http://localhost/Test
als auch über:
http://ip/Test

Das Verzeichnis aufgelistet. Gut, also der Webserver läuft, aber das sagt ja über Webdav noch nichts aus.

Also hab ich an meiner W7 Kiste erst mal versucht mit Bitkinex eine Webdavverbindung herzustellen:

Server address:
IP des Servers
Unter Site Map hab ich das Verzeichnis /Test als Webdav eingetragen

Nun verbinde ich mich und bekomme die Meldung:

HTTP: Unauthorized (/Test)

Also dachte ich mir ok: Nimmste die Windows Boardmittel, also versucht übern Explorer die Verbindung herzustellen.

Adresse:
Http://IP/Test

Verbunden - Domäne\Administrator + PW eingegeben - das kommt dann immer wieder - ergo angeblich falsch ... nach 3 mal kommt dann Verzeichnis ungültig.

Also scheint das mit dem Webdav irgendwie nicht so zu gehen.

Hat nun irgendwer noch eine Idee wie ich das eingerichtet bekomme, so dass ich mir das Verzeichnis als Laufwerk mappen kann?

VG und Thx!
Mitglied: Xaero1982
23.08.2011 um 16:32 Uhr
Ahoi,

so nach ein wenig weiter rumprobieren und dem folgendem Test:

Ich habe einen neuen Benutzer angelegt!
Keine Gruppen, kein nix - nur ein einfacher Benutzer im AD.

Noch mal gestest:
Und auf ein mal gehts!

Noch mal mit dem Administrator (Domänenadmin) getestet: Geht nicht!

Jemand eine Idee?

Was allerdings nicht geht: Ich kann nichts in dem Ordner erstellen, obwohl die Berechtigungen gesetzt sind?!

VG
Bitte warten ..
Mitglied: Xaero1982
24.08.2011 um 11:28 Uhr
Moin,

schade schade, dass hier keiner helfen kann, aber wie sagt man so oft ... jeder ist seines eigen Glückes Schmied

In den Webdaveinstellungen im IIS war die Option:

"Sperre zum Schreiben erforderlich" auf True gesetzt.

Das hab ich mal auf False gesetzt und siehe da - nun gehts auch mit dem Speichern.

Natürlich muss man dem Nutzer auch die Berechtigungen auf den Ordner geben - dazu habe ich die IISUSR Gruppe genommen und den entsprechenden Benutzer dort eingetragen.

Nächstes Ziel: SSL!

VG
Bitte warten ..
Mitglied: Xaero1982
24.08.2011 um 12:00 Uhr
So, auch das mit dem SSL + Webdav konnte ich mit Hilfe des folgenden Links erfolgreich lösen:

http://www.we-coffee.com/x509builder.aspx

Kennt die Seite jemand?

Die Zertifikate gehen problemlos, aber mir stellt sich dann die Frage, wenn ich es im gewerblichen Bereich anwenden, ob es erlaubt ist und sicher?

VG
Bitte warten ..
Mitglied: Coreknabe
07.09.2011 um 14:26 Uhr
Jetzt revanchier ich mich mal

Zu Deiner Frage: Wer will das verbieten? Den einzigen Nachteil, den Du dabei hast, ist, das bei einem selbst erstellten Zertifikat zumindest beim ersten Mal eine Meldung kommt, dass der Verbindung nicht vertraut wird. Blöd, wenn man einen Webshop o.ä. betreibt, weil sowas schlicht unseriös wirkt. In diesem Fall würde ich eher ein Zertifikat kaufen.

Was die Sicherheit angeht, ist das nicht unsicherer als ein gekauftes Zertifikat solange Du Grundregeln einhältst: Das Zertifikat sicher mit Passwort verwahren. Sicherstellen, soweit möglich, dass die Benutzer die Identität des Zertifikats prüfen (wer macht das schon, wenn man mal ehrlich ist?). Und wenn eine Windows-Domäne vorhanden ist, eine Stammzertifizierungsstelle einrichten. Zertifikate nur von untergeordneten Zertifizierungsstellen erstellen lassen.
Bitte warten ..
Mitglied: Xaero1982
07.09.2011 um 14:31 Uhr
)

Wir werden nun doch eins kaufen ... auch wenn das nach den aktuellsten Security-Meldungen auch nicht mehr so wirklich sicher ist, aber nun gut.

VG und mal sehen, ob wir dein Webdav auch noch ans Laufen bekommen!
Bitte warten ..
Mitglied: clowni
04.02.2012 um 16:12 Uhr
Hallo Xaero1982,
ich habe deinen Beitrag gelesen und wollte fragen, nach welcher Anleitung du WebDav eingerichtet hast?
LG Clowni
Bitte warten ..
Mitglied: Xaero1982
24.02.2012 um 21:12 Uhr
Hi,

gar nicht gesehen ... war nicht hier

http://learn.iis.net/page.aspx/350/installing-and-configuring-webdav-on ...

Die wars glaub ich wenn ich mich richtig erinner.

LG
Bitte warten ..
Ähnliche Inhalte
Hosting & Housing
IIS 7.5 Einstellungen
gelöst Frage von mschaedler1982Hosting & Housing2 Kommentare

Hallo zusammen. Ich habe bei uns eine Webseite konfiguriert und möchte nun dass der Inhalt der Webseite über intern ...

Informationsdienste
IIS 7.5 Probleme mit Bindung
gelöst Frage von Leo-leInformationsdienste9 Kommentare

Hallo Forum, ich hoste eine Website per IIS 7.5. Die 'Seite wird sauber per A-Record aufgelöst und ich habe ...

Windows Server
Problem mit Webdav und Webserver IIS
Frage von JUJUS31Windows Server3 Kommentare

Hallo, ich versuche seit einigen Tagen den Webdav dienst des Windows IIS server ans laufen zu bekommen. Die Verbindung ...

Informationsdienste

Webdav IIS 7.5 auf Server 2008 : Fehler beim Verbinden: System error 1397 has occurred. Mutual Authentication failed

Frage von MeinGottWalterInformationsdienste

webdav IIS 7.5 auf Server 2008 : Fehler beim Verbinden: System error 1397 has occurred. Mutual Authentication failed Hallo ...

Neue Wissensbeiträge
Windows 10

Windows 10 1809 - Snipping Tool wird verschoben und Benutzer sollen die App installieren

Information von Deepsys vor 1 StundeWindows 106 Kommentare

Hallo zusammen, und wieder ein Punkt mehr Windows 10 zu hassen, das Snipping Tool wird bald "verschoben" und durch ...

Windows 10

Blackscreen nach dem Update von 1809 auf 1809 wenn der Rechner aus dem Standby gestartet wird

Tipp von FSX2010 vor 1 TagWindows 108 Kommentare

Habt ihr den Samsung Treiber "Samsung_NVM_Express_Driver_3.0" installiert sollte dieser für 1809 deinstalliert werden da dieser nicht kompatibel ist. Der ...

Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 3 TagenUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 3 TagenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Heiß diskutierte Inhalte
Windows 10
Probleme mit Zielgruppenadressierung unter Windows 10
Frage von Mister-MWindows 1016 Kommentare

Hallo zusammen, folgendes Problem, bzw. Situation. Ich habe eine Gruppenrichtlinie mit einer Druckerzuweisung gemacht. Hier habe ich die Zielgruppenadressierung ...

Windows 10
Nach Windows-Upgrade verschwinden Kacheln aus dem Startmenü
Frage von swiss-electronicsWindows 1015 Kommentare

Hallo zusammen Ich habe nun schon mehrmalig die Erfahrung gemacht, dass nach dem Upgrade von Windows 10 Build 1709 ...

Webbrowser
Proxy-Zugangsdaten in Firefox hinterlegen
gelöst Frage von SebastianGSWebbrowser14 Kommentare

Hallo zusammen, kennt jemand von Euch aktuell eine Möglichkeit die Proxy-Zugangsdaten im Firefox (Vers. 63.0.3 - 64-Bit) zu hinterlegen, ...

Monitoring
WMI Problem bei PRTG
Frage von justInsaneMonitoring12 Kommentare

Hallo zusammen, ich bin zur Zeit dabei, das PRTG Monitoring Tool auszutesten. Ich habe das ganze nun grob konfiguriert ...