Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wiki und die (starken) Umlaute. System: IIS 6.0 und MySQL5

Mitglied: 17169

17169 (Level 1)

23.11.2005, aktualisiert 25.12.2005, 5386 Aufrufe, 1 Kommentar

Hallo,

ich habe einen Wiki auf einem IIS 6 mit PHP 5 und Mysql 5 aufgesetzt. Wenn ich im Wiki Links mit Umlauten anlege klappt das noch. Sobald ich in den Link aber was reinschreiben will fliegt das System auf die Nase. Das liegt vermutlich daran, dass die Umlaute nicht richtig in die Datenbank gespeichert werden. Weil wenn ich mir den Link anschaue dann steht da jetzt statt einem Ü ein %C%BC. Der Link ist folglich falsch weil der eingebene Name falsch in die DB geschrieben wurde.

Weiß jmd wo ich was umstellen muss dass das auch noch klappt ?

Danke im Vorraus,

creetz
Mitglied: netstorm
25.12.2005 um 18:12 Uhr
Hallo,

Du kannst bei MySQL die Zeichenkodierung in der Datenbank einstellen. Ich vermute, daß Du einen Zeichensatz für die Datenbank verwendest, der keine Umlaute enthält. Falls Du zufällig phpMyAdmin verwendest kannst Du das darüber recht bequem einstellen. Ansonsten kannst du es als Kommandozeilenparameter beim mysqld mit angeben (z.B. --default-character-set=latin1_de) oder in die my.cnf eintragen (default-character-set=latin1_de).
Allerdings bleiben Tabellen, die Du schon angelegt hast hierbei im alten Zeichensatz hängen. Dies ist meißt nur dadurch zu beheben, die komplette DB zu exportieren und danach wieder zu importieren, damit der neue "Standardzeichensatz" übernommen wird.

Ich hoffe ich konnte helfen,
CIAO Thorsten
Bitte warten ..
Ähnliche Inhalte
Windows Server
IIS 6.0 und Domänenanmeldung
Frage von slanskyWindows Server

Hallo Leute, ich habe eine Frage, aber erst die Umgebung: Domäne mit 3 DCs Windows Server 2008 R2 und ...

Ausbildung

Projektantrag Abschlussprüfung FISI - Wiki-System auf virtuellem Server

Frage von Michi2805Ausbildung5 Kommentare

Hallo, kurz zu mir! Ich heiße Michael, 29 Jahre Jung und bin in einer Umschulung zum Fachinformatiker - Systemintegration. ...

Administrator.de Feedback

Administrator-Wiki

Frage von BirdyBAdministrator.de Feedback14 Kommentare

Hallo zusammen, motiviert durch das Lob von aqui zu einem meiner Beiträge habe ich überlegt ein Tutorial zu den ...

PHP

Wiki für Unternehmen

gelöst Frage von gamerffPHP14 Kommentare

Hallo Forum, wir wollen bei uns im Unternehmen ein Wiki nutzen wo wir Dokumente und Anweisungen den Mitarbeitern zur ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 54 MinutenHumor (lol)

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 9 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 22 StundenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Server SSD: NVMe PCIe 3.0 RAID?
Frage von bouneeFestplatten, SSD, Raid15 Kommentare

Hallo liebe Admins, mir stellt sich gerade die Frage, ob ein neuer Server mit SSD NVMe PCIe 3.0 Sinn ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit14 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless14 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...