Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Win 10 WWAN und WLAN Probleme

Mitglied: ChristianHarm

ChristianHarm (Level 1) - Jetzt verbinden

17.05.2018 um 02:33 Uhr, 514 Aufrufe, 9 Kommentare, 1 Danke

Hallo liebe Forengemeinde,

seit längerem habe ich folgendes Problem, bei welchem ich bisher keine Lösung finden konnte. Würde mich sehr freuen, wenn ihr mir helfen könntet.
Folgende Situation:
Als Lotse an Bord von Seeschiffen haben wir ein Gerät, welches die AIS Daten eines Schiffes ausliest, und diese per WLAN an unsere Laptops weiterleitet.
Solange diese Geräte gekoppelt sind, können wir nicht über WLAN ins Internet. Dazu nutzen wir dann die WWAN Karte, welche parallel die Daten aus dem
Internet bekommt. Wenn wir dann vom Schiff runter sind, und die Geräte nicht mehr mit dem Schiff verbunden sind, soll der Rechner über das Firmen-
oder Privat Netzwerk wieder über WLAN in das Internet.
Bis Win8 konnten wir das noch relativ einfach bewerkstelligen, indem wir die Metrik der WWAN Karte so eingestellt hatten, das diese nur benutz wurde,
wenn über WLAN kein Internet möglich war.
Das soll jetzt eigentlich auch noch so sein - also Internet über WLAN, falls kein Internet vorhanden, WWAN Karte benutzen, AUCH wenn WLAN verbunden
ist.
Das scheint mit WIN10 aber ein grosses Problem zu sein, speziell seit dem letzten Update.
Mal verbindet sich der Rechner über die WWAN mit dem Internet, bekommt aber keine Daten. Mal verbindet sich der Rechner über WWAN mit dem Internet,
bekommt auch Daten, aber die WLAN Karte bekommt keine Daten. Alles sehr unzuverlässig und unregelmäßig, so dass es schwer ist, den Fehler einzugrenzen.
Auch haben wir schon versucht, über "Bekannte Netzwerke verwalten" entsprechende Einstellungen vorzunehmen. Leider ohne dauerhaften Erfolg.
Habe hier im Forum schon einige Beiträge mit Fragen zu zwei Netzwerken gelesen, aber die bezogen sich z.B. auf zwei ständig gleich bleibende Verbindungen,
also eine Karte Internet, die andere lokales WLAN zum Beispiel. Also etwas anders als mein Problem.
Würde mich sehr freuen, wenn das hier vorhandene geballte Fachwissen mir helfen könnte, dieses Problem zu lösen.

LG
Christian
Mitglied: ChristianHarm
17.05.2018 um 03:08 Uhr
Noch zur Info:
WLAN und WWAN Metrik ändern hilft nur kurzfristig, es scheint als versuche WIN10 ständig selber das beste zu versuchen,
scheitert aber dabei. Automatische Verbindungseinstellungen von WIN10 aus- und eingeschaltet. Mal klappt es, mal nicht...
Adapteranbieterreihenfolge geändert, gleiches Ergebnis, mal klappt, mal nicht...

Es ist zum Mäusemelken...

LG
Christian
Bitte warten ..
Mitglied: ChristianHarm
17.05.2018 um 04:10 Uhr
Hier mal ein Bild, gerade wieder passiert...
kein internet - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: StefanKittel
17.05.2018, aktualisiert um 07:42 Uhr
Moin,

Windows, und eigentlich jedes System, bekommt ein Problem wenn es zwei Verbindungen mit Default-Gateway hat.
Es entscheided dann anhand seiner Routing-Tabelle und der Metric (Kosten der Verbindung) wo die Daten übertragen werden. Dabei spielt primär die Reihenfolge, aber manchmal auch die Namen der Schnittstellen, eine Rolle.

Dynamischer und lustiger wird das bei aktuellen Betriebssystemem, namend Android und Windows 10, welche die Leitungen nach Qualität und Geschwindigkeit prüfen und die Routing-Tabelle "optimieren".

Zu Eurem Problem fallen mir folgende Lösungen ein für die es evt. fertige Tools/Programme gibt oder die man mit Skripten lösen könnte.
1. Default-Gateway leer lassen.
Bleibt die Frage ob das AIS dann noch funktioniert.
2. Default-Gateway in der Routing-Tabelle anpassen oder löschen
Ist vermutlich zu aufwendig wenn dies dynamisch ist
3. Mit der Metric die Kosten für diese Verbindung erhöhen und hoffen das Windows das richtig interpretiert
Bleibt zu hoffen das Windows das richtig interpretiert

Schau mal hier als Idee
01.
@echo off 
02.
taskkill /F /IM utorrent.exe 
03.
netsh interface ip set address name="Local Area Connection" source=dhcp gateway=192.168.1.130 gwmetric=1 
04.
start /wait C:\Progra~2\uTorrent\utorrent.exe 
05.
netsh interface ip set address name="Local Area Connection" source=dhcp gateway=192.168.1.1 gwmetric=1
Quelle: https://www.petri.com/forums/forum/windows-scripting/dos-command-shell/6 ...

Stefan
Bitte warten ..
Mitglied: aqui
17.05.2018 um 10:04 Uhr
Solange diese Geräte gekoppelt sind, können wir nicht über WLAN ins Internet.
Mit der richtgen Konfig dieses Adapters schon !
utzen wir dann die WWAN Karte,
Wer oder Was ist WWAN ??
Die Lösung ist kinderleicht, denn wenn man dem MLAN Interface das Default Gateway entzieht kann man immer beides machen. Auch z.B. mit 2 WLAN Adapter.
Außerdem lässt sich das auch erreichen wenn man die Bindungsreihenfolge der Karten unter Winblows entsprechend anpasst.
Mit der richtigen Adapter Konfig ist das ein Kinderspiel.
Bitte warten ..
Mitglied: ChristianHarm
17.05.2018 um 13:45 Uhr
Hallo,

erst mal vielen Dank euch beiden für die Hilfe. Zur Info: WWAN Karte ist die Mobilfunkkarte.
Wenn ich euch beiden mal die Adapterkonfigurationen und Reihenfolge per screenshot einstelle,
würde euch das helfen, mir zu helfen?
Wenn ich bei der WLan Karte das Standardgateway entferne, komme ich dann darüber doch nicht mehr ins Internet, oder?
Ich könnte dann also nur den AIS Plug nutzen, und müsste, um zu Hause wieder über WLan ins Netz zu kommen, das Gateway
wieder eintragen, oder verstehe ich das falsch?
Die Metrik habe ich erst gestern geändert, vorher war sie auf automatisch. Hat aber leider auch keinen Erfolg gebracht.
Und wenn ich bei den bekannten Netzwerken die Einstellungen ändern möchte, werden diese nicht gespeichert.
Würde mich riesig freuen, wenn ihr mir anhand eines konkreten Beispiels schreiben könntet, was ich wo eintragen soll.
Bin zwar schon seit vielen Jahren mit Windows vertraut, aber das mit den Netzwerken hat sich mir immer noch nicht wirklich
erschlossen. (Bin wohl auch mittlerweile zu alt)
Vielen Dank für eure Hilfe!
Christian
reihenfolge - Klicke auf das Bild, um es zu vergrößern
telefonkarte - Klicke auf das Bild, um es zu vergrößern
wlan - Klicke auf das Bild, um es zu vergrößern
bekanntes netzwerk - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: ChristianHarm
17.05.2018 um 14:31 Uhr
Hier nochmal ein screenshot von den Einstellungen des AIS Plugs, welche ebenfalls geändert werden können.
Macht es sinn, dort das Standardgateway zu entfernen?

LG
Christian
plug einstellungen - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: ChristianHarm
17.05.2018 um 15:46 Uhr
Hier nochmal die gleiche Situation,
anderer AIS Plug, Telekom voller Empfang, aber kein Internet.
Alle Treiber nochmal aktualisiert, Metrik wieder auf automatisch...
Es ist zum k...

LG
Christian
kein internet2 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: ChristianHarm
22.05.2018 um 18:42 Uhr
Hallo,

hat keiner eine Idee?

LG
Christian
Bitte warten ..
Mitglied: aqui
LÖSUNG 23.05.2018 um 10:30 Uhr
Wenn ich bei der WLan Karte das Standardgateway entferne, komme ich dann darüber doch nicht mehr ins Internet, oder?
Ja !
Ist ja auch klar, denn dem Netz fehlt ja dann das Default Gateway ins Internet.
und müsste, um zu Hause wieder über WLan ins Netz zu kommen,...
Ja, richtig. Das kann man aber vereinfachen über einen Profile Switcher Tool der auf Mausklick entsprechende WLAN Profile aktiviert.
Metriken nutzen nicht viel bei Windows, da sich Windows selber im NIC Beriech nicht Standard konform verhält mit schlecht programmierten Treibern.
Du musst also schlciht und einfach nur dafür sorgen das das Default Gateway immer nur auf der Karte aktiv ist über die du ins Internet musst. Die anderen dürfen keins haben.
Damit ist auch sichergestellt das die Bindungsreihenfolge der NICs dir da nicht dazwischenfunkt.
Ein route print in der Eingabeaufforderung gibt dir immer aus wie aktuell das IP Routing auf der Windows Maschine läuft.
Daran kannst du dich immer problemlos orientieren WO was hingeht.
Traceroute (tracert bei Windows) oder Pathping zeigt dir das dann auch noch genau an.
Nur so bekommst du das in den Griff mit Winblows.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Wie kann in Win 10 der WWAN APN per Skript geaddet werden?

gelöst Frage von Jens4everLAN, WAN, Wireless8 Kommentare

Hallo zusammen, einige Lenovo-Geräte verlieren immer wieder sporadisch den APN des LTE Moduls. Der Nutzer kommt dann nicht online ...

Windows 10

Probleme mit Win 10 PIN

Frage von FFSephirothWindows 101 Kommentar

Hallo zusammen, mir ist folgendes an meinem und an dem PC eines Kunden aufgefallen: Nachdem ich mich ordnungsgemäß mit ...

Windows 10

WWAN Dienst startet nicht mehr

Frage von HanutaWindows 10

Hallo Zusammen, wir haben Notebooks mit LTE Kartenslots von Dell Die Treiber wurden alle aktualisiert (BIOS) ebenso. Nach Upgrade ...

Windows 10

WIN 10 November Update, seit dem keine Verbindung zum WLAN

Frage von HappyF66Windows 1010 Kommentare

Hallo Leute, erst mal tolle Seite, immer viel Mitgelesen nun auch mal eine Frage. Ich habe gestern über mein ...

Neue Wissensbeiträge
Windows Userverwaltung

Passwortwechsel in der Domain bei Anmeldung erzwingen

Anleitung von Looser27 vor 40 MinutenWindows Userverwaltung

Nachdem es immer wieder User geschafft haben, sich während des laufenden Betriebes auszusperren, habe ich nach einer Möglichkeit gesucht, ...

Ausbildung

Linux-Ausstieg in Niedersachsen - Windows statt Bugfix

Information von StefanKittel vor 3 TagenAusbildung37 Kommentare

Sind ja nur Steuergelder

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 5 TagenSpeicherkarten6 Kommentare

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 5 TagenSicherheit1 Kommentar

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Passwortwechsel Zeitpunkt festlegen
gelöst Frage von Looser27Windows Userverwaltung28 Kommentare

Guten Morgen liebe Kolleginnen und Kollegen, da es eine Userin in meinem Urlaub geschafft hat, sich vom AD vollständig ...

Windows Server
Probleme im AD am Außenstandort
gelöst Frage von emeriksWindows Server19 Kommentare

Hi, wir haben ein Problem mit AD und GPO am Außenstandort und ich stehe momentan mächtig auf dem Schlauch. ...

Microsoft
Netzlaufwerksordner Berechtigungen Speichern unter aus Programmen
Frage von ITler7Microsoft15 Kommentare

Moin, bin in ein neues Unternehmen eingetreten und habe die Anforderung bekommen Berechtigungen auf einige Ordner anzupassen, da bisher ...

CMS
Seltsame Joomla-Meldung auf unserer WebSite
Frage von Winfried-HHCMS14 Kommentare

Hallo in die Runde! Kennt sich jemand mit Joomla aus? Im Backend unserer WebSite lesen wir seit einiger Zeit ...