Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win 7 64bit - Treiber für WLAN Adapter können nicht korrekt installiert werden

Mitglied: KNOCKOUT

KNOCKOUT (Level 1) - Jetzt verbinden

02.10.2013, aktualisiert 21:34 Uhr, 6618 Aufrufe, 6 Kommentare

Hallo zusammen,

bei einem Bekannten habe ich ein sehr merkwürdiges Problem:

Er hat einen Acer Desktop PC mit Win 7 Home Premium 64bit Version.
Zuhause hat er ein WLAN.

Seit kurzem hat er den WLAN Stick Netgear A6200. Dieser ist laut Verpackung sowie Homepage mit Win 7 64 bit kompatibel.
Bei der Installation kam dann folgende Meldung im Gerätemanager: Das Gerät funktioniert nicht ordnungsgemäß, da Windows für das Gerät erforderliche Treiber nicht laden kann (Code 31).

Gut, erstmal nichts dabei gedacht und den alten WLAN Stick von ihm, ebenfalls ein Netgear Modell (glaube N300 heisst der) angesteckt. Doch siehe da, genau das selbe Treiber Problem! Dieser Stick hat aber vor einem Jahr noch problemlos funktioniert.

Den Netgear Treiber bzw das ganze Netgear Genie Programm habe ich bereits neu installiert, genauso wie die aktuellste Version für Windows 7 64bit von der Netgear Homepage geladen. Auch die Standalone Treiber, die ebenfalls von Netgear verfügbar sind habe ich versucht, aber immer die selbe Meldung (siehe oben).

Gut, dachte ich mir ich versuche einen anderen WLAN Stick. So habe ich meinen TP Link wn722n, den ich ebenfals auf Win7 64 bit nutze mit zu ihm genommen. Auch bei diesem Stick erhalte ich nach installation der Treiber die idente Fehlermeldung!

Alle drei Sticks habe ich nun an meinem PC probiert und alle drei haben tadellos funktioniert.

Andere Geräte wie ein Canon Drucker, einen Olympus Digitalcamera und diverse USB Sticks werden an seinem PC problemlos erkannt, nur bei insgesamt 4 WLAN Sticks (auch einen der Marke US Robotics habe ich probiert) bekomme ich immer die Meldung

Das Gerät funktioniert nicht ordnungsgemäß, da Windows für das Gerät erforderliche Treiber nicht laden kann (Code 31).


An was kann das liegen? Ich werde nichtmehr schlau daraus. Ich habe bereits jegliche Software die in den letzten Monaten installiert wurde (CCleaner + Firefox sowie Visual C++ Redistributable und Microsoft Silverlight) deinstalliert sowie eine Systemwiederherstellung von Juni 2013 geladen (zu diesem Zeitpunkt funktionierte der alte WLAN Stick von Netgear noch!). Nichts brachte eine Besserung.

Ich bin langsam ratlos. Scheinbar handelt es sich nur um WLAN Adapter, die nicht korrekt installiert werden können.

Um jeden Tipp bin ich Dankbar!!!

Edit: Auch den Virenscanner (Avira) habe ich deaktiviert und zusätzlich im zweiten Versuch noch komplett deinstalliert. Kein anderer Virenscanner ist aktiv.
Mitglied: aqui
03.10.2013 um 11:14 Uhr
Warum siehst du nichtmal in die Winblows Konwledgebase:
http://support.microsoft.com/?kbid=509102
Der Fehlercode 31 deutet auf ein falsches oder altes BIOS hin oder das der USB Port im BIOS deaktiviert wurde !
Date also das BIOS des Rechners up und/oder überprüfe die BIOS Settings.
Das damit was nicht stimmt zeigt ja allein schon die Tatsache das keinerlei USB Geräte in diesem Rechner funktionieren eindeutig !

Generell kann man dir nur raten für einen Desktop Rechner niemals USB WLAN Adapter zu nehmen. Abgesehen von der erheblichen mechanischen Anfälligkeit bei stationären Systemen haben diese auch noch eine miserable Performance. Allein schon aus der Baugröße heraus resultiert die schlechte technische Möglichkeit MIMO Betrieb oder Antennen Diversity zu realisieren usw. usw.
USB WLAN Adapter sind also immer ein NoGo und die technsich allerschlechteste Wahl bei Desktop Systemen und sollten besser immer durch PCI oder PCIe Steckkarten intern ersetzt werden:
http://www.alternate.de/html/listings/Hardware-Komponenten-Netzwerkkart ...
bzw. PCIe
http://www.alternate.de/html/listings/Hardware-Komponenten-Netzwerkkart ...
Dadurch würde sich auch dein obiges USB Problem von selber lösen...
Bitte warten ..
Mitglied: KNOCKOUT
03.10.2013 um 11:28 Uhr
Weil die Windows Knowledge Base leider keine funktionierende Lösung für das Problem hat.

- WLAN Adapter #2 (N300) hat ja funktioniert, daher kann die BIOS Version kaum zu alt sein (zudem gibts es keine aktuellere Version für das Board). BIOS auf default settings zurücksetzen habe ich bereits probiert + Kontrolle ob die USB Ports im BIOS aktiv sind ebenfalls OK.


Ich hatte nie geschrieben das KEINERLEI USB Geräte funktionieren, im Gegenteil. USB Sticks, Drucker über USB Port, ... funktionieren Problemlos am selben Port an dem ich den WLAN Stick anhänge.

Da er nur ein "Von Zeit zu Zeit" User ist, ist die schlechtere Performance bei USB WLAN Sticks zweitrangig und ebenso eine Neuinvestition die letztmögliche Alternative. Besonders da der Netgear A6200 von ihm gerade angeschafft wurde.

Danke für die Antwort.
Bitte warten ..
Mitglied: aqui
03.10.2013, aktualisiert um 13:06 Uhr
.. ."keine funktionierende Lösung für das Problem hat."
Was ja auch logisch und verständlich ist wenn es sich wirklich um eine Fehleinstellung oder ein veraltertes BIOS handelt. Das kann das Betriebssystem natürlich nicht fixen...wie auch ?!
Das USB Sticks ausgenommen von der o.a. Bemerkung sind ist evident, die haben generische Treiber im OS !
Ggf. ist das auch nur ein Bug im BIOS. Bei Billigstheimer Acer wäre das auch nicht groß verwunderlich...?!
Bitte warten ..
Mitglied: KNOCKOUT
03.10.2013 um 13:11 Uhr
Ok nochmals: die BIOS Version wurde nicht verändert, war also schon ident als der alte Stick noch funktionierte. Die USB Ports im BIOS sind aktiviert, zurücksetzen auf "default settings" sowie "failsafe defaults" brachte beides keine Änderung.

Der Besitzer des PC ist absolut kein Profi und sah das BIOS gestern, als ich die Einstellungen prüfte, zum ersten mal.. Die BIOS Batterie ist auch OK.
Bitte warten ..
Mitglied: spinnifex
14.11.2013 um 15:29 Uhr
Hallo Knockout,

lass Dich von aqui nicht ärgern, es gehört nicht zu seinen Stärken den Sinn einer Anfrage zu verstehen, genau zu lesen oder fehlerfreies Deutsch zu schreiben. Er (oder vielleicht auch sie) konzentriert sich lieber darauf, auf kleinen Unklarheiten anderer Forumsmitglieder herumzuhacken, ohne dabei seine eigenen Schlampereien zu sehen.

@aqui: Lies mal Deine zehn letzten Beiträge, denke drüber nach und versuche weniger motzig, dafür aber etwas konstruktiver zu posten!

Okay, zurück zum Problem: Nachdem das BIOS jawohl ausgeschlossen werden kann und auch die Wiederherstellungspunkte nichts gebracht haben, würde ich folgenden Weg versuchen: Durchsuche die Registry nach Resten der Netgear- bzw. TP-Link-Installationen und schmeiße sie raus. Anschließend starte den PC neu und kontrolliere die Registry erneut auf Reste. Sind tatsächlich keine mehr vorhanden, installiere den aktuellen NG-Treiber und schließe danach den WLAN-Stick an.

Ob's klappt kann ich nicht garantieren, versuchen würde ich es auf jeden Fall. Viel Erfolg!

Schöne Grüße!
Bitte warten ..
Mitglied: KNOCKOUT
21.11.2013 um 08:34 Uhr
Hallo spinnifex,

ja das habe ich gemerkt. Davon lass ich mich sicher nicht ärgern

Auch in der Registry habe ich die ganzen alten Überbleibsel der WLAN Adapter sowie der Software dazu gelöscht. Leider auch hier das selbe Problem.

Das Problem hat sich mittlerweile "gelöst" - nur eine Neuinstallation von Windows hat geholfen. Hatte zwar den unangenemen Nebeneffekt das alle Daten gesichert werden sowie alles neu eingerichtet werden musste, gleichzeitig hörte ich im nachhinein aber "woah der ist ja wieder schnell"

Danke für die Hilfe!
Bitte warten ..
Ähnliche Inhalte
Peripheriegeräte

Suche Treiber für atheros ar9002wb-1ng wireless network adapter win 7

gelöst Frage von Hendrik2586Peripheriegeräte17 Kommentare

Guten Morgen liebe Gemeinde! :) Ich bin gerade dabei einen Toshiba Satellite neu zu installieren da die alte Festplatte ...

Router & Routing

VPN Adapter werden als WLAN Adapter angelegt

Frage von RoxyyoRouter & Routing4 Kommentare

Hallo zusammen, ich habe erst seit kurzem das Problem, dass neue VPN Verbindungen die ich anlege, als WLAN Adapter ...

Windows 7

Beste Vorgehensweise - Vista und Win 7 sind installiert - Vista soll jetzt weg

gelöst Frage von CarryOnWindows 74 Kommentare

Hallo zusammen, zugegeben, es gibt viel Lektüre dazu, aber ich bin einfach unsicher. Aktuell ist Dual-Boot angesagt. Vista (Home ...

LAN, WAN, Wireless

Gibt es USB zu WLAN Adapter?

Frage von grkaLAN, WAN, Wireless3 Kommentare

Hallo, ich habe ein Gerät das ein USB Kabel hat und im PC als Serieller COM Port in der ...

Neue Wissensbeiträge
iOS
IOS 11.2.6 verfügbar
Information von sabines vor 2 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 16 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server38 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless15 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...