Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Win Server 2008 R2 Raid 5 - Hotswap Platte bleibt in Wiederherstellungsmodus (blinkt) obwohl Status in W2k OK

Mitglied: aroseisarose

aroseisarose (Level 1) - Jetzt verbinden

02.10.2011 um 22:41 Uhr, 5112 Aufrufe, 3 Kommentare

Hallo zusammen,

so nebenbei habe ich in der Vergangenheit schon mal mehrere W2k Server aufgebaut. Meistens mit Hardware-Raid, aber auch mit Software-Raid. Normalerweise nutze ich ausschließlich Linux, doch die Kunden brauchen halt ab und zu auch mal was exotisches *hehe*

Zur Sache:

Hard- und Software:

  • Lenovo ThinkServer 430 TS mit 4 Hotswap-Einschüben
  • Windows Server 2008 R2 Standard auf extra Platte an SATA Port P0 mit Hilfe der EasyInstall DVD aufgespielt
  • DVD an SATA P1
  • 4 Hotswap Laufwerke (500GB) an SATA Port P2-5 als
    • ursprünglich waren die Platten auf Port 0-3 und wurde testweise mal mit dem boardeigenen Raid 10 konfiguriert
    • Sind jetzt als Software Raid 5 via Windows Server 2008 R2 konfiguriert (also nicht mit einem Raid Controller oder dem verfügbaren Raid5 Key des ThinServer)

Mögliche Ursache

  • Raid 10 via BIOS (LSI MegaRaid) wurde aufgelöst, der Controller von [RAID] auf [AHCI] umgestellt
  • Dabei wurde eventuell die Reihenfolge der Platten vertauscht (weiss ich nicht mehr, sollte aber beim Aufsetzen eines komplett neuen Raid ziemlich wurscht sein, und ist es unter z.B. Linux ja auch)
  • Anschließend Raid 5 via Datenträgerverwaltung konfiguriert

Problembeschreibung:

  • Das zweite Laufwerk an P3 hört einfach nicht auf zu blinken
    • Statusanzeige laut Lenovo- Handbuch (grün blinkt schnell, gelb ca. 1x pro Sekunde) -> Das Festplattenlaufwerk wird
wiederhergestellt (S. 36 deutsches Handbuch 00740ug_gr.pdf)
  • Das Blinken beginnt just nachdem das Betriebssystem startet
  • Starte ich ein Live-Linux vom Stick / CD, tritt das Blinken nicht auf. Auch lässt sich hier problemlos ein RAID 5 aufsetzten, ohne dass die Platte blinkt

Versuche um das Problem zu lösen:

  • DiskPart: Clean und andere Spielchen
  • Mehrfaches Löschen der Volumes und Wiedererstellen, dazwischen Reboots, Neukonfigration, komplette Formatierung (nicht schnell) als RAID und normales Volume, MBR neu erstellt, ...
  • Linux gebootet, Platten komplett formatiert, partitioniert, als Raid5 und normal
  • Windows Server komplett neu installiert
  • Platte getauscht -> dann fängt diese getauschte Platte an diesem Port an zu blinken ;)

Fazit:

Ich bekomme unter W2k das Blinken auf P3 einfach nicht weg!

Im Grunde ist es nur eine Schönheitsfehler, denn der W2k zeigt an, dass das Raid in Ordnung ist. Aber so kann ich das Teil dem Kunden einfach nicht ausliefern. Das Ganze macht mich echt noch wahnsinnig ;) Das aller seltsamste ist, dass unter Linux die ganze Sache problemlos funktioniert.

Die Installationsplatte wurde von mir auch schon formatiert (bei der Neuinstallation mit der Easy-Install DVD) und der Server von Grund auf neu installiert.
Irgendwie scheint die W2K-Platte ein Elefantengedächtnis zu haben. Ich frage mich nur, wo die Infos dazu gespeichert sind (scheint W2k spezifisch zu sein).
Das einzige, was ich noch nicht versucht habe: Platte mit Linux komplett löschen, dann den W2K ohne Easy-Install mit der Standard W2K DVD aufspielen.

Aber vielleicht hat von euch einer ne Idee. Kann ja nicht sein, dass man dem W2K das nicht beibringen kann, dass die Platte aufhört zu blinken, ohne das Ganze komplett neu aufzusetzen.

Grüße
Axel
Mitglied: 60730
02.10.2011 um 22:50 Uhr
moin,

warum?

  • Stecken die Platten da, wo Sie stecken?
  • Nutzt du ein Software Raid, wenn es ein Hardwareraid gibt?

was passiert?

  • Wenn das blinkende Laufwerk allein an Port0 hängt und du im Bios des Raidcontrollers "stöberst"?

Nicht falsch verstehen ich weiß, warum manche unter Tux lieber ein weiches Raid nehmen und auf das harte verzichten, aber Winblows ist nicht Tux...

Gruß
Bitte warten ..
Mitglied: aroseisarose
02.10.2011 um 23:29 Uhr
Hi Timo, danke für deine Antwort

Leider läuft grade wieder mal ne Formatierung (völlig unsinnig, ich weis). Die läßt sich grad nicht abbrechen. Werde mich morgen Abend dann noch mal melden.

Aber ein paar Antworten kann ich dir schon mal geben:

  • Stecken die Platten da, wo Sie stecken?
??? wie oben beschrieben und da bleiben sie auch. Habe nur einmal gewechselt, nachdem wir uns für eine extra Bootplatte entschieden haben. P0 muss die W2k Platte sein, also das Bootlaufwerk.

  • Nutzt du ein Software Raid, wenn es ein Hardwareraid gibt?
Das LSI Raid ist kein Hardware-Raid, sondern ein Onboard-Software-Raid und kann nur 0, 1 und 10 (den 5er Key muss man für nen Huni extra kaufen)
Aber: das zu erstellende System braucht keine Performance und hat ein gutes Backup-Szenario, Software-Raid 5 via W2k ist also völlig ausreichend.

  • aber Winblows ist nicht Tux
Seeeehr richtig ;) Und Raid5 unter W2k ist sooooooo langsam ;)

Also bis nach dem Formatierungsabruch ;)

Grüße Axel
Bitte warten ..
Mitglied: aroseisarose
11.10.2011 um 21:34 Uhr
So, nun ist alles so wie es sein soll.
Die Formatierung (oben) hat übrigens über 3 Tage gedauert ... mann o mann ;)

Warum es jetzt nicht mehr blinkt? Kann ich nicht genau sagen, sucht euch was aus den folgenden Punkten aus. Ich habe ja folgende Kandidaten im Verdacht
    • die Lenovo Easy-Install DVD, die vielleicht die Raid Informationen der Laufwerke versucht hat wiederherzustellen
    • die BIOS Einstellung für die Reihenfolgen der Platten.

Habe das System auch einfach mal ein paar Tage in "Ruhe" gelassen, das hatte aber nichts an dem Problem geändert..

Wie auch immer, so gings dann:
    • SATA Belegung auf dem Board geändert:
      • P0 -> Bootfestplatte für Win 2008 R2
      • P1 - P4 -> Hotswap Festplatten
      • P5 DVD

    • BIOS -> Boot -> Bootreihenfolge
        • P0 - P1 - P2 - P3 - P4 (die war durcheinander)

    • Von Linux Bootstick gestartet und mit Gparted ALLE Partitionen gelöscht.

      • Die Server 2008 R2 DVD eingelegt (und diesmal NICHT die Lenovo Easy-Install DVD verwendet) und das BS installiert
        • Raid 5 auf dem 4 Hotswaps konfiguriert

    Voilá
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid

Server Architektur mit RAID 5 - wozu interne Platten?

Frage von Pierre78Festplatten, SSD, Raid10 Kommentare

Hallo, ich beschäftige mich gerade mit RAID Systemen. Ich habe mir einen gebrauchten Dell PowerEdge R515 gekauft. Dieser hat ...

Windows Server

Win 2008 R2 - CMD bleibt stehen

Frage von emeriksWindows Server4 Kommentare

Hi, wir haben seit 2-3 Tagen auf einem TS ein Problem mit der CMD. Windows 2008 R2 Standard SP1 ...

Festplatten, SSD, Raid

Windows Server 2008 R2 Platte spiegeln - unterschiedliche Platten?

gelöst Frage von imacerFestplatten, SSD, Raid2 Kommentare

Hallo und guten Morgen, Anfang dieser Woche habe ich festgestellt, dass auf einem meiner Server eine Platte fehlerhafte Sektoren ...

Windows Server

2008 R2 mit RAID 5 - schwerwiegende Probleme nach Austausch einer HDD

gelöst Frage von blacksnowWindows Server3 Kommentare

Hallo, liebe Leute! Dies ist mein erster Post hier. Ich würde mich freuen, auf Hilfe zu stoßen, und werde ...

Neue Wissensbeiträge
E-Mail
Email-Apps und Verhalten bei Pop3
Erfahrungsbericht von kfranzk vor 22 StundenE-Mail3 Kommentare

Hallo Freunde, da mir mein diesbezüglicher Faden als gelöst markiert wurde, muss ich hier neu aufsetzen. Ich arbeite bewusst ...

Hyper-V

Optimiertes Ubuntu per Microsoft Hyper-V-Schnellerstellung verfügbar

Anleitung von Frank vor 23 StundenHyper-V

Für Microsofts Virtualisierungssoftware Hyper-V ist ab sofort auch ein optimiertes Ubuntu 18.04.1 LTS verfügbar. In der "Hyper-V-Schnellerstellung" App, die ...

Sicherheits-Tools

Trend Micro WorryFree Business Security (WFBS) 10 - neuer Patch 1470 verfügbar

Tipp von VGem-e vor 1 TagSicherheits-Tools1 Kommentar

Servus, mal sehen, ob mit Patch 1470, zu finden unter dann die angeblich fehlerhafte Funktion, die unter W10 im ...

Server-Hardware

Lösung für Ersatz eines defekter Raid-Controllers

Anleitung von wellknown vor 1 TagServer-Hardware3 Kommentare

Hallo, da ich nichts gefunden habe und selbst eine Lösung brauchte, hier eine kleine Anleitung für alle die vor ...

Heiß diskutierte Inhalte
Windows Server
Mit der alten Domäneprofil anmelden ohne Server
gelöst Frage von SyosseWindows Server37 Kommentare

Hallo Jungs Folgendes Szenario: Ich habe bei einem sehr kleinen Unternehmen (2Personen) den Server migriert, soweit hat alles geklappt. ...

Sicherheits-Tools
Virenprogramm lässt Programme nicht starten
Frage von SurferGirlSicherheits-Tools23 Kommentare

Hallo, ich bin neu hier, ich hoffe ich habe die richtige Rubrik gewählt. Falls nicht, tut es mir leid. ...

Windows Server
SQL Server Instanz (Eplan) auf WIN 2008 RC2 Server frisst RAM ohne Limit
Frage von derinderinderinWindows Server17 Kommentare

Hallo Zusammen, Wir haben hier einen Windows 2008 RC2 Server. Darauf läuft ein SQL Server Express 2014 Version 12.0.4232.0. ...

Windows 10
Best Practice für Schulungsräume
Frage von Sn0wFoxWindows 1016 Kommentare

Hallo, leider bin ich auch nach langer Suche nicht auf eine zufriedenstellende Nicht-Cloud-Lösung gestoßen und wollte mal Fragen ob ...