Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win2k3 Netzwerklaufwerk Unterbrechungen im Datenstrom langsames Gigabit

Mitglied: vip3234

vip3234 (Level 1) - Jetzt verbinden

01.10.2008, aktualisiert 15.10.2008, 3737 Aufrufe, 2 Kommentare

Hallo,

ich habe beim Kopieren von einem Netzwerklaufwerk des Servers aus ein Problem mit der Datenrate, was auf ein Zusammenbrechen des Datenstromes zurückzuführen ist.
Weitere Details siehe unten:

Folgende Konfiguration liegt vor:

1x Server Windows 2003 SBS Standard mit 2x Intel Pro Gigabit on Board (intel serverboard)
und Hardware Raid5 mit Adaptec Controller und 4x400GB Seagate Festplatten

1x Client mit Windows Vista Ultimate und 1x Intel Gigabit Adapter in Board
und SATA2 1x320GB Seagate Festplatte

Das Szenario wurde mit direkter Cross Over Verbindung über Cat5e Kabel UND über einen Gigabit Switch getestet.

Mit netio ermittelte Netzwerkdatenrate: 99Mb/s-110Mb/s

Mit HdTach ermittelte Daten:
lesen schreiben
Raid5: 55MB/s 30MB/s
SATA2: 73MB/s 60MB/s

CPU Auslastung während des Kopierens:
Server: 6%
Client: 10%

Das Szenario:

Auf dem Server ist ein Netzwerklaufwerk, auf dem eine Datei mit 2,5GB liegt, die es zu kopieren gilt. Des Weiteren ist auch der Zielort auf dem Client freigegeben.
1. Es wird nun vom CLIENT aus der Kopiervorgang vom Servernetzwerklaufwerk lokal auf den Client gestartet.


Das untere Bild zeigt den Transfer mit NetMeter auf dem Client

e8359eab840fc9a990fbfefc2491eb8b-vista_business_-_win2k3 - Klicke auf das Bild, um es zu vergrößern


Wie man deutlich sehen kann, wird der Datenstrom immer wieder unterbrochen und es enstehen deutlich erkennbare Abstände. Dies führt zu einer Transferrate von durchschnittlich 20-25Mb/s


2. Nun wird der gleiche Versuch noch einmal gemacht, nur dass jetzt der Kopiervorgang vom Server aus auf das ebenfalls freigegebene Ziel auf dem Client gestartet wird.
Somit also der gleiche Vorgang, nur eben vom Server aus gestartet.


Das untere Bild zeigt wieder den Transfer mit NetMeter auf dem Client

3eba0744fe3909547860e393c889be40-win2k3_-_vista - Klicke auf das Bild, um es zu vergrößern


Der Datenstrom ist nun konstant und gleichmäßig. Die durchschnittliche Tranferrate liegt jetzt mit 50MB/s beim Festplattenlimit.



3. Zum Vergleich wurde noch ein Kopiervorgang zwischen 2 gleichwertigen Vista Clients gemacht. Auch hier ist der Datenstrom konstant und die Rate lag bei ca. 45MB/s

ecd10ca7f0eb0a9d62a7db8e76feceb9-vista_-_vista - Klicke auf das Bild, um es zu vergrößern



Nun stellt sich die Frage, womit das Ganze zusammenhängt ? Wieso bricht der Datenstrom immer in kurzen Abständen zusammen wenn der Vorgang vom Client aus gestartet wurde und wieso nicht, wenn dieser vom Server aus begonnen wird ?


Ich wäre euch echt dankbar, wenn mir da jemand weiterhelfen könnte.

Gruß,
Ludwig
Mitglied: XOR-Bit
15.10.2008 um 19:14 Uhr
Hallo,
Raid 5 hat eine schlechtere Schreibperformance als die meisten anderen Raid-Konfigurationen, was oben ja auch gemessen steht. Wenn die Platten nun mit "nur" 30 MB/s wegschreiben können, dann sind die 20 bis 25 MB/s doch gar nicht so schlecht. Auch die übrige Schilderung passt recht gut, denn die Transferraten zwischen Systemen, deren HD I/O besser performt, ist genügend dicht an den Schreibraten der jeweiligen HDs. Ebenso passt das asymmetrische Übertragungsverhalten Server <-> Client zu dieser These.
Gruß
XOR
Bitte warten ..
Mitglied: vip3234
15.10.2008 um 19:21 Uhr
Hallo und danke für die Antwort.

Allerdings kann es nicht an der Festplatten performance liegen. Denn wenn ich daten vom raid5 beziehe werden die Daten zu keinem Zeitpunkt geschrieben. Und die Zielplatten können sehr wohl mit mehr als 30Mb/s schreiben,
denn wie beschrieben erreiche ich eine Geschwindigkeit von 55mb/s wenn ich vom Server aus den Vorgang starte.

Nochmal kurz:

Quelle (server) und Ziel (Client) bleiben gleich. Es wird immer vom Server gelesen und auf den Client geschrieben.
Jedoch im eine Fall vom Server aus gestartet und im anderen vom Client.
Im einen Fall erreiche ich 55MB/s und im anderen eben nur 24MB/s
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Langsames Netzwerk trotz Gigabit
gelöst Frage von lupitaHyper-V1 Kommentar

Hallo zusammen Ich bin ein wenig Ratlos. Ich habe gerade einen Hyper-V Server installiert und darauf befindet sich ein ...

Monitoring
Langzeitmessung des Datenstroms
gelöst Frage von GueNeMonitoring11 Kommentare

Hallo Community, habe unser NW auf verschiedene Gebäude verteilt und diese Gebäude via Richtfunk ( kein W-LAN ) verbunden. ...

Netzwerke

Unterbrechung der Netzwerkverbindung im Ereignisprotokoll

Frage von UselessUserNetzwerke

Hallo Leute, es geht um einen Lenovo Thinkserver 430 mit Windows SBS 2011 Essentials (basierend auf Windows Server 2008 ...

LAN, WAN, Wireless

LAN (WAN) mit ständigen Unterbrechungen

Frage von BrudschgoLAN, WAN, Wireless10 Kommentare

Hallo zusammen. Eine merkwürdige Erscheinung fand ich bei einem Freund. Versuche ich auf das NAS zuzugreifen oder zu surfen ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 14 StundenHumor (lol)3 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 1 TagSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware16 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...

Windows Netzwerk
Backup über WAN
Frage von petereWindows Netzwerk11 Kommentare

Hallo, ich muss aus einem entfernten WAN (synchrone 1Gbit) Daten sichern. Dabei handelt es sich sowohl um wenige große ...