Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Win2k3 Root-Server friert ein

Mitglied: Matthias3x

Matthias3x (Level 1) - Jetzt verbinden

13.05.2008, aktualisiert 14.05.2008, 3598 Aufrufe, 1 Kommentar

Hallo,
ich habe seit ca. 1,5 jahren einen kleinen Windows Root-Server bei Strato gemietet. Die Hardware ist vergleichbar mit dem Power-Server M -> http://www.strato.de/server/power/index.html

Betriebssystem ist derzeit ein Win2k3 Web-Edition. Der Server dient in der Hauptsache zur Aufnahme von Datenbank-und Filebackups meiner beiden Linux-Rootserver. Da die Hardware jedoch meistens ungenutzt läuft hatte ich für ein paar Freizeit-Spieler aus meinem Bekanntenkreis zwei Gameserver incl. Teamspeak2 darauf installiert. Eingerichtet war in beiden Fällen das Spiel "Vietcong", ist schon etwas älter .. aber erzeugt dafür auch keine große Last und meine Bekannten zocken es eben noch recht gerne. Installiert wurden die Binarys für die 2 ded. Server via srvany als Dienst .. damit konnte ich das ganze dann via PHP-Webinterface problemlos steuern (net start .. net stop etc.)

Soweit sogut, das ganze lief mit den beiden Vietcong-Gameservern mehr als 1/2 jahr recht problemlos .. kaum abstürze der gameserver und wenn dann durch eine fehlconfig im Webinterface .. das beeinträchtigte jedoch nicht den kompletten Server als solches. Fehlconfig beseitigen, beide Dienste neu starten .. fertig. Etwa zu Beginn 2008 habe ich dann das alte Win2k3 durch ein Win2k3 R2 Standard mit Plesk 8.2 für Windows ersetzt, da ich den kleinen Server noch als Ausfallsicherung einsetzen wollte und sich das ganze via Weboberfläche, auch für den Kunden administrieren lassen sollte. Kurz und gut, der kleine sollte als Fallbacksystem für den Notfall bereit stehen.

Was mir seitdem ungelöste Sorgen bereitet sind die Gameserver. Ich hatte diese vor etwa 8 Wochen ebenfalls wieder eingerichtet. Seitdem gibt es aber ständig und absolut nicht reproduzierbar Abstürze des kompletten Servers. Nach etwa 15min - ca.5 Std. stürzt der Server ab, es spielt dabei keine Rolle ob auf dem Gamserver gespielt wird oder nicht .. zuviel Last kommt also nicht in Frage. Zudem hatte ich die Kiste mit prime95 mehr als 3 Stunden gestresst (max. 40 Grad CPU-Temparatur) .. er blieb stabil. Der Server friert bei laufendem Gameserver ein und läßt sich nur via Reset über das Strato-Kundeninterface wiederbeleben. Ansonsten ist er komplett tot, weder HTTP, E-Mail oder Remotekonsole funktionieren .. einen PING beantwortet er auch nicht. Wenn der Server incl. Gameserver läuft läßt sich auch problemlos darauf spielen .. bis zum Absturz.

Installiert wurde das Spiel anfangs nicht, ich hatte wie schon beim ersten mal, quasi nur die Game-Files auf den Server kopiert. Mehr ist eigentlich auch nicht nötig da das ded. Serverbinary vcded.exe keine eingelegte cd bzw. Komplettinstallation verlangt. Nachdem die ersten Abstürze auftraten habe ich dann kurzerhand beide Game-CD´s als Nero-Image auf den Server kopiert und dort dann mittels Dämon-Tools gemountet sowie sauber installiert und gepatcht. Gebracht hat es rein gar nichts. Schlußendlich habe ich sogar wieder das ältere Win2k3 Web-Edition via Strato-Kundeninterface installiert .. der Effekt war ebenfalls gleich null .. Abstürze wie gehabt.

Ein Blick in die Logfiles der Ereignisanzeige ergibt rein gar nichts .. lediglich die Neustarts sind vermerkt, davor findet sich absolut nichts ungewöhnliches. Ich habe dann probiert das Spiel quasi manuell und nicht als Dienst zu starten. Zuerst mit den Rechten eines eigens dafür eingerichteten Benutzers "VCServer", schließlich als Administrator und selbst als SYSTEM (bei Start via Webinterface) bleibt das Ergebnis dasselbe .. kompletter Server-Absturz nach einiger Zeit. Ich habe schließlich die Installationspartition von Datenpartition D: auf Systempartition C: gewechselt und zuvor nochmals die CD-Images neu auf den server kopiert (Kopierfehler schließe ich aber aus) .. ebenfalls null effekt. Zuletzt habe ich noch den Teamspeak2-Dienst sowie den Webserver (IIS 6.0) außer Betrieb genommen, um evtl. Einflüsse von außen zu minimieren .. ebenfalls kein effekt, Abstürze wie gehabt. Ansonsten läuft derzeit keinerlei weitere Fremd-Software auf dem Server.

Strato konnte zwar bei einem "Test" keine Defekte feststellen .. nachdem ich aber IMHO wirklich alles ohne erfolg probiert habe, gehe ich langsam davon aus das dennoch irgendwo ein Hardwaredefekt vorliegt. Speicher, Grafik oder evtl. Treiber etc. schließe ich mal aus, denn wenn es einen Bluescreen geben sollte müsste die Kiste neu starten (ist so eingestellt) .. tut sie aber nicht. Ich habe das Binary in meiner Verzweiflung sogar mal über eine Sandbox (Sandboxie) gestartet .. selbst da gab es nach ca. 2 Std. einen, wie oben beschriebenen, Absturz.

Kurz und gut ihr seht mich ratlos und irgendwo packt mich auch der Ehrgeiz das Problem zu lösen zumal das ganze ja schon längere Zeit problemlos funktionierte. Hat jemand ideen wo ich evtl. noch ansetzen könnte?
Mitglied: Matthias3x
14.05.2008 um 22:34 Uhr
trotz keinerlei antworten von seiten der community möchte ich euch nicht vorenthalten was des rätsels lösung war.

offenbar hängt ensteht das problem durch den AMD Prozessortreiber und einer bestimmten einstellung in der energieverwaltung von win2k3.
also was hab ich gemacht, AMD prozessortreiber durch den von MS in win2k3 eingebauten ersetzt und über systemsteuerung -> energieoptionen das energieschema von "Server Balanced Processor Power an Performance" auf "Always on" gestellt. Server neu gestartet und fertig .. er läuft jetzt seit ca. 12 Stunden stabil.

Scheinbar verfängt sich das Spiel im verbund mit win2k3 und meiner speziellen hardware in einer endlosschleife bzw. hängt sich das system durch das dynamische heruntertakten des prozessors auf. das problem scheint sich zumindest auf A64 singlecores zu beschränken, ob das mainboard oder eine andere komponente noch eine rolle spielt kann ich nicht sagen .. jedenfalls hatte ich auf einem A64 X2 6000+ mit einem Asus m2n-vm und win2k3 standard keine probleme mit dem spiel .. naja wie dem auch sei .. kleine ursache große wirkung.
Bitte warten ..
Ähnliche Inhalte
Server
Administrator Hetzner Root Server
gelöst Frage von MisterDServer4 Kommentare

Guten Tag, ich habe einen Hetzner Root Server und benötige eine Firma, die den derzeitigen Administrator ablöst .

Linux

Limitierte Verbindung zum eigenen root Server

gelöst Frage von 4everGhostLinux3 Kommentare

Ich besitze einen root Server bei Hetzner mit dem ich eigentlich auch recht zufrieden bin. Seit einem viertel Jahr ...

Debian

Welche Root Server Backup Strategie nutzen?

gelöst Frage von darkonrwDebian4 Kommentare

Hallo liebes Forum, ich habe eine Frage zu einer Sicherungsstrategie für einen Root- Server. Folgendes schwebt mir vor: 1. ...

DNS

Teamspeak Server auf root - Server, Domain bei Provider und alles hinter Cloudflare

gelöst Frage von TomPiXXDNS2 Kommentare

Hallo Gemeinde, ich habe Probleme, folgendes Szenario umzusetzen: Ein Teamspeak Server wird auf einem unser Root Server bei Hetzner ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 12 StundenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 2 TagenHumor (lol)5 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 2 TagenExchange Server8 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 3 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
Netzwerke
Netzwerk-Architektur mit VLANs
Frage von niLuxxNetzwerke47 Kommentare

Liebe Community, Ich hätte eine kurze Frage an euch. Ich werde in Kürze das Netzwerk unserer (sehr) kleinen Firma ...

Netzwerke
SSH - Wieso werde ich nach VPN Verbindung rausgeschmissen?
Frage von VernoxVernaxNetzwerke10 Kommentare

Hallo, ich habe es endlich geschafft mein Handy mit einer VPN Verbindung an meinen Router anzuschließen. Nach der Login ...

Windows 10
VPN Verbindung Android - Win10 funktioniert nach Update auf Android 8 Oreo nicht mehr
gelöst Frage von OnleinWindows 108 Kommentare

Hallo, SETUP: Ich habe unter Win10 (up to date) einen VPN Server eingerichtet (Eingehende Verbindung). In meinen Routern habe ...

Windows Server
Freigaben per Default nur für Domänen-Benutzer
Frage von tierwoWindows Server8 Kommentare

Hallo gibt es eine Möglichkeit, einen Server 2016 so zu konfigurieren (z.B. per GPO), dass Freigaben die erstellt werden ...