Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Windows 2003 Server - NETLOGON verändern klappt nicht

Mitglied: 69465

69465 (Level 1)

10.09.2008, aktualisiert 11.09.2008, 5956 Aufrufe, 8 Kommentare

Das Ändern eines Netzlaufwerk-Mappings in NETLOGON funkioniert nicht.

Hallo zusammen,

habe einen PDC ("SERVER_1") und auf diesem (bzw. im AD) befindet sich ja das NETLOGON und darin die NETLOGIN.BAT. Dort habe ich folgendes stehen:

@ECHO OFF
net use h: \\SERVER_2\%USERNAME%
net use g: \\SERVER_2\DATEN


Es wird also bei jedem Login von einem bestimmten Server ("SERVER_2") das entsprechende Userverzeichnis und das Datenlaufwerk gemountet (und zwar zu den Buchstaben h und g). Klappt wunderbar.

Nun zum Problem: wenn ich "SERVER_2\DATEN" auf "SERVER_3\DATA" ändere, und speichere, wird auf den Clients immer noch das ursprüngliche Laufwerk gemountet... Auch das Neustarten der Server bringt nichts.

Was mache ich falsch, wo liegt der Fehler? Wäre super, wenn mir jemand weiterhelfen könnte.

Danke und Grüße,
Squirrel 3G
Mitglied: langerwo
10.09.2008 um 20:50 Uhr
Hallo,

bin mir nicht sicher aber probiers mal mit

@ECHO OFF
net use h: /delete
net use g: /delete
  1. damit löscht du erst mal die bestehen den verbindungen ( auch die die presistant sind bzw schon # einmal bestanden haben

net use h: \\SERVER_2\%USERNAME%
net use g: \\SERVER_2\DATEN
Bitte warten ..
Mitglied: 69465
10.09.2008 um 21:30 Uhr
Hi langerwo,

suuuuper! Funktioniert!!

Ganz wichtig: das Leerzeichen zwischen dem Laufwerksbuchstaben und dem /delete...

Grüße,
Squirrel
Bitte warten ..
Mitglied: 51705
10.09.2008 um 22:21 Uhr
Hallo Squirrel,

alternativ:

net use h: \\SERVER_2\%USERNAME% /PERSISTENT:NO

Grüße, Steffen
Bitte warten ..
Mitglied: TuXHunt3R
10.09.2008 um 22:27 Uhr
Oder, um die Sache zu komplementieren, wenn du alle Netzlaufwerke auf einmal löschen willst:
01.
net use * /delete /y
Bitte warten ..
Mitglied: 69465
10.09.2008 um 22:30 Uhr
Cool, danke euch für die Ergänzungen!

@tuxhunter: was bedeutet denn das "/y"-flag?

Danke und Grüße,
Squirrel
Bitte warten ..
Mitglied: 51705
10.09.2008 um 22:46 Uhr
Hallo,

net use * /delete /y

hat den Nachteil, daß zusätzliche Netzlaufwerke, welche mit der Option 'bei Anmeldung wiederherstellen' gemountet werden, eben bei Anmeldung getrennt werden.

Grüße, Steffen
Bitte warten ..
Mitglied: TuXHunt3R
11.09.2008 um 09:35 Uhr
@ srmerlin

Stimmt


@ squirrel-3g

Der Parameter /y ist undokumentiert und stammt noch aus DOS-Zeiten. Er beantwortet allfällige Ja/Nein Fragen einfach mit Ja. In meinem Loginscript habe ich es so gemacht.
Bitte warten ..
Mitglied: 69465
11.09.2008 um 14:11 Uhr
...ahhhhh natürlich! Danke für die Antwort.

Grüße,
Squirrel
Bitte warten ..
Ähnliche Inhalte
Windows 10

Windows 10 kein Zugriff auf Server 2012 Netlogon

gelöst Frage von Chris-75Windows 108 Kommentare

Hallo, hat schon jemand mit der RTM-Version von Windows 10 Pro x64 probiert auf einem Windows 2012R2 Server auf ...

Windows Server

Schreibrechte im Netlogon

Frage von uridium69Windows Server5 Kommentare

Hallo zusammen Ich sehe gerade das auf dem Netlogon \\domäne\netlogon jeder schreiben und löschen kann, sollte das nicht auf ...

Windows 10

Windows 10 update klappt nicht

Frage von Thor01Windows 1011 Kommentare

Hallo, versuche seit vorgestern mein Kostenloses Update von 8.1 auf 10 durchzuführen. Das ganze nach dieser Anleitung: Das Update ...

Netzwerkmanagement

Zugriff auf FTP-Server durch Chrome in Windows 7 klappt nicht

Frage von emilien2Netzwerkmanagement3 Kommentare

Hallo geschätzte Helfer, ich habe folgende Schritte ausgeführt, um auf meinem Windows 7 Home Premium Desktop Rechner einen FTP-Server ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement19 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen17 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Router & Routing
VPN hinter zweiter Fritzbox nutzen im Nachbarhaus
gelöst Frage von georg2204Router & Routing11 Kommentare

Hallo zusammen, ich blicke hier leider nicht mehr so ganz durch. In Haus 1 steht eine Fritzbox 7390, diese ...