Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Windows Server 2008 R2 Netzwerkperformance lässt zu wünschen übrig

Mitglied: el111

el111 (Level 1) - Jetzt verbinden

28.11.2011 um 12:58 Uhr, 5659 Aufrufe, 12 Kommentare, 1 Danke

Hallo zusammen,

ich habe folgendes problem: wir haben einen Windows Server 2008 R2 mit mehreren Netzwerkkarten. Problem ist, dass der Netzwerkdurchsatz nicht zufriedenstellend ist. Beispiel an einer GBit-Karte: Wenn ich vom Win7-PC ein Testfile mit 2,5GB auf den Server kopiere, komme ich maximal an 40 MB/s. Ziehe ich die gleiche Datei vom Server, komme ich auf maximal 50 MB/s. Die Ergebnisse von NetIO anbei:

W7-Client -- Server 2008 R2

Packet size 1k bytes: 7589.50 KByte/s Tx, 6210.03 KByte/s Rx.
Packet size 2k bytes: 10.87 MByte/s Tx, 11.18 MByte/s Rx.
Packet size 4k bytes: 17.84 MByte/s Tx, 21.54 MByte/s Rx.
Packet size 8k bytes: 25.38 MByte/s Tx, 35.71 MByte/s Rx.
Packet size 16k bytes: 36.83 MByte/s Tx, 53.48 MByte/s Rx.
Packet size 32k bytes: 44.80 MByte/s Tx, 84.25 MByte/s Rx.

Hier nochmal das gleiche von meinem W7-Client zu einem frisch aufgesetzten Windows Server 2008 R2:

W7-Client -- Testserver 2008 R2

Packet size 1k bytes: 37.67 MByte/s Tx, 66.98 MByte/s Rx.
Packet size 2k bytes: 67.06 MByte/s Tx, 57.30 MByte/s Rx.
Packet size 4k bytes: 92.36 MByte/s Tx, 80.19 MByte/s Rx.
Packet size 8k bytes: 83.41 MByte/s Tx, 82.09 MByte/s Rx.
Packet size 16k bytes: 90.24 MByte/s Tx, 77.76 MByte/s Rx.
Packet size 32k bytes: 92.37 MByte/s Tx, 84.43 MByte/s Rx.

Ich habe schon diverse Konfigurationen vorgenommen, die unter www.speedguide.net zu finden sind. Den TCP/IP Optimizer von genannter Seite habe ich auch schon angewandt, keine Besserung.
Als Antivirenprogramm ist avast installiert, war auch testweise deaktiviert, keine Besserung. Treiber sind die aktuellsten installiert und das Problem tritt bei allen Netzwerkinterfaces auf.

netsh int tcp show global gibt mit dem momentanen Konfiguration folgendes aus:

Globale TCP-Parameter
Empfangsseite : enabled
Chimney-Abladestatus : enabled
NetDMA-Status : enabled
Direkter Cachezugriff (DCA) : enabled
Autom. Abstimmungsgrad Empfangsfenster : normal
Add-On "Überlastungssteuerungsanbieter" : ctcp
ECN-Funktion : disabled
RFC 1323-Zeitstempel : disabled

Aber wie geschrieben, habe ich hier schon andere Konfigurationen ausprobiert ohne Erfolg.
Falls ich etwas relevantes vergessen habe, werde ich das natürlich nachposten ;)

Danke schonmal für eure Zeit
Viele Grüße
Erik
Mitglied: lenny4me
28.11.2011 um 13:17 Uhr
Hallo,

tritt das Problem nur zwischen dienem Client und dem Server auf oder immer?
sind die Platten vom Server vielleicht das Problem (wobei die Werte dann sehr sehr gering wären)
Nic Treiber aktualisiert?

Grüße
Bitte warten ..
Mitglied: el111
28.11.2011 um 13:32 Uhr
Hallo lenny4me,

also der Server ist ein Fileserver mit 2x40 TB Raid 6, Raid zu Raid-Kopierungen laufen mit 500-600 MB/s , NIC-Treiber sind die aktuellsten drauf, Problem tritt von allen Clients auf, Windows7, Windows XP, Linux.
Bei den Ergebnissen von oben geht der Test über mehrere Switche, aber auch wenn ich mich direkt an den Server hänge bekomme ich keine anderen Resultate.

Viele Grüße
Erik
Bitte warten ..
Mitglied: Pjordorf
28.11.2011 um 13:41 Uhr
Hallo,

Zitat von el111:
aber auch wenn ich mich direkt an den Server hänge bekomme ich keine anderen Resultate.
Das lässt dann die Frage nach dem Serverboard (Onboard NIC) und treiber sowie deines verwendeten W7 Clients aufkommen. Kann dein Server (Client) überhaupt die von dir geforderte Geschwindigkeit liefern? Nein, ich meine nicht das du dort eine 1 GB NIC drauf hast Hast du ein GBit fähiges Patchkabel beim direkten verbinden deines W7 Clients am Server genutzt? Nenn Fakten.

Gruß,
Peter
Bitte warten ..
Mitglied: Ravers
28.11.2011 um 13:41 Uhr
Moin moin,

also Switche fallen schonmal weg, lokal sind die Werte OK ?? ... davon ausgehend - Checke das Netzwerkkabel, ob dies ein Kabelbruch o.ä. hat.

Wenn du von dem Server auf einen anderen Server drauf zugreifst, sind die Werte immer noch so schwach??

greetz
ravers
Bitte warten ..
Mitglied: AndiEoh
28.11.2011 um 14:10 Uhr
Manche NICs sind nicht wirklich in der Lage GBit zu liefern. Einfach mal auf beiden Seiten einen hochwertigen NIC z.B. von Intel verwenden. Ansonsten noch prüfen ob auf einer der beteiligten Stationen zusätzliche Filtertreiber wie z.b. Personal Firewall oder des Virenscanners aktiv sind. Beim "deaktivieren" des Scanners wird oft nur die Ausleitung an den Scanner, aber nicht der Filter deaktiviert.
Bitte warten ..
Mitglied: NetWolf
28.11.2011 um 15:38 Uhr
Moin Moin,

das Übliche: eine Deaktivierung des Anti-Virus-Programms bringt nichts! Erst eine Deinstallation bringt eine Änderung!
Das sollte dann auf beiden Seiten = Server und Client durchgeführt werden.

Bei direkter Verbindung Client <-> Server nutzt du min. ein CAT 5 Patchkabel?
Der Client ist kein Notebook mit onBoard Netzwerkkarte?

Grüße aus Rostock
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: nEmEsIs
28.11.2011 um 15:46 Uhr
Hi

Schon einmal versucht die nic fest auf 1000 Mbit zu setzten im Gerätemanager bzw. Treiber?

MfG Nemesis
Bitte warten ..
Mitglied: el111
28.11.2011 um 16:06 Uhr
Hallo zusammen,

ich danke für die zahlreichen Vorschläge, das Problem ist gelöst, danke Wolfgang. Wie du richtig angemerkt hast bringt eine Deaktivierung des Anti-Virus-Programms nichts, erst nach einer Deinstallation hatte ich gute Ergebnisse!
Hier nochmal für die interessierten das Ergebnis nach der Deinstallation von avast:

Packet size 1k bytes: 37.57 MByte/s Tx, 30.39 MByte/s Rx.
Packet size 2k bytes: 65.62 MByte/s Tx, 61.18 MByte/s Rx.
Packet size 4k bytes: 78.11 MByte/s Tx, 99.98 MByte/s Rx.
Packet size 8k bytes: 82.45 MByte/s Tx, 99.93 MByte/s Rx.
Packet size 16k bytes: 92.90 MByte/s Tx, 96.43 MByte/s Rx.
Packet size 32k bytes: 98.13 MByte/s Tx, 102.45 MByte/s Rx.

Die 2,5GB-File kopiert mit 91 MB/s. Ich bin sehr zufrieden, jetzt kann man vielleicht mit Feintuning noch ein paar MB rausholen.

Danke & Viele Grüße
Erik
Bitte warten ..
Mitglied: lenny4me
28.11.2011 um 16:55 Uhr
2x40 TB Raid 6

Hübsch ^^
Bitte warten ..
Mitglied: nEmEsIs
28.11.2011 um 17:47 Uhr
Hi

Jetzt aber mal ne Frage bei 2x 40 TB macht es da Sinn mit nur einer GBit Karte drauf zu gehen??
Warum machst du nicht nen Trunkling / Teaming ?? Mit mehreren Karten bzw. Gehst nicht gleich mit Glasfaser auf den Backbone Switch?

MfG
Nemesis
Bitte warten ..
Mitglied: el111
28.11.2011 um 18:01 Uhr
Hi Nemesis,

keine Angst, die GBit-Karten sind nur für das Hausnetz, zum Austausch von kleineren Files. Die großen Daten werden über 10 Gig Ethernet draufgeschoben. Aber wenn ich schon grad nochmal schreibe, kann wer nen guten (performanten) Virenscanner für W2k8 empfehlen?

Viele Grüße
Erik
Bitte warten ..
Mitglied: lenny4me
28.11.2011 um 21:03 Uhr
Hallo,

wir setzen für die gesamte Firma Trend Micro Office Scan ein.
Hast du dann die Storage Version von Windows im Einsatz?

Grüße
Bitte warten ..
Ähnliche Inhalte
Windows Server

Windows 2008 R2 Server und Verbindungsabbrüche

gelöst Frage von mike7050Windows Server21 Kommentare

Hallo, habe einen Windows Server 2008 R2 neu inst. vor zwei Wochen. Der Server hat eine feste Ip und ...

Windows Server

Windows Server 2008 R2 Foundation

Frage von MiStWindows Server21 Kommentare

Hallo, wir bekommen ein neues ERP-System. Jetzt brauche ich einen Server auf dem die -Datenbank drauf liegt. Mein Idee ...

Windows Server

Firebird Server unter Windows 2008 R2 lässt sich nicht per Script beenden

gelöst Frage von BWeber1988Windows Server1 Kommentar

Moin moin, ich habe folgendes Problem: Zwecks einer Backup-Prozedur beende ich auf einem Windows 2008 R2 Server den Dienst ...

Windows Server

Server 2008 R2 - Windows Search Suchindex lässt Dateien aus!

gelöst Frage von eastfrisianWindows Server2 Kommentare

einen schönen samstag wünsche ich euch allen! ich habe hier mal wieder ein kurioses Problem. wird bestimmt lösbar sein, ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement18 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen17 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Router & Routing
VPN hinter zweiter Fritzbox nutzen im Nachbarhaus
gelöst Frage von georg2204Router & Routing11 Kommentare

Hallo zusammen, ich blicke hier leider nicht mehr so ganz durch. In Haus 1 steht eine Fritzbox 7390, diese ...