Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Startscript, kann das funktionieren?

Mitglied: ChrisDynamite

ChrisDynamite (Level 2) - Jetzt verbinden

04.08.2013 um 11:50 Uhr, 2794 Aufrufe, 10 Kommentare

Guten Tag,

folgende Frage an Diejenigen, welche Erfahrungen mit einem Startscript bei Windows Domänen haben:

In einer Batch Datei (*.bat) habe ich festgelegt, dass von einem UNC Pfad (\\servername\freigabename\) per call eine exe aufgerufen wird und diese silent ausgeführt wird. danach in einer bedingung geprüft wird, ob die vorgängerversion existiert und geg. ein sp und danach per gleicher abfrage ein hotfix installiert wird. das funktioniert lokal prima. das heißt: 1 Click auf eine Bat und 1 exe mit 2 neuen Updateständen werden installiert und anschließend die desktopsymbole per copy dort hinzugefügt.

nun habe ich die bat als startscript hinzugefügt, per gpoupdate die richtlinie erfasst und per gpresult geprüft. alles ok, aber das startscript wird nicht ausgeführt.

Frage 1: passt irgendwas nicht?
Frage 2: wird das startscript als domänenadmin ausgeführt
frage 3: meiner meinung nach wird das script VOR der anmeldung des jeweiligen nutzers ausgeführt. ist das auch korrekt?

grüße

Chris
Mitglied: colinardo
04.08.2013, aktualisiert um 20:29 Uhr
Hallo Chris,
Wenn dein Script als Startscript läuft und nicht als Anmeldescript, läuft es im Kontext von LocalSystem, d.h. in diesem Zustand greift das System nur mit dem Computeraccount auf das Netzwerk zu. Du musst dem "Computer Account" des Rechners explizit Zugriffsrechte auf die Freigabe erteilen damit es auf das Programm zugreifen kann. Startscripte werden noch vor der Anmeldung ausgeführt, d.h. noch bevor die Anmeldemaske erscheint.

Grüße Uwe
Bitte warten ..
Mitglied: ChrisDynamite
05.08.2013 um 08:37 Uhr
danke für die antwort.
es würde nicht reichen den computer in eine sicherheitsgruppe aufzunehmen und diese sicherheitsgruppe den zugriff auf die freigabe zu gewähren?

grüße chris
Bitte warten ..
Mitglied: colinardo
05.08.2013 um 09:29 Uhr
Klar das kannst du natürlich auch machen ....
Bitte warten ..
Mitglied: DerWoWusste
05.08.2013 um 13:11 Uhr
Hi.

Auch die Gruppe "authenticated users" enthält schon alle Domänencomputer, nur für den Fall, dass sie bereits berechtigt ist.
Bitte warten ..
Mitglied: ChrisDynamite
05.08.2013 um 16:33 Uhr
ich teste das aus und gebe bescheid. bis jetzt funktioniert es nur, wenn ich explizit den computer hinzufüge.
Bitte warten ..
Mitglied: colinardo
05.08.2013, aktualisiert um 21:13 Uhr
Zitat von DerWoWusste:
Auch die Gruppe "authenticated users" enthält schon alle Domänencomputer,
das wäre mir neu, das sich alle Computeraccounts in dieser Gruppe befinden. Deshalb heißt sie ja auch "Authenticated Users" und nicht "Authenticated Computers".
Das Startscript läuft ja bevor sich überhaupt jemand am Rechner eingeloggt hat. Und da kann sich der Rechner ja im Netzwerk nur mit seinem Computeraccount ausweisen. Also entweder der Sicherheitsgruppe Domain Computers dieser Freigabe Zugriffsrechte erteilen, oder selber eine erstellen und die benötigten Computer-Accounts hinzufügen.
feddich
Bitte warten ..
Mitglied: DerWoWusste
05.08.2013, aktualisiert um 18:32 Uhr
Doch, es enthält auch die Computer. http://www.google.de/search?q=Authenticated+Users#sclient=psy-ab&q= ...
Edit: und ja, der Computer hat sich zu dem Zeitpunkt bereits schon authentifiziert.
Bitte warten ..
Mitglied: colinardo
05.08.2013 um 21:12 Uhr
Zitat von DerWoWusste:
Doch, es enthält auch die Computer.
Ah now i see... danke für die Info. Das nenn ich mal irreführende Bezeichnung. Ich glaub für die Tuppen bei Microsoft sind die Rechner auch schon User, womöglich reden die sogar mit denen -- was für eine Horrorvorstellung
Bitte warten ..
Mitglied: ChrisDynamite
12.08.2013 um 11:15 Uhr
Guten Tag,

egal welche Einstellung ich auch verwende, ich habe alles versucht bez asynchron, nicht asynchron.... welche einstellung verhilft mir dazu, dass erst das startscript ausgeführt wird und danach die anmeldemaske kommt? immer passiert das
61d75d1f5e1a7c7e84ea694b88c83838 - Klicke auf das Bild, um es zu vergrößern
und ich drücke auf anmelden und das sript wird übersprungen und später nach der anmeldung im hintergrund ausgeführt.

der anwender wartet natürlich nicht bis das schwarze fenster weg ist, sondern meldet sich gleich an.

freundliche grüße chris
Bitte warten ..
Mitglied: colinardo
12.08.2013, aktualisiert um 11:41 Uhr
Zitat von ChrisDynamite:
egal welche Einstellung ich auch verwende, ich habe alles versucht bez asynchron, nicht asynchron.... welche einstellung verhilft
mir dazu, dass erst das startscript ausgeführt wird und danach die anmeldemaske kommt?

Lese mal das:
https://www.administrator.de/forum/gpo-windows-7-startskript-l%C3%A4uft- ...
Administrative Vorlagen > System > Scripts > Startscripts asynchron ausführen  = "Deaktivieren"
Administrative Vorlagen > System > Scripts > Startscripts sichtbar ausführen  = "Deaktivieren"
Normalerweise steht im Dialog "Startscripts werden ausgeführt" und kein DOS-Fenster ist sichtbar, und erst wenn das Script fertig ist erscheint die Anmeldemaske. Hierbei lässt sich in den GPO auch noch eine maximale Laufzeit für Start-Scripts festlegen(Windows wartet standardmäßig maximal 10 Minuten). Da hasst du wohl vollkommen falsche GPOs-Einstellungen gesetzt. Starte nochmal mit einer sauberen GPO, in der nur das Startscript angegeben ist, und überprüfe ob in anderen GPOs Einstellungen bezüglich Startscripts gesetzt sind.

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Windows Server

Startscript wird nicht überall ausgeführt

Frage von Thor01Windows Server5 Kommentare

Hallo, habe einer bestehenden Domäne einige neue PCs hinzugefügt und diese in die passenden OUs gesteckt. Verwunderlich ist jetzt, ...

Windows Server

Startscript erfordert bei Windows Clients aufeinmal andere Rechte

Frage von staybbWindows Server1 Kommentar

Hallo zusammen, wir haben bei uns ein Startscript als .cmd auf dem Domäncontroller liegen, welches von Windows 7 und ...

Windows Server

Windows 10 GPOs funktionieren nicht

gelöst Frage von slanskyWindows Server19 Kommentare

Hallo Leute, ich habe das Problem das die GPOs für Windows 10 in meiner Umgebung nicht funktionieren. Meine Umgebung: ...

Linux

Startscript PID statt PPID

gelöst Frage von schneerunzelLinux5 Kommentare

Hallo zusammen, ich habe auf Grundlage des Beispiels ein Startscript für Java Applikation geschrieben nun habe ich folgendes Problem ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 10 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 16 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...