Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Winsock- und-oder TCPIP-Problem...

Mitglied: telefix1

telefix1 (Level 1) - Jetzt verbinden

29.01.2008, aktualisiert 09.04.2010, 6911 Aufrufe

Hallo Forum, hier wieder ein Problem zum Kopfzerbrechen:

Die Umgebung:

Router als Gateway
192.168.178.1
stat. Route_1:
192.168.178.31
255.255.255.0
193.169.178.0

(Server
Printserver
div. andere Peripherie)

Mobiler Kassen-PC XP Pro SP2 - alle "wichtigen" Updates außer IE7

NIC1 WLAN US Robotics
WZCSVC-Dienst ist autom. gestartet, außer Treiber keine weitere Karten-SW installiert.
stat. IP 192.168.178.31
Mask 255.255.255.0
Gateway 192.168.178.1
DNS 192.168.178.1

NIC2 on board SiS 900
stat. IP 193.169.178.1
Mask 255.255.255.0
kein Gateway
kein DNS

An NIC2 steckt ein Kreditkarten-Terminal
stat. IP 193.169.178.40
Mask 255.255.255.0
Gateway 193.169.178.1

Intranet und Internet funktionieren einwandfrei, d.h. Ping aus der Konsole in alle Richtungen, ipconfig /all zeigt alles von MAC-Adresse bis DNS-Server an - BIS ZU EINEM NEUSTART.

Danach haben die NIC´s keine Konnektivität mehr. Die Einstellungen in den TCP/IP-Protokoll-Eigenschaften sind zwar noch vorhanden, können aber nicht mehr ausgelesen werden. Ping funktioniert nicht mehr, ipconfig /all-Protokoll ist LEER.

Also beide NIC´s deinstalliert, neu installiert und mit den o.g. Parametern konfiguriert. Danach wieder alle Funktionen - BIS ZU EINEM NEUSTART.

Also googlen, lesen, googlen, lesen, googlen, lesen...

...aha, wahrscheinlich Winsock/TCPIP-Protokoll kompromittiert. Also zu Fuß lt. MS-Knowledgebase "netsh int ip reset" durchgeführt, die Registry gesäubert, das Protokoll neuinstalliert (ja, ich weiss, es geht auch mit winsockxpfix, aber man gönnt sich ja sonst nichts...), die tcpip.sys aus einem intakten System kopiert, die NIC´s neu installiert und parametriert und alles funktioniert - BIS ZU EINEM NEUSTART.

Ok., jetzt von unten: Reparaturinstallation, Neustart, ALLE Updates neu, NIC´s neu installiert und parametriert und alles funktioniert - BIS ZU EINEM NEUSTART.

Ich habe 5 identische Kassensysteme mit EXAKT der gleichen Hard- und Softwarekonfiguration (IP-Adressen natürlich nicht! ). Die Clients haben zwar Internetzugang, sind aber (mit an Sicherheit grenzender Wahrscheinlichkeit) sauber. Ich habe keinen Proxy, die Einstellungen sind aber sehr restriktiv. 4 Systeme funktionieren mit der o.g. Konfiguration, das 5. zickt...

Ich hoffe, die Infos reichen für eine Betrachtung und Fehleranalyse aus und bitte hiermit um Eure Hilfe.

Achso, XP neu aufsetzen möchte ich nicht - jetzt sehe ich es als Herausforderung...

MfG. telefix1

EDIT 06.02.2008

Habe das Problem für mich gelöst, obwohl ich mit der Art und Weise eigentlich nicht ganz zufrieden bin:

Also, das "Phänomen" tritt immer auf, wenn ich den NIC´s statische IP´s verpasse.

Bei ausgeschaltenem DHCP-Client-Dienst bekommen die NIC´s eine vom System generierte Adresse. Diese generierten Adressen habe ich in der Registry manipuliert und meinem Netz angepasst.

Wie gesagt, nicht ganz konventionell, aber es hilft mir über den Tag
Ähnliche Inhalte
Windows Server

Etwas schräges Problem im TCPIP (Windows Server)

gelöst Frage von emeriksWindows Server8 Kommentare

Hi, ich brauche mal ein paar Denkanstöße: Windows Server 2008 R2 VMware VM Version 7 1x NIC vmxnet3 AD-Mitglied, ...

Windows Netzwerk

Problem mit TCPIP Verbindung von Virtuellen Servern (HYPER V)

Frage von samet22Windows Netzwerk2 Kommentare

Hallo Leute, Habe ein SEHR komisches Problem. In meiner Firma haben wir Zeit-stempel-Terminals welche alle 3 Stunden abgerufen werden. ...

Windows Server

SBS 2011 erkennt TCPIP Port für Drucker nicht

gelöst Frage von BadgerWindows Server14 Kommentare

Hallo Leute, - Druckserver: SBS 2011 - Drucker: Tally Dascom 2600 - Netzinterne Firewall gibt es nicht - Der ...

SAN, NAS, DAS

FibreChannel-Karte (also SAN-FC, nicht TCPIP) für PCIe x1 gesucht

Frage von broeckerSAN, NAS, DAS

Moin, (nur für Ausbildungszwecke) suche ich eine solche Karte, eine Modell-Bezeichnung wäre natürlich auch schon hilfreich, alternativ: hilft ein ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 12 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 12 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 1 TagSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
gelöst Frage von YellowcakeExchange Server23 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server13 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...