Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst WSUS: Nicht alle Computer erkannt

Mitglied: S1c3r

S1c3r (Level 1) - Jetzt verbinden

07.08.2006, aktualisiert 09.08.2006, 20392 Aufrufe, 11 Kommentare

Lösung im letzten Thread!!!

Guten Tag

Ich betreibe einen WSUS Server, wo Win XP, W2K, W2KS und W2K3S geupdatet werden.
Im Moment sind 60 Clients und 4 Server erfasst.

Leider habe ich mit ca. 10 Arbeitsstationen (W2K und XP) das Problem, dass diese einfach nicht vom WSUS Server erkannt werden.

Das komische ist, dass bereits so viele erkannt wurden und auch funktionieren.

Probleme auf den einzelnen Clients kann ich eigentlich auch ausschliessen.
Die Updates können Problemlos über die Windows Update Webseite gemacht werden, die Computer sind alle ziemlich auf dem neusten Stand (SPs überall aktuell) und ich habe auch überall die WinUpdRestore laufen lassen (gibt es hier: [url]http://www.mshelper.de/sites/regists.html[/url]) zudem dieses Script auf den Clients ausgeführt:
Regsvr32 MSXML3.dll
net stop wuauserv
regsvr32 /u wuaueng.dll
regsvr32 wuaueng.dll
net start wuauserv
wuauclt.exe /resetauthorization /detectnow

Und zum Schluss noch gecheckt:
WSUS Client Diagnostics Tool

Checking Machine State
Checking for admin rights to run tool . . . . . . . . . PASS
Automatic Updates Service is running. . . . . . . . . . PASS
Background Intelligent Transfer Service is not running. PASS
Wuaueng.dll version 5.8.0.2469. . . . . . . . . . . . . PASS
This version is WSUS 2.0

Checking AU Settings
AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
Option is from Policy settings

Checking Proxy Configuration
Checking for winhttp local machine Proxy settings . . . PASS
Winhttp local machine access type
<Direct Connection>
Winhttp local machine Proxy. . . . . . . . . . NONE
Winhttp local machine ProxyBypass. . . . . . . NONE
Checking User IE Proxy settings . . . . . . . . . . . . PASS
User IE Proxy. . . . . . . . . . . . . . . . . NONE
User IE ProxyByPass. . . . . . . . . . . . . . NONE
User IE AutoConfig URL Proxy . . . . . . . . . NONE
User IE AutoDetect
AutoDetect not in use

Checking Connection to WSUS/SUS Server
WUServer = [url]http://wsus[/url]
WUStatusServer = [url]http://wsus[/url]
UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
Connection to server. . . . . . . . . . . . . . . . . . PASS
SelfUpdate folder is present. . . . . . . . . . . . . . PASS

Press Enter to Complete
Der Port wurde auf den Default (80) gesetzt, womit ich also keinen angeben muss!

Mit der Gruppenrichtlinie habe ich soweit keine Probleme, wenn ich nämlich unter Arbeitsplatz-->Eigenschaften-->Automatische Updates schaue wurde dort die Einstellung "Täglich um 12.00" übernommen.

Ich habe den Client auch schon neu zur Domäne hinzugefügt, wodurch es eigentlich auch nicht am Computerkonto liegen sollte.

Ich weiss beim besten Willen nicht mehr weiter...

Danke für eure Hilfe!

glg

//-->
Lösung im letzten Thread!!!
Mitglied: Maggus
07.08.2006 um 11:31 Uhr
Hi,

was für ein SP haben die 10 Clients denn?

Bei W2k muss SP4 installiert sein und bei XP sollte der aktuelle Windows Installler installiert sein. Das es über Windows Update geht heisst noch nicht unbedingt, dass es mit WSUS auch gehen muss. Hatte mit einem Client auch mal das Problem, da gab es Probleme mit dem Automatischen Update Dienst und dem BITS 2.0. Manchmal dauert es auch länger. Unter www.wsus.de gibt es Tools zum Download für solche Probleme.

MfG
Maggus
Bitte warten ..
Mitglied: kr1eger
07.08.2006 um 11:42 Uhr
Hallo,

falls es sich um geimagte clients handelt, bei denen der WSUS-Client mitgeimaged wurde, bekommen die clients eine WSUSid, die bei allen gleich ist und den anschein erweckt, der client hinge nich am WSUS


Einfach mal das logfile c:\windows\Windows Update.log überprüfen, ob der client nicht doch am WSUS hängt!


Falls doch, hier die Lösung:

1. Batchdatei erstellen:

net stop wuauserv
regedit /S WSUSClientRepair.reg
net start wuauserv
wuauclt.exe /resetauthorization /detectnow

2. Regdatei (wsusclientrepair.reg) erstellen:



REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate]
"AccountDomainSid"=-
"PingID"=-
"SusClientId"=-


3. Beide dateien in ein folder auf dem client kopieren und batch ausführen.


Hoffe, ich konnte Dir damit weiter helfen


grüsse

kr1eger
Bitte warten ..
Mitglied: Arma-Geddon
07.08.2006 um 11:48 Uhr
Servus,
Ich hatte ein ähnliches Problem. Aber bei mir lag es daran dass ich SUS hatte. Aber WSUS einfach installiert habe, auf einem anderen Server. Solltest du auch ungefähr ähnliche Konsellation gehabt haben/haben.

REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /f

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /f

machen und schon authentifizieren sich die Kisten. Aber halt nur wenn du vom SUS auf WSUS gemacht hast.

MfG
Arma
Bitte warten ..
Mitglied: S1c3r
07.08.2006 um 12:17 Uhr
W2K: SP4
XP: SP2

Also den BITS 2.0 hab ich auf allen Maschinen deaktiviert. Und der sollte auch keine Rolle beim erkennen spielen. Der würde dann wohl eher im Bezug bei fehlerhaften Updateinstallationen zum Zug kommen.
Die Tools helfen mir leider auch nicht weiter .

Und der Automatische Update Dienst hab ich heute noch einmal über Win Update Seite aktualisiert.

Aber vielen Dank für die Tipps. Ich habe den BITS 2.0 nun bei einer Maschine mit den Problemen aktiviert. Vielleicht könnte es ja trotzdem helfen...

glg
Bitte warten ..
Mitglied: S1c3r
07.08.2006 um 12:22 Uhr
Danke für die vielen Hilfestellungen!
Ich werde das ganze Testen und danach Bescheid sagen!

glg
Bitte warten ..
Mitglied: S1c3r
07.08.2006 um 16:43 Uhr
Was ich seit dem letzen Post gemacht habe:

Also auf dem einen Client hatte ich Probleme mit dem WMI Dienst und wenn dies so ist, kann sich dieser nicht mit dem WSUS Server synchronisieren, da er keine OS Informationen sendet.

Also Muss man diesen Dienst stoppen:
net stop winmgmt

Danach den Ordner "repository" unter system32\wbem löschen.

Den Dienst wieder starten:
net start winmgmt

Danach Start-->Ausführen-->Wbemtest.exe --> Verbinden mit den Default Einstellungen und der Ordner wird wieder erstellt.

Da der Client, wenn er schon im WSUS aufgelistet ist als Unknown bezeichnet wird muss man noch den Ordnerinhalt Softwaredistribution löschen.

Am besten man verwendet das Script:
REM Stop the Automatic Updates service
net stop wuauserv

REM Stop the Windows Management Instrumentation service
net stop winmgmt

REM Backup ReportingEvents.log. Then, delete the contents of
REM %systemroot%\SoftwareDistribution and
REM %systemroot%\system32\WBEM\Repository
copy %systemroot%\softwaredistribution\reportingevents.log %homedrive%\
del /f /q %systemroot%\softwaredistribution\*.*
move %homedrive%\reportingevents.log %systemroot%\softwaredistribution

REM Delete SusClientID and AccountDomainSid keys from
REM HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
SET WU_KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
reg delete %WU_KEY% /v SusClientID
reg delete %WU_KEY% /v AccountDomainSid
SET WU_KEY=

REM Start the Automatic Updates service
net start wuauserv

REM Start the Windows Management Instrumentation service
net start winmgmt

REM Force a group policy update
gpupdate /force

REM Roll the WU Client...
wuauclt /resetauthorization /detectnow
Aber ich habe immer noch Probleme, die sich nicht so lösen...
Mit der obigen Erklärung konnte ich einer von drei getesteten Clients hinzufügen.

Ach und ich habe noch ein Update auf dem WSUS Server installiert:
WindowsServer2003-KB898708-x86-deu.exe

Probleme (WindowsUpdate.log):
WU client failed Searching for update with error 0x8024000b

glg
Bitte warten ..
Mitglied: Supaman
07.08.2006 um 23:41 Uhr
rechner platt machen und neu installieren.. ist mit einer guten nlite cd fix erledigt und ein kalkulierbarer zeit aufwand
Bitte warten ..
Mitglied: S1c3r
08.08.2006 um 09:06 Uhr
Habe ja eine Full Unattended nLite CD, aber bei 10 Clients, wo zum Teil Bankensoftware installiert ist mag ich das trotzdem nicht machen...

Also, nach dem Tipp von Squire:

Squire
Hi,

schau mal auf http://www.wsus.de vorbei und zieh Dir auf der Download Seite "WSUS - DETECTNOW 2.0 "
Nach dem Ausführen dieses Tools erhalte ich folgendes Logfile (vor dem Ausführen habe ich es natürlich gelöscht):
http://www.bernhardluginbuehl.ch/temp/wuau.txt

Besonders Kopfschmerzen bereitet mir dieser Fehler, welcher ich auch bei anderen Clients habe:
WARNING: WU client failed Searching for update with error 0x8024000b

Also dieser Errorcode: 0x8024000b
Bitte warten ..
Mitglied: S1c3r
08.08.2006 um 13:22 Uhr
Der Computer erscheint jetzt auf dem WSUS Server, verschwindet aber nach einer gewissen Zeit wieder, obwohl einer nun immer noch drin ist.
Zudem ist die Anzahl seit den beiden Computern nicht gestiegen und beträgt im Moment immer noch 65 Computer.

Was könnte das bloss wieder sein?

glg

//EDIT
Das Logfile ist übrigens sauber. Keine Warnungen mehr...

---
Die gesammte Lösung werde ich am Schluss posten!
Bitte warten ..
Mitglied: S1c3r
09.08.2006 um 08:42 Uhr
So ich werd mal den Lösungsweg posten, obwohl 2 von 3 Clients immer wieder aus dem WSUS verschwinden.
Aber das Logfile WindowsUpdate.log ist nun sauber.

Als erstes empfehle ich auf dem WSUS Server alle Updates nachzufahren (Auch SP).

Wenn Windows Update auf den Clients nicht funktioniert empfehle ich WinUpdRestore22.exe (http://www.mshelper.de/sites/regists.html).

Wenn das Logfile unter C:\WINDOWS\WindowsUpdate.log sauber ist kann man sich beim WSUS mit dem Tool WSUS_detect_now_2.0_ger.exe (http://downloads.wsus.de) anmelden.

Wenn es Probleme gibt wie:
WU client failed Searching for update with error 0x8024000b
0x8024400a
WARNING: Failed to read the service id for re-registration 0x80070002:
WARNING: SyncUpdates failure, error = 0x8024400A, soap client error = 10, soap error code = 0, HTTP status code = 200
WARNING: Sync of Updates: 0x8024400a
WARNING: Failed to synchronize, error = 0x8024400A

Sollten so vorgegangen werden:
Informationen zu WMI: http://www.microsoft.com/germany/technet/datenbank/articles/600682.mspx ...

Also wenn keine OS Informationen an den WSUS Server gesendet werden kann muss man den "Windows Management Instrumentation" Service stoppen

net stop winmgmt

Danach müssen Sie den Ordner Repositorys unter C:\WINDOWS\system32\wbem löschen.
Jetzt kann der Dienst wieder gestartet werden.

net start winmgmt

Jetzt das ganze Testen und den Ordner dadurch wieder erstellen.
Start-->Ausführen-->Wbemtest.exe eintippen.
Verbinden.. betätigen, die standard Einstellungen beibehalten und auf Verbinden klicken. Das kann nun ein bisschen dauern...

Es kann nun sein, dass der Client zwar im WSUS erkannt wird, aber das OS immer noch nicht erkannt wird und der Client im WSUS als "unknown" bezeichnet wird.
Dazu muss man den Inhalt des Softwaredistributionsverzeichnis löschen.

Hier ein Script:
REM Stop the Automatic Updates service
net stop wuauserv

REM Stop the Windows Management Instrumentation service
net stop winmgmt

REM Backup ReportingEvents.log. Then, delete the contents of
REM %systemroot%\SoftwareDistribution and
REM %systemroot%\system32\WBEM\Repository
copy %systemroot%\softwaredistribution\reportingevents.log %homedrive%\
del /f /q %systemroot%\softwaredistribution\*.*
move %homedrive%\reportingevents.log %systemroot%\softwaredistribution

REM Delete SusClientID and AccountDomainSid keys from
REM HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
SET WU_KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
reg delete %WU_KEY% /v SusClientID
reg delete %WU_KEY% /v AccountDomainSid
SET WU_KEY=

REM Start the Automatic Updates service
net start wuauserv

REM Start the Windows Management Instrumentation service
net start winmgmt

REM Force a group policy update
gpupdate /force

REM Roll the WU Client...
wuauclt /resetauthorization /detectnow
Sollten weiterhin Probleme auftreten kann noch das Versucht werden:
http://support.microsoft.com/kb/282784
Qfecheck.exe verifies the installation of Windows 2000 and Windows XP hotfixes
Download: http://www.microsoft.com/downloads/details.aspx?FamilyID=155c7c58-102e- ...

Windows Installer:
http://www.pctipp.ch/helpdesk/kummerkasten/archiv/win2k/29703.asp
Windows Installer ist defekt - PCtipp-Kummerkasten

Wenn DLLs defekt sind kann bei Windows XP das SP2 erneut installiert werden. Bei Windows 2000 funktioniert das reparieren durch erneutes SP installieren leider nicht.

Ich hoffe, ich habe alles erwähnt.

Problem, welches noch offen ist:
Es gibt noch zwei Clients die im WSUS nach einer Reauthorisierung erscheinen, nach einer gewissen Zeit aber wieder verschwinden. Das WindowsUpdate Logfile ist aber sauber und enthält keine Warnungen oder sonstiges. Die GPO wurde erfolgreich angewendet, und der Client kann auch einwandfrei mit dem WSUS kommunizieren. Aber leider verschwinden die beiden immer wieder. Aber da es sich hier um nur zwei Clients handelt werde ich wohl einfach das Image neu installieren. Aber wenn es trotzdem noch einen Lösungsweg geben sollte wäre ich für jeden Tipp dankbar!

glg
Bitte warten ..
Ähnliche Inhalte
Windows Server
WSUS findet keine Computer
Frage von takvorianWindows Server19 Kommentare

Hallo zusammen, ich habe vergangene Woche an einem DC die WSUS Installation durchgefüht. Da ich dies an einem 2012R2 ...

Windows Server
Computer finden den neuen WSUS nicht
gelöst Frage von PizzaPepperoniWindows Server41 Kommentare

Hallo. habe gerade in ner Umgebung gesehen, dass Workstations keine Updates bekommen. Wie ich erfahren habe, hatte ein anderer ...

Windows Server
Computer erscheint nicht im WSUS
gelöst Frage von Jabberwocky86Windows Server5 Kommentare

Hallo Zusammen Ich habe für meine Testumgebung einen WSUS installiert. Nun erscheint meine Win7 Maschine die ich zum Testen ...

Windows Netzwerk

Seite Intranet wird als lokaler Computer "erkannt"

Frage von SchiDieWindows Netzwerk2 Kommentare

Hallo zusammen, ich habe bei uns in der Firma eine neuen Rechner (Win7-64) bekommen und dabei fiel mir auf, ...

Neue Wissensbeiträge
Suche Projektpartner

PC Recycling Projekte mit Flüchtlingen und Kids suchen Materialspenden und Mitmacher!

Erfahrungsbericht von NettePCyclePiraten vor 11 StundenSuche Projektpartner1 Kommentar

Hallöchen liebe Kollegen, ich betreue zwei PC-Gruppen im Raum Dortmund: "Ne#e PCycle Pir@ten" & "PCschr@uber Br@mbauer" Wir sind eine ...

iOS
IOS 12.2 beta und OpenVPN iPad und iPhone
Erfahrungsbericht von magicteddy vor 19 StundeniOS

Moin, kleiner Hinweis an die experimentierfreudigen unter Euch: Bei der aktuellen beta gibt es ein Problem im Zusammenspiel zwischen ...

Vmware
VMware Tools 10.3 verfügbar
Information von sabines vor 22 StundenVmware

Eine Sicherheitslücke wird mit den Tools der Version 10.3 geschlossen, die Tools müssen auf jeder VM aktualisiert werden. Näheres ...

Apple

Apple aktualisiert MacBook Pro, mit bis zu sechs Kernen

Information von Vision2015 vor 3 TagenApple

Jawohlchen das Warten hat sich gelohnt :-) Apple aktualisiert MacBook Pro Frank

Heiß diskutierte Inhalte
Microsoft
Dringend: Nach neustart kein zugriff mehr per RDP möglich - vermutlich wegen gelöschter SID in AD
gelöst Frage von sven784230Microsoft30 Kommentare

Hallo zusammen, gerade hat ein Server 2012 (terminalserver + Active directory) einen geplanten Neustart durchgeführt, wenn ich mich jetzt ...

Exchange Server
Exchange 2013 - Update schlägt fehlt
gelöst Frage von chb1982Exchange Server20 Kommentare

Hallo zusammen, kann sich jemand einen Reim auf die unten stehenden Fehlermeldung machen? Sie tritt auf beim Update von ...

Firewall
Pfsense - Package Manager - Unable to retrieve package information
Frage von nubyFirewall12 Kommentare

Hallo! Ich habe mit verschiedenen Versionen von Pfsense Probleme neue Packages herunterzuladen. Bei Pfsense 2.3.1 oder 2.3.5 heißt es: ...

Verschlüsselung & Zertifikate
Windows PKI root Zertifikate werden nicht aktualisiert
Frage von Chaser21aVerschlüsselung & Zertifikate10 Kommentare

Hallo Community, wir haben eine eigene Unternehmens PKI im Einsatz. Aktuell gibt es das Problem, dass mehrere ROOT- und ...