Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Xcopy For- Schleife mit Leerzeichen in x.jpg

Mitglied: regedit19

regedit19 (Level 1) - Jetzt verbinden

13.12.2011, aktualisiert 21:21 Uhr, 6614 Aufrufe, 9 Kommentare

Hallo Admins!



Möchte folgendes Batch- Script funktionstüchtig machen.

01.
 for /r "%homedrive%\users\user\desktop\ordner" %q IN (*.jpg) DO xcopy /Y /C %q "C:\Users\user\fertig" 

In dem Ordner "\desktop\ordner\" befinden sich mehrere Unterordner mit *.jpg - Bildern, welche blöderweise im Bild-Namen Leerzeichen enthalten.

Das Problem ist, dass mir zwar die Schleife angezeigt wird, aber Xcopy die Bilder nicht kopieren kann, da im Bildnamen Leerzeichen enthalten sind. Somit gibt mir Xcopy einen Syntaxfehler zurück.
Wenn ich den Variablen "" gebe funktioniert es ja leider auch nicht.

Was muss ich in meiner Batch noch verändern damit ich diese Bilder mit Leerzeichen auch zum gewünschten Ziel kopieren kann?


Danke im Voraus!


[EDIT]

Es wird kein Syntaxfehler zurückgegeben, sondern: "Unzulässige Parameterzahl" aufgrund des Pfades.

Was die Sache schon wieder komplett anders aussehen lässt.
Sorry mein Fehler!
[/EDIT]
regedit19
Mitglied: pieh-ejdsch
13.12.2011 um 20:34 Uhr
moin regedit19,

wenn das die Zeile zum Testen in der CMD-Line sein soll musst Du ein @echo xcopy voranstellen. dann siehst Du auch wie es machen würde wenn es soll.

Dein Ziel ist zwar ohne Sonderzeichen hat aber trotzdem Anführungszeichen und funktioniert.
Deine Quelle hat aber SonderZeichen aber leider keine benötigten Anführungszeichen.
[Edit]
oh schlecht durchgelesen.
den ZielOrdner kannst Du noch einen Backslash anfügen
[/Edit]


Gruß Phil
Bitte warten ..
Mitglied: regedit19
13.12.2011 um 21:20 Uhr
Hallo Phil, und danke für deine schnelle Antwort!


Ausgabe der Schleife pro Bild, in diesem Ordner:

01.
C:\>xcopy C:\users\user\desktop\ordner\21 16 13 12 2011 - 09.jpg "C:\Users\user\fertig" 
02.
Unzulässige Parameteranzahl
Und dies kann aufgrund der Fehlenden "" in der For-Schleife Oben nicht kopiert werden, weil Leerzeichen enthalten sind. Nur wie bringe ich die For-Schleife dazu dass sie mir das bei jedem Bild hineinmacht bzw.: den ganzen vorderen Pfad .jpg in "" setzt?


MfG

regedit19
Bitte warten ..
Mitglied: Skyemugen
13.12.2011 um 21:42 Uhr
Aloha,

wo ist jetzt das Problem "%q" zu verwenden bei xcopy?

greetz André
Bitte warten ..
Mitglied: Biber
13.12.2011 um 22:08 Uhr
[OT]
Zitat von Skyemugen:
wo ist jetzt das Problem "%q" zu verwenden bei xcopy?

Weil dann morgen in der BILD steht "Gemein: Hobbybätscher klammert Kuh mit Zollzeichen fest"

[/OT]
Bitte warten ..
Mitglied: regedit19
14.12.2011 um 06:50 Uhr
Guten Morgen allerseits!


@André: Das Problem liegt bei dem Script darin, dass die Ausgabe von der Schleife pro gefundenem Bild so aussieht:

C:>xcopy C:\users\user\desktop\ordner\21 16 13 12 2011 - 09.jpg "C:\users\user\fertig"

Und mir Xcopy dann zurückgibt, dass eine unzulässige Parameteranzahl in der auszuführenden Zeile gibt, und somit das Bild/die Bilder nicht kopiert werden können, weil die Datei: 21 16 13 12 2011 - 09.jpg Leerzeichen im Bildnamen hat.


Was ich möchte ist, dass die FOR- Schleife es pro Bild in dem Ordner so:
01.
C:>xcopy "C:\users\user\desktop\ordner\21 16 13 12 2011 - 09.jpg" "C:\users\user\fertig" 
macht, und nicht so:
01.
C:>xcopy C:\users\user\desktop\ordner\21 16 13 12 2011 - 09.jpg "C:\users\user\fertig"
Man beachte die Anführungszeichen.

Danke! : )


MfG
regedit19
Bitte warten ..
Mitglied: Skyemugen
14.12.2011 um 08:28 Uhr
Zitat von Skyemugen:
wo ist jetzt das Problem "%q" zu verwenden bei xcopy?

01.
for /r "%homedrive%\users\user\desktop\ordner" %q IN (*.jpg) DO xcopy /Y /C "%q" "C:\Users\user\fertig"
ohne Worte ... oder um es mal mit deinen Worten auszudrücken

Man beachte die Anführungszeichen.
Bitte warten ..
Mitglied: 60730
14.12.2011 um 08:51 Uhr
Zitat von Skyemugen:
Aloha,

wo ist jetzt das Problem "%q" zu verwenden bei xcopy?

greetz André

Das der charakter "q", der der einzige ist, der fast alle 007 filme mitgespielt hat, zuerst durch "r" ersetzt wurde und spaeter dann in einem autounfall verstorben ist und leider nicht mehr zurueckkommt.....

Ich nix copypier das problem

Gruss

edit
Iich hab mal ein paar Links verlinkt...
/edit
Bitte warten ..
Mitglied: Skyemugen
14.12.2011 um 09:00 Uhr
Aloha T-Mo,

ganz ehrlich: Ich habe keinen blassen Dunst, was du uns damit jetzt sagen willst <(O_O)>

Alles funktioniert wie es soll ...

naja, mir auch egal, gibt gleich Frühstück ... ist mir zu blöd in dem Thread

greetz André
Bitte warten ..
Mitglied: regedit19
15.12.2011 um 18:36 Uhr
Hallo an Alle!

Danke für eure Hilfe, funktioniert es Neuerung so wie ich möchte!

Durch nichtsetzen der "" bei "%q" hat die Schleife nicht das gewünschte gemacht.

Danke nochmal für eure Hilfe, auch wenn es Sicht wirklich Anspruchsvoll ist/war.

MfG
regedit19
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
For-Schleife Leerzeichen in Pfadangabe
gelöst Frage von goodbytesBatch & Shell3 Kommentare

Hallo, mittels For-Schleife sollen zeilenweise Pfadangaben aus einer txt-Datei geholt werden und damit was abgearbeitet werden. Ist ja soweit ...

Batch & Shell

Leerzeichen aus Zeichenfolge entfernen mit Batch FOR f Schleife

gelöst Frage von gexnerBatch & Shell2 Kommentare

Hallo! Ich möchte aus einer Zeichenfolge alle Leerstellen, egal ob vorne hinten oder in der Mitte, entfernen. In Anlehnung ...

Batch & Shell

Batch Schleife als FOR-SCHLEIFE

gelöst Frage von mp2711Batch & Shell2 Kommentare

Mit den FOR-Schleifen habe ich mich leider bislang zu selten auseinander gesetzt, aber da ich sonst gerade nicht weiter ...

Batch & Shell

FOR Schleife mit LOOP und nachfolgender FOR Schleife

gelöst Frage von miczarBatch & Shell6 Kommentare

Hallo zusammen, ich habe ein Problem mit einem Batchfile. Situation: im Netzwerk ist kein WINS mehr vorhanden und so ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement19 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen17 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Router & Routing
VPN hinter zweiter Fritzbox nutzen im Nachbarhaus
gelöst Frage von georg2204Router & Routing11 Kommentare

Hallo zusammen, ich blicke hier leider nicht mehr so ganz durch. In Haus 1 steht eine Fritzbox 7390, diese ...