Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XP SP2 findet seine eigenen Standarttreiber nicht mehr

Mitglied: karlson

karlson (Level 1) - Jetzt verbinden

05.09.2006, aktualisiert 18.10.2012, 4114 Aufrufe, 3 Kommentare

Habe ein notebook XP SP2, dass anscheinend nicht mehr auf seine Treiberdatenbank zugreift.

Das Problem fing an mit der Installation eines USB-Sticks. Hardware-Assistemt (auf automatische Treibersuche) findet keinen Treiber (unbekanntes USB-Gerät).
Problem besteht auch bei allen anderen USB und PCMCIA-Geräten die ich versucht habe. Auch wenn man den Treiber direkt wählt, kommt die Meldung kein Treiber gefunden.

Bin jetzt wenigtstens für den USB-Stick etc. auf eine peinlich banale Lösung gekommen. Wenn man ihn unter %Systemroot%\inf suchen lässt wird der Stick erkannt und geht. Das Stellt mich allerdings nach einigen Stunden suchen nicht wirklich zufrieden, da:
1. Ich nicht der User des Rechners bin
2. z.B. alles was einen "eigenen" Treiber hat so nicht installiert werden kann (PCMCIA Wlan Karte etc.)
3. Es einfach eine unsaubere Lösung ist

Habe u.A. fogendes versucht:

- infcache.1 gelöscht (sollte doch neu angelegt werden, oder? tut aber nicht!)
- SP2 neu drüber gespielt (driver.cab und INFs werden dabei denke ich alle erneuert)
- biosupdate
- winupdate
- netzteil ab und akku raus
- regcleaner
- "treiberleichen" beseitigt

Gibt es vielleicht in der Reg einen Eintrag, der festlegt wo Win seine Harwareinformationen herholen soll?

Neuinstallation wäre keine so gute Idee....

Sorry, bin sicherlich in der falschen Kategorie gelandet. Habe aber keine richtig passende gefunden.
Vielen Dank schon mal im Vorraus für die Antworten!

Gruß
Tobias
Mitglied: ulli1966
05.09.2006 um 10:26 Uhr
Gibt es vielleicht in der Reg einen Eintrag,
der festlegt wo Win seine
Harwareinformationen herholen soll?

Hallo,
schau mal da rein:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

DevicePath = %SystemRoot%\inf (REG_EXPAND_SZ)

Was besseres fällt mir auch nicht ein.

Grüße Ulli
Bitte warten ..
Mitglied: leknilk0815
05.09.2006, aktualisiert 18.10.2012
Hi,
geh in den Gerätemanager und schmeiß mit "deinstallieren" gnadenlos alles raus, was irgendwie mit USB, PCMCIA usw. zu tun hat.
Nach einem Reboot sollte er sich reorganisieren.
Wenn das keinen Erfolg bringt, würde ich eine Reparaturinstallation laufen lassen.
Wie das geht, findest hier:
https://www.administrator.de/wissen/reparaturinstallation-windows-xp-pro ...

Gruß - Toni
Bitte warten ..
Mitglied: karlson
05.09.2006 um 12:20 Uhr
Super! Hab's hinbekommen.

In der Reg stand "systemroot%\inf..." statt "%systemroot%\inf". Danach hab ich noch mal alle nicht erwendeten, nicht erkannten und sonstigen Geräte die mit USB und PCMCIA zu tun haben im Gerätemanager deinstalliert. Hat gleich alles wieder erkannt und treiber geladen. Infcache.1 wird auch wieder angelegt und bei "treiber selbst wählen" sind auch alle Standarttreiber wieder in der Liste (war vorher leer).

Scheint also alles wieder zu funktionieren. Bleibt nur noch ein komischer Beigeschmack wie einfach ein ein Zeichen aus einem Reg-Wert verschwinden kann. Dass da jmd händisch was gemacht hat kann ich eigentlich mit Sicherheit auschließen. Alleine schon wegen den Rechten. War das evtl. ein Speicherfehler der beim schieben aufgetreten ist?
Bleibt nur zu hoffen das sowas nicht wieder auftritt.

Vielen Dank auf jeden Fall für eure Antworten!!!

Werde mir gleich mal ein Image von der Installation ziehen. Btw weiß jmd wie ich in regelmäßigen Abstanden ein Backup von der Reg auf einen Server schiebe oder vom Server holen lasse? Da muss ich doch erstmal in eine reg-Datei exportieren, oder?

Gruß
Tobias
Bitte warten ..
Ähnliche Inhalte
Windows Server
Forfiles findet nicht alles
gelöst Frage von DerVolkerWindows Server15 Kommentare

Hallo zusammen, ich suche auf einem Netzwerklaufwerk nach alten Dateien: forfiles /P PFAD /D -01.01.2013 /S Somit finde ich ...

Webbrowser

XP SP2 unter Hyper-V auf 2012 R2 Kein Internet

gelöst Frage von HenereWebbrowser6 Kommentare

Hallo zusammen, ich müsste was testen und habe ein XP-SP2 unter Hyper-V auf 2012 R2 installiert. Irgendwie hab ich ...

Windows Server

Windows Suche findet Datei nicht

Frage von jojo0411Windows Server3 Kommentare

Hallo Leute, Ich habe einen Windows 7 Client und einen Windows Server 2008 Standard Fileserver. Auf einem Netzlaufwerk liegt ...

Datenbanken

Wordpress findet MySQL Server nicht

gelöst Frage von 118080Datenbanken27 Kommentare

Moin :-) Ich habe mir um ein Wordpress Theme zu entwickeln eine XAMPP Instanz auf meiner lokalen Entwicklungsumgebung installiert. ...

Neue Wissensbeiträge
Microsoft

Neuigkeiten zu Server und Office 365 was läuft mit was und was nicht

Tipp von AlFalcone vor 1 TagMicrosoft4 Kommentare

Da diese Infos scheinbar unerwünscht sind, habe ich diese wider gelöscht.

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 1 TagSpeicherkarten1 Kommentar

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 1 TagSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 2 TagenHardware2 Kommentare

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Sicherheitsgrundlagen
EuGH-Urteil - Internetanschluss für die ganze Familie - Filesharer haften trotzdem
Frage von StefanKittelSicherheitsgrundlagen40 Kommentare

Hallo, In diesem Artikel geht es darum, dass Jemand aus der Familie ein Hörbuch illegal hochgeladen hat. Der Vater ...

Off Topic
SysAdmin im öffentlichen Dienst - jemand Erfahrungen?
Frage von JohnDorianOff Topic19 Kommentare

Hallo zusammen, hat jemand Erfahrung wie es so ist als SysAdmin im öffentlichen Dienst (Landkreis) im Südwesten der Republik ...

TK-Netze & Geräte
Low budget TK-Anlage für KMU
Frage von HeinklugTK-Netze & Geräte16 Kommentare

Hallo Admins, ich bin auf der Suche nach eine kostengünstigen Telefonanlage für mein kleines Büro mit 4-5 Mitarbeitern. Dabei ...

Datenbanken
MS SQL DB-Daten archivieren?
gelöst Frage von SchelinhoDatenbanken16 Kommentare

Hallo zusammen! Ich habe eine Anwendung, welche MSSQL (SQL Server 2014 SP2) nutzt. Auf der DB-Instanz laufen diverse Datenbanken. ...