Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

%-Zeichen fehlt beim Ausführen einer Batchdatei

Mitglied: 5643

5643 (Level 1)

16.10.2004, aktualisiert 19:35 Uhr, 7968 Aufrufe, 2 Kommentare

Ich versuche eine Batchdatei zu schreiben um mich ins Internet einzuwählen. Der Befehl funktioniert in der Eingabeaufforderung nur wenn ich ihn über meine Batchdatei ausführe, fehlt ein %-Zeichen.

Ich versuche eine Batchdatei zu schreiben um mich ins Internet einzuwählen. Der Befehl funktioniert in der Eingabeaufforderung nur wenn ich ihn über meine Batchdatei ausführe, fehlt ein %-Zeichen.

Der Befehl lautet wie folgt:

<font class="code">call C:\windows\system32\rasdial.exe adsl dslflat/1000192%portable128.ngi xxxxxx</font>

Im DOS-Fenster wird allerdings nur folgendes ausgeführt:

<font class="code">call C:\windows\system32\rasdial.exe adsl dslflat/1000192portable128.ngi xxxxxx</font>

Wie kann ich das Prozentzeichen mit ausführen oder hat jemand eine bessere Idee, wie ich die Verbindung zum Internet über eine Batchdatei herstellen kann?

mfg Lars
Mitglied: alaska
16.10.2004 um 19:24 Uhr
Die % Zeichen bei Variablen in einer Batchdatei müssen Verdoppelt werden.

Also in der Eingabeaufforderung genügt %portable128.....

und in der Batch

%%portable128.......

Tschau
w.s.
Bitte warten ..
Mitglied: 5643
16.10.2004 um 19:35 Uhr
Danke für deine schnelle Antwort. Es hat geklappt.

Ich musste nur noch das Wort 'call' weglassen.

Lars
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Batchdatei auf einem Server ausführen mit psexec.exe

Frage von imebroBatch & Shell18 Kommentare

Ich möchte gerne eine Batchdatei auf einem Server ausführen. Ich habe Adminrechte auf dem Server und kann z.B. auch ...

Batch & Shell

Unterdrücken eines DOS Fenster bei Ausführen einer Batchdatei

gelöst Frage von ZockervogelBatch & Shell10 Kommentare

Hallo, ich habe zwar schon gesucht, aber noch nichts gefunden was funktioniert. Ich führe per Aufgabenplanung unter Windows 8 ...

Netzwerke

Hilfe beim Ausführen einer Batchdatei von einem Client auf einem Server

Frage von mayofantNetzwerke8 Kommentare

Hallo Gemeinde, ich Hoffe hier Hilfe zu bekommen, den langsam bin ich am Ende meines Lateins (und ich habe ...

Python

Python von ZEICHEN bis ZEICHEN

gelöst Frage von schneerunzelPython2 Kommentare

Hallo, ich glaube ich habe eine ganz einfache Frage: Ich möchte aus eine Testdatei die So aufgebaut ist: ID;Vorname;Name;Jahrgang ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 14 StundenPeripheriegeräte1 Kommentar

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 1 TagWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 1 TagWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 3 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Humor (lol)
Freitagsfrage: Was tun, wenn der Admin der DAU ist?
Frage von VoiperHumor (lol)29 Kommentare

Moin Zusammen, Eine nicht ganz ernst gemeinte Frage an die Außendienstler unter uns. Zusammenfassung: Ein Inhouse Admin ruft bei ...

Windows Server
W2K16 Essentials: keine Namensauflösung nach der Einrichtung DNS + AD DS
Frage von Ben-WittWindows Server22 Kommentare

Ich versuche bereits seit ca. 4 Wochen einen Server 2016 "Essentials" richtig zu installieren. An diesem Server möchte ich ...

Exchange Server
Exchange Backup 10 Jahre Aufbewahrung
Frage von arccosExchange Server20 Kommentare

Hallo zusammen. Aktuell beschäftigen mich ein paar Fragen zum Thema Office365/ Exchange. 1.10 Jahre Aufbewahrungspflicht sicherstellen 2.Kann man als ...

Windows Netzwerk
LTE Modul - Kein Internet trotz Verbindung
Frage von killtecWindows Netzwerk18 Kommentare

Hallo, ich habe hier ein Dell 7390 2-in-1 mit W10 Pro wo ich nachträglich eine LTE-Karte (Original Dell DW5811e ...