Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Zertifikatsanforderung kann nicht abgeschlossen werden

Mitglied: PhobosX

PhobosX (Level 1) - Jetzt verbinden

02.08.2013, aktualisiert 15:41 Uhr, 8209 Aufrufe, 9 Kommentare

Hallo zusammen.
Wir haben bereits einen Exchange 2013 (auf einem Server 2012) mit einem StartSSL Single-Domain Zertifikat im Einsatz.

Nun haben wir das Class 2 Zertifikat gekauft. Zudem haben wir nun einen weiteren Exchange Server.

Auf diesem würde ich gerne das SSL Zertifikat für mail.domain.de bekanntmachen.

Nun habe ich erst ein mycertrequest.REQ gemacht, wo aber ein Tippfehler drin war. Also habe ich den offenen Request gelöscht und danach einen neuen Request angelegt. Hier stimmen nun die Daten.

Nun habe ich bei StartSSL die Domain mail.domain.de zertifizieren lassen. Danach erhält man das Zertifikat, welches ich dann in eine .cer Datei geschrieben habe.

Damit wollte ich dann den Request auf dem Exchange abschließen, aber der Status ändert sich nicht auf abgeschlossen. Es kommt aber auch kein Fehler.


Woran liegt das nun? Hätte ich den fehlerhaften Request erst abschließen sollen? Die Datei davon habe ich noch, nur erscheint sie nicht merh in der ECP.


Was meint ihr?

VG



EDIT: Oder anders herum gefragt. Wie importiere ich das Zertifikat ohne den Request (wenn ich den private Key von StartSSL erzeugen hab lassen)?
Mitglied: Dani
02.08.2013, aktualisiert um 19:16 Uhr
Moin,
oder ein Wildcard-Zertifikat... schenkt sich meistens nicht viel und kann für beliebig viele Subdomains + Hauptdomain genutzt werden. Den Privatekey, etc... dafür aber gut verstauen.

Zum Exportieren/Importieren gibt es zwei Möglichkeiten - Link


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 08:58 Uhr
Hallo zusammen.
Bei StartSSL bekommt man ein offizielles Zertifikat. Und wir haben auch ein Wildcard-Zertifikat.

Von daher passt das. Haben wir ja auch schon beim ersten Exchange so realisiert.

@Dani
Ich will ja kein Zertifikat umziehen, sondern ein neues Importieren.

Kann ich beim Exchange 2013 auch ein *.domain.de (Wildcard) Zertifikat ohne eine .req Datei einspielen?

Wenn ja, wie?

Und ist es problematisch einen bestehenden Request zu löschen?


Danke un und viele Grüße!
Bitte warten ..
Mitglied: Dani
05.08.2013 um 09:17 Uhr
Moin,
steht alles im Technet. Leider haben wir noch keinen Testserver mit Exchange 2013.

Und ist es problematisch einen bestehenden Request zu löschen?
Eigentlich nicht...


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013, aktualisiert um 11:37 Uhr
Also ich versuche nun eine PKCS#12 (PFX) Datei zu importieren.

ef8c2f36683634c94fa284558ea509e0 - Klicke auf das Bild, um es zu vergrößern


Der Exchange sagt mir aber, dass bereits ein Zertifikat mit diesem Fingerabdruck vorhanden sei. Da ist aber kein Zertifikat in der Exchange-Verwaltungskonsole zu sehen.

Wie kann das sein?


Grüße


EDIT:
So, konnte den Fehler zumindest ausfindig machen und beheben. Unter der MMC war das alte Zertifikat sichtbar und ließ sich nun löschen.


ABER:
Ich habe nun ein wildcard Zertifikat verwendet. Das lautet auf *.domain.de

Der Exchane mag das aber nicht, da es kein FQDN darstellt.

Warnung
Dieses Zertifikat mit dem Fingerabdruck 96.... und dem Antragsteller '*.domain.de' kann für POP-SSL/TLS-Verbindungen nicht verwendet werden, da der Antragsteller kein vollqualifizierter Domänenname (FQDN) ist. Verwenden Sie den Befehl 'Set-POPSettings', um X509CertificateName auf den FQDN des Diensts festzulegen.


Dieses Zertifikat mit dem Fingerabdruck 96... und dem Antragsteller '*.domain.de' kann für IMAP-SSL/TLS-Verbindungen nicht verwendet werden, da der Antragsteller kein vollqualifizierter Domänenname (FQDN) ist. Verwenden Sie den Befehl 'Set-IMAPSettings', um X509CertificateName auf den FQDN des Diensts festzulegen.


Wie lässt sich das *.domain.de Zertifikat für den Exchange verwenden?


Grüße
Bitte warten ..
Mitglied: Dani
05.08.2013 um 13:39 Uhr
Moin,
musste noch kurz einen Exchange 2013 installieren.

Ich habe es mit unserem Wildcard-Zertifikat versucht. Funktioniert auf Anhieb ohne Probleme. Wichtig ist das, der private Schlüssel enthalten ist. Steht doch dran, was du zu tun hast. Öffne die Exchange Management-Powershell und gebe ein:
01.
Set-PopSettings -X509CertificateName domain.de
Dienste neustarten und die Management Oberfläche aktualisieren.


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 13:43 Uhr
Heyhey, das nenn ich doch mal Wissensdurst

Ich hab jetzt nicht unser Wildcard- sonder ein Single-Domain-Zertifikat genommen und die Dienste zugewiesen. Ging/geht ja auch und erfüllt seinen Zweck.

Ich denke das Thema kann ich dann als gelöst markieren.

Vielen Dank für eure Hilfe! Wie immer top!
Bitte warten ..
Mitglied: Dani
05.08.2013 um 13:45 Uhr
Heyhey, das nenn ich doch mal Wissensdurst
Eigentlich nicht... hab heut entspannte Schicht im NOC. Eis, Fernseher und nichts zu tun.


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 14:35 Uhr
Ein Hoch auf das Sommerloch. Ich kann so auch etwas entspannter die Exchange Migration durchführen.

Also viel Spaß noch!

VG
Bitte warten ..
Ähnliche Inhalte
Windows Server

WinSrv Stammzertifizierungsstelle - Zertifikatsanforderung ohne Webinterface durchführen

gelöst Frage von ShiokuWindows Server3 Kommentare

Hallo, aktuell nutze ich das Webinterface der Zertifizierungsstelle " um eine Zertifikatsanforderung durchzuführen, nachdem ich eine Anforderungsdatei über den ...

Microsoft Office

Excel VBA warten, bis eine Aktion abgeschlossen ist

Frage von RedryderMicrosoft Office1 Kommentar

Hallo Wissende, ich habe eine Excel Liste programmiert, die via SNMP die Zählerstände meiner Drucker abfrägt und diese dann ...

E-Mail

Indizierung von Outlook-Elementen wird nicht abgeschlossen

Frage von w.doplerE-Mail

Hallo zusammen, wir haben in unserem Betrieb eine Domäne und nutzen Exchange. Bei manchen Mitarbeitern haben wir das Problem, ...

Windows Server

Ordnerumleitungen nicht vollständig abgeschlossen

gelöst Frage von CaptainRubikWindows Server1 Kommentar

Einen schönen guten Tag, ich habe eine Testumgebung worin es um Ordnerumleitungen geht. Ich hab mir meine Versuche aufgeschrieben ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 21 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...