Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst kein Zugriff auf Maxtor Shared Storage II per VPN

Mitglied: Janni

Janni (Level 2) - Jetzt verbinden

10.10.2008, aktualisiert 13.10.2008, 6160 Aufrufe, 5 Kommentare

Moinsen,

wird per VPN (OpenVPN) auf das Büronetz zugegriffen ist leider keine Verbindung mit dem NAS (Maxtor Shared Storage II) möglich. Dies beinhaltet sämtliche Verbindungen, sowie auch Pings, etc.. Im Büro selber ist der Zugriff auf den NAS kein Problem.

Ein klein wenig zum Rahmen:
Büro:
Netz: 192.168.69.0
Subnetz: 255.255.255.0

VPN:
Netz 192.168.68.0
Subnetz: 255.255.255.0

NAS/ Maxtor Shared Storage II
IP: 192.168.69.72
Subnetz: 255.255.254.0
Ordner: öffentlicher Zugriff
neueste Firmware (3.1.28)

Das arbeiten per OpenVPN-Verbindung im Netz des Büros ist problemlos möglich. Hier ist der Zugriff auf alle Rechner gegeben (zum Beispiel auf den Server 192.168.69.1).

Komischerweise müsste selbst ohne NAT, etc. der Zugriff aus dem Netz 192.168.68.0 durch die Subnetmaske auf den NAS möglich sein.

Hat Jemand eine Idee ?

Und Danke schon einmal.
Mitglied: Arch-Stanton
10.10.2008 um 08:16 Uhr
falsche Subnetzmaske beim NAS?

Gruß, Arch Stanton
Bitte warten ..
Mitglied: Janni
10.10.2008 um 08:35 Uhr
Die 255.255.254.0 sollte eigentlich das 192.168.68.0er Netz mit abdecken .... funktioniert aber auch mit einem 255.255.0.0 nicht.
Bitte warten ..
Mitglied: aqui
10.10.2008 um 21:14 Uhr
Nein, das ist voelliger Unsinn, denn die Clients haben ja noch eine 24 Bit Subnetzmaske und fuer die ist das NAS schlicht und einfach in einem anderen IP Netz bzw. fuer sie im falschen Netz und ohne Router nicht zu erreichen !
Du machst auch einen erheblichen Denkfehler, denn der OpenVPN Server routet das .68er Netz ja in eurer lokales Netzwerk !!!

Ausserdem hast du somit inkonsistente Subnetzmasken in deinem .69er Netzwerk was ein absolutes NO GO ist in einem IP Netz !!! Abgesehen davon ist es mehr als fraglich ob das NAS mit CIDR IP Adressen umgehen kann ?!

Das solltest du also schnellstens wieder rueckgaengig machen !!!

Du hast nichts anderes als ein simples und banales Routing Problem, sonst nix.
Vermutlich hat das NAS schlicht und einfach gar keinen Gateway Eintrag. Oder wenn doch, dann hat es den falschen !!
Wenn du das NAS Gateway auf die IP Adresse des OpenVPN Servers einstellst sollte es anstandslos funktionieren.

Mit einem Traceroute oder Pathping vom Client kannst du ja sofort sehen wo der Datenfluss haengenbleibt und da ist auch meist das Problem !!!
Kannst du auf andere Geraete im .69er netz vom VPN Client pingen ???
Bitte warten ..
Mitglied: Janni
11.10.2008 um 01:29 Uhr
Kannst du auf andere Geraete im .69er netz vom VPN Client pingen ???

Ja, kann ich und ich kann wunderbar auf sie zugreifen.

Du machst auch einen erheblichen Denkfehler, denn der OpenVPN Server routet das .68er Netz ja in
eurer lokales Netzwerk !!!
Soll er ja

Ausserdem hast du somit inkonsistente Subnetzmasken in deinem .69er Netzwerk was ein absolutes NO GO
ist in einem IP Netz !!! Abgesehen davon ist es mehr als fraglich ob das NAS mit CIDR IP Adressen
umgehen kann ?!
Warum sollte er das nicht ?


Und ja, beim NAS ist der Gateway und der DNS auf dem VPN Server gesetzt, sollte also eigentlich gehen (wenn man sich die theoretischen Werte anschaut). Naja soweit gedacht, geht ja leider trotzdem nicht ...... also mache ich irgendwo einen Denk-, bzw. Einstellungsfehler....
Bitte warten ..
Mitglied: Janni
13.10.2008 um 13:52 Uhr
Lösung:

Wenn auf den NAS der Arbeitsgruppenname falsch geschrieben ist, dann geht auch der Zugriff aus einem anderen Subnet nicht ... warum auch immer. Ist der Arbeitsgruppenname gleich der Domäne, dann geht auch der Zugriff.
Bitte warten ..
Ähnliche Inhalte
Vmware

Datastore aus shared Storage für VMware

gelöst Frage von Leo-leVmware10 Kommentare

Hallo zusammen, wir haben eine Vmware-umgebung aus 3 ESX Servern und einer MSA 2050. Die momentane Edition ist eine ...

Windows Server

Windows Explorer Freeze bei Zugriff auf Shared Folder

Frage von xstivixWindows Server7 Kommentare

Gruess euch, ich hab hier ein spannendes Problem. Unser Fileserver laeuft auf Server2012 und hat mehrere Shared Folder. Auf ...

Hosting & Housing

Günstiger Aktiv-Passiv Cluster für Linux-VMs ohne shared Storage

Frage von EDVMan27Hosting & Housing2 Kommentare

Hallo, ich wurde gebeten zu prüfen ob es inzwischen günstige Möglichkeiten gibt aktiv/passiv-Cluster für Linux-VMs ohne shared Storage zu ...

Vmware

VSphere 5.0 - Essentials Plus und Migration auf ein neues Shared Storage

gelöst Frage von 14116Vmware1 Kommentar

Hallo, ein Kunde hat "nur" vSphere 5.0 Essential Plus. Nun hat er ein neues FC - Storage bekommen, welches ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 5 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 8 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...