Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zwei identische Systeme, auf einem läuft der Webservice nicht! Zugriffsprobleme?!?

Mitglied: kontschi

kontschi (Level 1) - Jetzt verbinden

11.05.2008, aktualisiert 20:50 Uhr, 3838 Aufrufe, 3 Kommentare

hi liebe community.

ich sitze jetzt schon gute 48 stunden vor dem Schirm und bin mittlerweile am verzweifeln.

Ich hab auf Win XP Prof. den IIS 5.1 laufen, und eine website online welche einen webservice anbietet (ADS.dll-Protokoll). Der Webservice läuft über .NET Framework.

Wenn ich mit IExplorer die website aufrufe dauert es ein paar Sekunden und die Seite ist dargestellt, alles funktioniert.

Jetzt habe ich Win XP Media Center als 2. Betriebssystem laufen, wollte dasselbe dort einrichten, hab von .NET framework 1.1, 2.x, 3.5 die ganze Palette installiert. Java runtime läuft auch, Visual Studio ist auch installiert. Der IIS ist exakt gleich eingerichtet wie auf Win XP Professionell, jedoch steht beim Abruf der Seite immer "Service unavailable".

Ich habe beide systeme verglichen, auf dem funktionierenden öfftnet der IExplorer beim Aufruf der Site den Prozess "aspnet_wp.exe"! Auf Media Center passiert das nicht, ws. kommt es gar nicht soweit!

Die Datei, welche den Webservice aufruft ist eine *.asmx.

Habe folgendes entdeckt:

Auf Win XP Prof. kann ich die ASMX, wie auch die CS-Dateien, die dazugehören, ansprechen und der Browser zeigt mir den Quellcode an.

Auf Win XP Media Center lädt es ein paar Sekunden und dann bekomme ich immer eine Fehlermeldung - Zugriffsproblem auf die IIS-Metabasis?!?

Ich hab absolut keine Erfahrung noch auf diesem Gebiet und muss bis Donnerstag eine vollständige Dokumentation darüber abliefern

Kann mir jemand weiterhelfen, der mit IIS 5.1, Webservices und .NET Erfahrung hat?!?

LG aus Tirol

Markus
Mitglied: filippg
11.05.2008 um 19:29 Uhr
Hallo,

hast du die Anwendung denn vorkompliert? Andersherum gefragt: Sagt dir aspnet_compiler etwas? Wenn nein: man muss die Anwendung damit vorkompilieren, wenn man sie auf einen anderen Rechner übertragen will. So wirklcih auskennen tue ich mich damit auch nicht, aber auf msdn hatte ich die Referenz gefunden, und mit einem Beispiel, dass da stand war es dann auch ziemlich einfach.

Gruß

Filipp
Bitte warten ..
Mitglied: kontschi
11.05.2008 um 20:04 Uhr
hi.

ich hab ein vorgefertigtes Beispiel verwendet. Der Webservice hat die Funktion, Schaltvorgänge von Java-Buttons auf der HTML-Seite über ein offengelegtes Protokoll für eine andere Software bereitzustellen.

Sprich, ich kann via IExplorer auf Buttons klicken, was eine Statusänderung einer Booleschen Variable in dieser anderen Software zur Folge hat.

Auf Win XP Prof. hab ichs zum laufen gebracht.

Auf Media Center will der Webservice nicht starten und ich weiß nicht, was man da machen soll/kann?! Hab im IIS 5.1 einen virtuellen Ordner von allen Dateien gemacht, und genügend Zugrifssrechte auf alle files gegeben.

1) Bringts dir was, wenn ich dir das Beispiel maile?
2) Hab Prof. auf C: und MEdia Center auf D: installiert, kann das dran Schuld sein? Ich hab mir die Sourcecodes angeguckt, da sind nur relative Pfadangaben zu finden. Kann es sein, dass IIS oder .NET da Probleme mit D: hat?

lg Markus
Bitte warten ..
Mitglied: kontschi
11.05.2008 um 20:50 Uhr
hey nochmal.

hab jetzt was gefunden:

Beim IIS auf XP Prof. ist bei den ASAPI-Filter für die Websites der ASP.NET Filter "aspnet_filter.dll" in der Liste und auf Status: geladen, also der grüne Haken.

Beim IIS auf Media Center ist bei den ASAPI-Filtern gar kein ASP.NET-Filter in der Liste. Wenn ich ihn manuell zufüge, dann kommt Status: nicht geladen.

Habe alle Framework-Pakete installiert, wie kann das passieren??! Was kann ich dagegen tun?!

lg Markus
Bitte warten ..
Ähnliche Inhalte
Windows 10
Klonen zweier identischer WIN10 Systeme
Frage von ClarissaWindows 106 Kommentare

Beide PC-Systeme sind absolut identisch - inkl. des BIOS und habe eine eigenen Lizenz-Key. Beide Systeme habe als System-Laufwerk ...

Windows 7

Windows Client Anmeldung bei zwei identischen Domänen

gelöst Frage von creekoWindows 711 Kommentare

Hallo, wir haben vor einiger Zeit einen neuen Server mit Windows Server 2012 R2 aufsetzen lassen. Nach der Inbetriebnahme ...

PHP

Webservice Server

Frage von artonbinakajPHP8 Kommentare

Hallo administratoren, Ich wollte fragen ob jemand eine komplettlösung kennt unter der man viele verschiedene cms installiren kann. unter ...

Router & Routing

Webservices SBS2011 mit PFSense

gelöst Frage von thommy75Router & Routing3 Kommentare

Hallo im Administrator.de-Forum, Mithilfe einiger Beiträge in diesem Forum und ein wenig sonstigem Google-Fund habe ich erfolgreich meinen bisherigen ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 23 StundenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 1 TagMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 1 TagHardware12 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++27 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux27 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless22 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...