Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zwei Spalten-Inhalte vergleichen in zwei Sheets

Mitglied: Armon8

Armon8 (Level 1) - Jetzt verbinden

27.04.2011 um 23:03 Uhr, 4114 Aufrufe, 7 Kommentare

Hallo zusammen,
Ich bin neu hier

so zu meinem Problem,

Ich hab zwei Sheets wo jeweils zwei Spalten verglichen werden sollten.

Also, Sheet1 Spalte-A enthält 80 (von 1 bis 80) Einträge.
Sheet2 Spalte-K hat von 3 bis 1525 die anderen Einträge.

das Problem ist so : die Daten in Spalte-K haben Erweiterungen als die in Spalte-A (z.B. in Spalte-A steht ABC-12 aber in Spalte-K ABC)

Nun möchte ich die Spalten in den beiden Sheets vergleichen, und wenn die ABC-12 in Sheet1/Spalte-A auch als ABC (ohne Erweiterung) in Sheet2/Spalte-K auftaucht muss eine "JA" in Sheet1/Spalte-B geschrieben werden, ansonsten "NEIN".

Mit SVerweis lässt sich das nicht lösen (denke ich zumindest) da ich kein Excel Profi bin.

Ich hab auch verschiedene Lösungen im Net und hier im Forum gefunden, leider hat nicht viel gebracht.

Wäre sehr dankbar für jede Hilfe


Gruß
Armon
Mitglied: bastla
27.04.2011 um 23:10 Uhr
Hallo Armon8 und willkommen im Forum!

Unter der Annahme, dass immer "-" als Trennzeichen gilt, etwa so:
=WENN(ISTFEHLER(SVERWEIS(LINKS(A1;FINDEN("-";A1)-1);Sheet2!$K$3:$K$1525;1;0));"NEIN";"JA")
Falls es immer um die ersten 3 Zeichen der Spalte A geht, genügt auch:
=WENN(ISTFEHLER(SVERWEIS(LINKS(A1;3);Sheet2!$K$3:$K$1525;1;0));"NEIN";"JA")
Grüße
bastla

P.S.: Es müsste übrigens kein "SVERWEIS()" sein:
=WENN(ZÄHLENWENN(Sheet2!$K$3:$K$1525;LINKS(A1;FINDEN("-";A1)-1))=0;"NEIN";"JA")
Bitte warten ..
Mitglied: Armon8
28.04.2011 um 09:08 Uhr
Hallo Bastla,

und danke für die schnelle Antwort.
Hat leider nicht funktioniert. Die Einträge die verglichen werden sehen beispielsweise so aus:
wenn in Sheet1 / Spalte-A ABC_DEF_123 und in
Sheet2 / Spalte-K ABC_DEF bedeutet der Eintrag ist vorhanden und damit soll "JA" in Sheet-1 Spalte-B oder C geschrieben werden, sonst "Nein"

Das bedeutet _123 wird beim Vergleichen immer ignoriert.

Ausserdem die 2 Sheets sind im gleichen Datei. Bzw. die beiden Tabellen sind im gleichen Datei. (Ich glaube ich hab Sheet und Tabelle verwechselt :s )

Vielen Dank nochmal
Bitte warten ..
Mitglied: bastla
28.04.2011 um 14:26 Uhr
Hallo Armon8!

Nachdem es zunächst "ABC-12" war und es jetzt um "ABC_DEF_123" geht - darf ich dann davon ausgehen, dass zwar "_123" nicht konstant ist, aber zumindest der Aufbau "3 Zeichen + _ + 3 Zeichen + _ + 3 Ziffern" gleich bleibt? Dann würde nämlich auch die Version mit der vorgegebenen Anzahl von Zeichen (in diesem Fall 7) genügen:
=WENN(ZÄHLENWENN(Sheet2!$K$3:$K$1525;LINKS(A1;7))=0;"NEIN";"JA")
Grüße
bastla
Bitte warten ..
Mitglied: Armon8
28.04.2011 um 20:01 Uhr
Hallo bastla!

Danke nochmal für deine Antwort.
ich glaube da liegt ein Missverständnis vor, oder ich hab das Problem falsch vorgestellt.

also in Tabelle1 Spalte-A von Zeile-1 bis Zeile-80 sind die Daten (ABC_DEF_123, ABCD_EF_123, XYZ_123, AZG_123, usw. )
und in Tabelle2 Spalte-K ab Zeile-3 bis Zeile-1525 (ABC_DEF, ABCD_FF, AZG usw. )
d.h. ABC_DEF_123 (von Tabelle-1) = ABC_DEF (von Tabelle-2) das beduetet ein "JA" in Tabelle1 Spalte-B muss eingetragen werden.

Also beim Vergleichen von den beiden Spalten in 2 verschiedenen Tabellen wird die Endung (_123) die nur in Tabelle-1 Spalte-A ignoriert.

Zurück zu deiner Frage, es geht nicht nur um die ersten Buchstaben. Es ist leider unterschiedlich.

Es ist ein bisschen kompliziert

In deinem Vorschlag sehe ich nur Sheet2 obwohl ich mit 2 Tabellen arbeite.
Bitte warten ..
Mitglied: bastla
28.04.2011 um 20:07 Uhr
Hallo Armon8!

Vorweg:
In deinem Vorschlag sehe ich nur Sheet2 obwohl ich mit 2 Tabellen arbeite.
Die Formel steht ja (nach meiner Interpretation) in Sheet1 - wozu also das auch noch angeben? Wenn Du gesteigerten Wert darauf legst, kannst Du auch
=WENN(ZÄHLENWENN(Sheet2!$K$3:$K$1525;LINKS(Sheet1!A1;7))=0;"NEIN";"JA")
verwenden.
es geht nicht nur um die ersten Buchstaben. Es ist leider unterschiedlich.
Wie soll etwas verglichen werden, von dem nicht feststeht, wie es zu ermitteln ist? Solange es keine Regel gibt, nach der festzustellen ist, welcher Teil des Wertes in der Spalte A in der Spalte K des anderen Blattes gesucht werden soll, kann es auch keine passende Formel geben ...

Ginge es aber tatsächlich darum, nur immer den gleich bleibenden Textteil "_123" wegzulassen, könnte die Formel so (gleichfalls mit der mE unnötigen Angabe von "Sheet1!") aussehen:
=WENN(ZÄHLENWENN(Sheet2!$K$3:$K$1525;WECHSELN(Sheet1!A1;"_123";""))=0;"NEIN";"JA")
Grüße
bastla
Bitte warten ..
Mitglied: Armon8
28.04.2011 um 21:29 Uhr
Hallo bastla,

danke dir.

also es geht tatsächlich darum den Teil "_123" beim Vergleichen wegzulassen.

>es geht nicht nur um die ersten Buchstaben. Es ist leider unterschiedlich.

Damit meinte ich eben das vor dem "_123" nicht immer 3 Buchstaben gibt.

Euh ich hab bis jetzt deine Vorschläge immer im Funktion Feld eingefügt, komischerweise bekomme ich immer wieder ein Fehler das die Formel fehlerhaft ist.

Ich bin wie gesagt ein Angänger was das betrifft

Gruß
Armon
Bitte warten ..
Mitglied: bastla
28.04.2011 um 21:36 Uhr
Hallo Armon8!

Die Formel muss einfach in die Zelle B1 oder C1 (und kann dann nach unten kopiert werden) ...

Noch eine (etwas sicherere) Alternative, nämlich mit Abschneiden der letzten 4 Zeichen:
=WENN(ZÄHLENWENN(Sheet2!$K$3:$K$1525;LINKS(A1;LÄNGE(A1)-4))=0;"NEIN";"JA")
Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Datenbanken

SQL: Inhalte aus einer Spalte mit den Inhalten aus mehreren Spalten einer zweiten Tabelle vergleichen

gelöst Frage von sqlbeginnerDatenbanken4 Kommentare

Guten Tag ich habe folgende Fragen Frage 1: Tabelle1 , Spalte A in dieser stehen Kürzel Tabelle2, Spalte A, ...

VB for Applications

Sheet in hinter letzten, verwenderten Spalte einfügen

gelöst Frage von aivilonVB for Applications9 Kommentare

Moin Zusammen Ausgangslage: Ich habe zwei Sheets. Sheet "SCData" ist Variabel in der Grösse. Darin befindet sich eine Pivot, ...

Basic

Zwei Spalten vergleichen und wenn nicht gleich dann nach unten verschieben

gelöst Frage von Rabbit81Basic4 Kommentare

Hallo, ich habe hier schon viele gute Infos im Forum gefunden, aber zu meinem Anliegen finde keine passende Lösung. ...

VB for Applications

SVerweis vs. VBA - Zusammenstellung nach Vergleich über mehrere Spalten in mehreren Sheets

gelöst Frage von aivilonVB for Applications18 Kommentare

Hallo Zusammen Ich brauche ziemlich dringend eine Auswertung, die ich am besten über einen SVerweis oder VBA mache. Leider ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 10 StundenHumor (lol)3 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 22 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 23 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 1 TagMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server45 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware16 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...