Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Linux Apache Server

GELÖST

Eine öffentliche IP, 2 Webserver Apache und IIS

Mitglied: flugfaust

flugfaust (Level 2) - Jetzt verbinden

31.07.2007, aktualisiert 18.10.2012, 7775 Aufrufe, 6 Kommentare

Hallo,

ich habe folgendes Problem.
Ich habe auf meinem DSL Router einen dynamsichen DNS Eintrag und forwarde port 80 auf einen Apache Webserver auf dem eine Homepage zur Verfügung gestellt wird.

Nun habe ich auf einem anderen Server einen Exchange Server laufen und will den Zugriff über das Web anhand von Outlook Web Access ermöglichen.
Dazu habe ich Port 443 vom DSL Router auf den Exchange Server geforwardet.
Wenn ich nun https://meinedomain/exchange eingebe, kommt nichts. Auf meine Domain komme ich problemlos per http://meinedomain
Wenn ich aber auf dem DSL Router Port 80 nicht auf den Apache Server sondern auf die IP des Exchange forwarde, komme ich per http://meinedomain/exchange drauf.

Was muss ich machen um den Zugriff auf den Exchange UND den Apache zu ermöglichen ?


DANKE schon mal im Vorraus
Mitglied: Alfredus
31.07.2007 um 11:28 Uhr
Apache kann als Frontend für den Exchange laufen. Siehe:

Howto

Die Frontend-Stellung hindert den Apache aber nicht daran, auch ganz normale http-Dienste anzubieten.

Gruß
Alfredus
Bitte warten ..
Mitglied: flugfaust
31.07.2007 um 11:47 Uhr
OK das sieht schon mal 1.sehr interessant und 2.sehr gut aus. Werde ich auf jeden Fall sobald ich mehr Zeit habe, testen.

Aber nichts desto trotz..........gibts noch einen anderen Weg? Ich meine das Portforwarding sollte doch so eigentlich auch klappen oder?
Bitte warten ..
Mitglied: Spao
31.07.2007 um 11:56 Uhr
Ist das ein oder zwei Rechner ?
Bitte warten ..
Mitglied: aqui
31.07.2007, aktualisiert 18.10.2012
Normalerweise kann der Router niemals auf Verzeichnisse in einer URL differenzieren...wie sollte er auch. Was er machen kann ist einzig und allein nach eingehenden Ports auf seiner öffentlichen IP Adresse zu differenzieren. Nichts anderes macht diese Port Forwarding Liste.
Die Angabe des Verzeichnisses \exchange ist in der Hinsicht also völlig sinnlos !!!
Wenn Port TCP 80 auf den Apache geht und Port TCP 443 auf den Exchange dann reicht es von remote wenn man
http://meinedomain angibt um auf den Apache zu kommen und
https://meinedomain um auf den Exchange Server zu kommen

Wichtig ist natürlich das der Exchange Server sofort mit der Exchange Seite antwortet sollte er per HTTPS angesprochen werden, was sich sicher bei MS einrichten lässt. Bei einem lokalen Test muss also bei https://<exchange ip adresse> sofort die Webmail Seite kommen.

Wenn der Exchange Webzugriff allerdings irgendwelche Daten zwischendurch per Port TCP 80 macht hast du ein Problem, da die dann immer an den Apache gehen, und das ist auch nicht zu verhindern.

Du solltest mal versuchen mit dem Router eine Port Translation als Test zu fahren, indem du den Exchange mit Port 8080 und 443 ansprichst !
Dazu legst du in der PFW Tabelle des Routers den Port TCP 8080 als incoming fest und gehst outgoing lokal auf die Exchange IP mit TCP 80. TCP 443 legst du gleich fest auf die lokale Exchange IP Adresse.
Wenn du nun den Exchange mit
http://meinedomain:8080
ansprichst müsste es klappen. Ggf. sogar wenn du https://meinedomain:8080 machst aber das ist davon abhängig wie dein Router die PFW Liste abhandelt....


Du solltest fairerweise auch oben noch dazuschreiben das dieser Thread ein Doppel von:
http://www.administrator.de/forum/portforwarding-funktioniert-nicht-so- ...
ist, den du nicht geschlossen hast
Bitte warten ..
Mitglied: flugfaust
31.07.2007 um 18:16 Uhr
OK. Also dass mit dem Portforwarding hab ich logischerweise schon versucht, allerdings hatte ich https://meinedomain/exchange
Kaum geb ich nur https://meinedomain an, geht es auch schon.
Also DANKE
Bitte warten ..
Mitglied: aqui
31.07.2007 um 18:17 Uhr
War eigentlich vorauszusehen....

Bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Firewall
Exchange und Webserver mit nur einer öffentlichen IP Adresse?
Frage von meddieFirewall1 Kommentar

Hallo Leute, eine Frage ich habe bei mir zu Hause in meiner Versuchsumgebung einen Exchange den ich nach außen ...

HTML
Seitenaufbau beschleunigen - Apache Webserver
gelöst Frage von mabue88HTML5 Kommentare

Hallo, und schon wieder habe ich eine Frage, die ich selbst nicht beantworten kann. Ich habe einen Apache-Server. Eine ...

Informationsdienste
IIS als Frontend für interne Webserver
gelöst Frage von SKB-CGNInformationsdienste9 Kommentare

Hallo Zusammen, ich bin auf der Suche nach einer "Fähigkeit", wo ich nicht weiss, ob dies möglich ist - ...

Windows Server
Problem mit Webdav und Webserver IIS
Frage von JUJUS31Windows Server3 Kommentare

Hallo, ich versuche seit einigen Tagen den Webdav dienst des Windows IIS server ans laufen zu bekommen. Die Verbindung ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 8 StundenLinux1 Kommentar

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit24 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
gelöst Frage von Windows10GegnerNetzwerkgrundlagen23 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...