Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

127.0.0.1 unter Windows 7 obowhl IPv4 deaktiviert?

Frage Netzwerke

Mitglied: meteora28

meteora28 (Level 1) - Jetzt verbinden

18.03.2011 um 09:58 Uhr, 5407 Aufrufe, 8 Kommentare

Hallo Leute,

folgende Sachlage:

Ich habe ein System mit Windows 7 und deaktiviertem IPv4. Es soll lediglich IPv6 genutzt werden.

Auf diesem System wollte ich eine Software testen, welche bisher nicht für IPv6 ausgelegt ist und auch hardcodiert noch 127.0.0.1 beinhaltet. Überraschenderweise hat diese funktioniert. Anschließend habe ich auch ping 127.0.0.1 getestet und auch das hat funktioniert. Wie kann das sein, obwohl IPv4 vollständig deaktiviert wurde?

Kann mir hier jemand helfen?

Danke!

meteora28
Mitglied: KowaKowalski
18.03.2011 um 10:05 Uhr
Hi meteora,


macht Win7 da eventuell einfach ne ::1 drauß?



jewunken
kowa
Bitte warten ..
Mitglied: meteora28
18.03.2011 um 10:09 Uhr
Überraschenderweise nicht.
Wenn ich ping localhost oder ping ::1 aufrufe, dann antwortet mir ::1.
Wenn ich jedoch ping 127.0.0.1 aufrufe, dann antwortet mir 127.0.0.1.
Bitte warten ..
Mitglied: rana-mp
18.03.2011 um 12:00 Uhr
Was steht denn in deiner hosts datei?
Bei mir (sowohl IPv4 als auch IPv6 aktiv) stehen sowohl 127.0.0.1 als auch ::1 als localhost drin.
Wenn du IPv4 nicht nutzt kannst du die Zeile mit 127.0.0.1 normalerweise entfernen.


Gruss,

rana-mp
Bitte warten ..
Mitglied: meteora28
18.03.2011 um 12:16 Uhr
In meiner hosts Datei steht folgendes:

"# 127.0.0.1 localhost"
"# ::1 localhost"

Wie man sehen kann, auskommentiert. Das hilft vermutlich nicht weiter.

Vielleicht kann irgendjemand diese Sache rekonstruieren und verifizieren indem man IPv4 kurz abschaltet und dann versucht 127.0.0.1 anzupingen?

Ich kann es mir nachwievor nicht erklären.
Bitte warten ..
Mitglied: Pjordorf
18.03.2011 um 13:17 Uhr
Hallo,

Zitat von meteora28:
Vielleicht kann irgendjemand diese Sache rekonstruieren und verifizieren indem man IPv4 kurz abschaltet
Wie genau hast du denn dein IPv4 deaktiviert. Ein abschalten ist nicht gleich deaktiviert oder deinstalliert.

Gruß,
Peter
Bitte warten ..
Mitglied: meteora28
18.03.2011 um 13:26 Uhr
Ich habe bei meinem NetzwerkController unter "Systemsteuerung\Netzwerk und Internet\Netzwerkverbindungen" -> Eigenschaften -> IPv4 den Haken entfernt und dies somit deaktiviert.
Es funktioniert keine weitere Verbindung via IPv4, ausser 127.0.0.1.
Bitte warten ..
Mitglied: GuentherH
18.03.2011 um 17:03 Uhr
Hallo.

IPv4 den Haken entfernt und dies somit deaktiviert

Damit hast du IPv4 mit Sicherheit nicht deaktiviert, sondern nur die Bindung von der Netzwerkkarte entfernt.

Um z.B. IPv6 zu deaktivieren, ist ein Eingriff in die Registry notwendig - siehe hier - http://support.microsoft.com/kb/952842

Ob man IPv4 überhaupt deaktivieren kann, wage ich zu bezweifeln, aber auf keinen Fall nur dadurch, dass du die Bindung von der Netzwerkkarte entfernst.

LG Günther
Bitte warten ..
Mitglied: meteora28
21.03.2011 um 08:27 Uhr
Vielen Dank für Eure Antworten.

Warum dies nun genau so ist, werde ich im nächsten Schritt bei Microsoft selbst anfragen. Wenn es eine Antwort gibt, werde ich sie natürlich hier veröffentlichen.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Update
Windows Update-Suche nach Win7 Neuinstallation wieder schneller (2)

Erfahrungsbericht von the-buccaneer zum Thema Windows Update ...

Windows Server
Windows Server 2012 R2 - Rechtevergabe gestört bei Netzlaufwerken (2)

Frage von Intruder0001 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...