Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

1GBit Nic mit Ubuntu

Frage Linux Ubuntu

Mitglied: ottscho

ottscho (Level 2) - Jetzt verbinden

03.11.2008, aktualisiert 04.11.2008, 4264 Aufrufe, 5 Kommentare

Hallo zusammen,

vor mir steht ein neuer HP dx2400 Desktop PC mit welchem ich gerne in unser Netzwerk (DHCP) möchte.
Dieser Rechner hat eine onBoard Realtek 1GBit Netzwerkakrte.
Ich habe es nun auf jede erdenkliche Art versucht:
Roaming-Modus, DHCP, Manuell und mit Ubuntnu 7.10, 8.04 und Knoppix. Leider ohne Erfolg. Unter WindowsXP funktioniert die Karte einwandfrei.

Nun habe ich gelesen, dass eine 1GBit Karte unter Linux auch eine 1Gbit Leitung erwartet. Ichj hänge aber nur mir 100MBit am Switch.

Ich habe folgendes Versucht, aber leider ohne Erfolg:

Re: On Board Realtek GBit only running at 1Gbit
Sounds like you need to make sure autoneg is enabled, to do this:

Code:

sudo ethtool --change eth0 autoneg on

Then do the following:

Code:

sudo ifdown eth0 && sudo ifup eth0

This should force the interface to auto duplex speed (should pickup 100MB/Full) and then force the interface down and back up to pickup DHCP
Ich hoffe ihr könnt mir weiterhelfen.

Gruß ottscho
Mitglied: aqui
03.11.2008 um 14:59 Uhr
Eigntlich ist das Autonegotiation Verhalten vollkommen unabhängig vom Treiber und es vollkommen egal ob due 100 oder 1000 Mbit machst mit der Karte und das dürfte nicht das Problem sein.
Wird die Karte denn grundsätzlich unter Ubuntu erkannt ??
Die Realtek Seite hat sonst alle Treiber da für Linux:

http://www.realtek.com.tw/downloads/

Dazu musst du den Chipset aber kennen.
Ggf. solltest du nochmal eine aktuellere Distro booten wie Opensuse die ggf. aktuellere Treiber haben:

http://de.opensuse.org/Willkommen_auf_openSUSE.org
Bitte warten ..
Mitglied: Alphavil
03.11.2008 um 15:14 Uhr
Versuchs mal mit Ubuntu 8.10 damit müsste es gehn.

Ich hatte einen ähnlichen Fall, nur umgekehrt 'g. Unter Linux lief die Onboard-Nic ohne Probleme, unter Windows wurde sie nicht mal gefunden
Bitte warten ..
Mitglied: ottscho
03.11.2008 um 16:09 Uhr
danke für die Antworten.
Also ich habe es mit Ubutnu 7.10 und Ubuntu 8.04 und dem ganz neuen Knoppix versucht. Die Karte wird 100% richtig erkannt. In dmesg, lspci etc. ist nichts außergewöhnliches zu finden. Ubuntu 8.10 möchte ich nicht installieren, ist mir zu NEU fürs Geschäft hier...
Bitte warten ..
Mitglied: Alphavil
04.11.2008 um 12:49 Uhr
Ubuntu 8.10
möchte ich nicht installieren, ist mir zu NEU fürs
Geschäft hier...

Verständlich, ich bin da auch immer etwas vorsichtig. Aber ich muss sagen ich habe gestern von 8.04 auf 8.10 geupdated und es läuft alles einwandfrei. Nur beim VMWare-Server musste ich noch einen kleinen Patch einspielen das er wieder lief
Bitte warten ..
Mitglied: ottscho
04.11.2008 um 12:52 Uhr
danke für die AW.
Ich habe hier leider 10 Rechner die noch auf 7.10 optimal laufen. Da ich alle auf einem Stand haben will, müsste ich die alle Updaten.

Ich habe nun eine zusätzliche Nic eingebaut. Die funktioniert. Ist zwar ärgerlich, aber die beste Lösung bis jetzt.

Aber sollte jmd noch eine Idee haben, nur her damit ;)
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...