Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

2 Excel Dateien jeweils 1 Spalte vergleichen

Frage Microsoft Microsoft Office

Mitglied: El-Larso

El-Larso (Level 1) - Jetzt verbinden

24.07.2009, aktualisiert 13:44 Uhr, 9235 Aufrufe, 2 Kommentare

Jeweils 1 Spalte mit Namen aus 2 Excel Dateien sollen verglichen werden

Guten Tag,

ich habe 2 Excel Dateien.
In beiden Dateien gibt es eine Spalte mit Namen (Nachname, Vorname).
Nun möchte ich beide Spalten vergleichen und eine Übereinstimmung farbig markieren (bedingte formatierung).
Wie kann ich die aber vergleichen?

01.
=WENN(B:B='[2._exceldatei.xls]Tabelle2'!$C:$C;"Wahr";"Falsch")
Funktioniert so natürlich nicht.
Da hier ja jetzt die Bedinung ist, das in der gesammten Spalte das gleiche stehen muss.

Gruß
Lars
Mitglied: bastla
24.07.2009 um 15:13 Uhr
Hallo El-Larso!

Lässt sich mit Bedingter Fomatierung (zumindest bis Excel2003, 2007 noch nicht getestet) nicht lösen, da die Bedingung keinen Bezug auf eine andere Tabelle / Datei enthalten darf - Workaround:

  • Erstelle eine Hilfsspalte (im Beispiel Spalte E) mit folgender Formel (für E1):
=ZÄHLENWENN([2._exceldatei.xls]Tabelle1!$C:$C;B2)
  • Lege folgende Bedingte Formatierung für die Spalte B als Formel fest:
=E1>0
Du kannst sogar unterscheiden, ob der Name ein- oder mehrmals in der anderen Datei vorkommt, indem Du zwei Bedingte Formatierungen verwendest und als Bedingungen
=E1=1
und
=E1>1
einsetzt.

  • Für die Optik kannst Du die Hilfsspalte noch ausblenden.

Grüße
bastla
Bitte warten ..
Mitglied: El-Larso
24.07.2009 um 15:40 Uhr
Hi,

Super!
Vielen Dank.
Man... es kann so einfach sein... manchmal hängt man wie ein Ochs vorm Berg.

Gruß
Lars
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Auslesen und Vergleichen Zweiter CSV Dateien Powershell (7)

Frage von Hainoon zum Thema Batch & Shell ...

Microsoft Office
gelöst Excel: 2 Spalten zu einer transformieren und Namen definieren (3)

Frage von Kalisser zum Thema Microsoft Office ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Infineon TPMs unsicher!

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Firewall

PfSense Repository für Version 2.3.x

(3)

Information von Dobby zum Thema Firewall ...

LAN, WAN, Wireless

WPA-2 hat erste Risse: KRACK

(6)

Information von the-buccaneer zum Thema LAN, WAN, Wireless ...

Hardware

GPD Pocket: Winziger Laptop für Wenig Tipper

(1)

Information von pelzfrucht zum Thema Hardware ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (20)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...