Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

2 Excel Dateien jeweils 1 Spalte vergleichen

Frage Microsoft Microsoft Office

Mitglied: El-Larso

El-Larso (Level 1) - Jetzt verbinden

24.07.2009, aktualisiert 13:44 Uhr, 9174 Aufrufe, 2 Kommentare

Jeweils 1 Spalte mit Namen aus 2 Excel Dateien sollen verglichen werden

Guten Tag,

ich habe 2 Excel Dateien.
In beiden Dateien gibt es eine Spalte mit Namen (Nachname, Vorname).
Nun möchte ich beide Spalten vergleichen und eine Übereinstimmung farbig markieren (bedingte formatierung).
Wie kann ich die aber vergleichen?

01.
=WENN(B:B='[2._exceldatei.xls]Tabelle2'!$C:$C;"Wahr";"Falsch")
Funktioniert so natürlich nicht.
Da hier ja jetzt die Bedinung ist, das in der gesammten Spalte das gleiche stehen muss.

Gruß
Lars
Mitglied: bastla
24.07.2009 um 15:13 Uhr
Hallo El-Larso!

Lässt sich mit Bedingter Fomatierung (zumindest bis Excel2003, 2007 noch nicht getestet) nicht lösen, da die Bedingung keinen Bezug auf eine andere Tabelle / Datei enthalten darf - Workaround:

  • Erstelle eine Hilfsspalte (im Beispiel Spalte E) mit folgender Formel (für E1):
=ZÄHLENWENN([2._exceldatei.xls]Tabelle1!$C:$C;B2)
  • Lege folgende Bedingte Formatierung für die Spalte B als Formel fest:
=E1>0
Du kannst sogar unterscheiden, ob der Name ein- oder mehrmals in der anderen Datei vorkommt, indem Du zwei Bedingte Formatierungen verwendest und als Bedingungen
=E1=1
und
=E1>1
einsetzt.

  • Für die Optik kannst Du die Hilfsspalte noch ausblenden.

Grüße
bastla
Bitte warten ..
Mitglied: El-Larso
24.07.2009 um 15:40 Uhr
Hi,

Super!
Vielen Dank.
Man... es kann so einfach sein... manchmal hängt man wie ein Ochs vorm Berg.

Gruß
Lars
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
VB for Applications
VBA Excel Dateien zusammenfassen (3)

Frage von cberndt zum Thema VB for Applications ...

Microsoft Office
Mehr als 20 Excel Dateien öffnen gleichzeitig (7)

Frage von PizzaPepperoni zum Thema Microsoft Office ...

Microsoft Office
Excel Dateien durchsuchen und Werte einzeln in neue Excel Datei auslesen (1)

Frage von krischanii zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (13)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...