Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Eine von 2 gleichen Netzwerkkarte deaktivieren per console

Frage Microsoft Windows Netzwerk

Mitglied: aldasoriginal

aldasoriginal (Level 1) - Jetzt verbinden

11.01.2011, aktualisiert 13:40 Uhr, 6018 Aufrufe, 10 Kommentare

Hallo Leute,
und zwar habe ich eine frage. wie kann man per console eine netzwerkkarte deaktivieren?
Ich habe windows xp mit sp3.
hab das mit devcon jetzt ausprobiert, das problem ist aber, dass 2 gleiche netzwerkkarten verbaut sind. gebe ich nun in die konsole "devcon disable *dev_1600" ein, werden beide Netzwerkkarten deaktiviert.
Könnt ihr mir da irgendwie weiterhelfen? mir fehlt der ansatz zum weitermachen
danke im vorraus

gruß alex
Mitglied: Friemler
11.01.2011 um 13:57 Uhr
Hallo aldasoriginal,

Du musst DEVCON nur exaktere Angaben liefern, welche NIC deaktiviert werden soll. Die genaue Hardware-ID Geräteinstanzkennung kannst Du über den Gerätemanager erfahren, im Dialogfeld "Eigenschaften" der Netzwerkkarte, Karteikarte "Details", Eigenschaft "Hardware-IDs" "Geräteinstanzkennung". Korrekt wäre dann die folgende Syntax:
devcon disable "@Hardware-ID"
[EDIT]
Berichtigung:
devcon disable "@Geräteinstanzkennung"
[/EDIT]


Oder Du nimmst NETSH (in Windows enthalten):
netsh interface set interface name="LAN-Verbindung2" admin=DISABLE
[EDIT]
Berichtigung:
netsh interface set interface name="LAN-Verbindung2" admin=DISABLED
[/EDIT]

Statt LAN-Verbindung2 musst Du den tatsächlichen Namen der Netzwerkverbindung, so wie er im "Ordner" Netzwerkverbindungen angezeigt wird, eintragen. Falls sich der Name aber mal aus irgendwelchen Gründen ändert (übereifrige Benutzer...), funktioniert das nicht mehr, deshalb ist DEVCON der sicherere Weg.

Gruß
Friemler
Bitte warten ..
Mitglied: aldasoriginal
11.01.2011 um 14:09 Uhr
erstmal danke für die schnelle hilfe.
wenn ich bei den hardware eigenschaften guck, hab ich mir jetzt mal den Punkt Hardwarekennung angeguckt (Hardware-IDs gibt da nicht), da steht dann zeichen für zeichen das gleiche.
bei: netsh interface set interface name="InternesLAN" admin=DISABLE
kommt die Meldung: Mindestens ein erforderlicher Parameter wurde nicht angegeben. ungültige Syntax. Bei meinem Kollegen (hat windows 7) geht das einwandfrei....
any ideas?
Bitte warten ..
Mitglied: vossi31
11.01.2011 um 14:28 Uhr
Hallo aldasoriginal,

ich kenne nur diese Variante: "netsh interface set interface InternesLAN disabled"

Gruß
Bitte warten ..
Mitglied: aldasoriginal
11.01.2011 um 14:51 Uhr
neuer versuch,
selbes resultat: alles noch aktiviert...
(aber danke^^)
Bitte warten ..
Mitglied: Friemler
11.01.2011 um 15:50 Uhr
Hallo aldasoriginal,

ich muss mehrfach um Entschuldigung bitten, die korrekte Syntax für NETSH wäre
netsh interface set interface name="InternesLAN" admin=DISABLED
Man beachte das letzte D bei DISABLED. Das funktioniert unter XP jedoch nur für WAN-Interfaces.

Für den DEVCON-Aufruf brauchst Du die Geräteinstanzkennung (Name unter XP Prof. SP3 32Bit auf meinem Zweitrechner verifiziert), auch über den oben beschriebenen Weg zu erfahren.

Übrigens habe ich zum Testen tatsächlich ein Windows 7 Ultimate 32Bit benutzt...

Gruß
Friemler
Bitte warten ..
Mitglied: aldasoriginal
11.01.2011 um 16:08 Uhr
also bei dem netsh-befehl bekomm ich immer die meldung mit dem fehlendem parameter, bzw. falscher syntax....
bei der geräteinstanzkennung sind sich die beiden ziemlich ähnlich:
1. Netzwerkkarte: PCI\VEN_1022&DEV_2000&SUBSYS20001022&REV_10\4&47B7341&0&0088
2. Netzwerkkarte: PCI\VEN_1022&DEV_2000&SUBSYS20001022&REV_10\4&47B7341&0&0888
mit devcon habe ich die gertät mit DEV_2000 deaktivieren können, aber halt nur beide....
Bitte warten ..
Mitglied: Friemler
11.01.2011 um 16:23 Uhr
Hallo aldasoriginal!

Bzgl. NETSH:
Geht unter XP nur für WAN-Interfaces. Musste mein letztes Posting nochmal korrigieren . WinXP und Win7 sind doch ein bisschen verschieden, auch auf dieser Ebene.

Bzgl. DEVCON:
Hast Du denn wirklich
devcon disable "@PCI\VEN_1022&DEV_2000&SUBSYS20001022&REV_10\4&47B7341&0&0888"
probiert? Wenn ja, weiß ich auch nicht mehr weiter.

Gruß
Friemler
Bitte warten ..
Mitglied: aldasoriginal
11.01.2011 um 16:28 Uhr
funkitoniert.....
besten danke
Bitte warten ..
Mitglied: Friemler
11.01.2011 um 16:35 Uhr
Und wo bleibt der grüne Haken?
Bitte warten ..
Mitglied: aldasoriginal
11.01.2011 um 16:36 Uhr
jetzt^^ danke nochmal (war kurz vor der verzweiflung)
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
Switche und Hubs
gelöst Cisco Console Cable - USB auf RJ45 (16)

Frage von huggybear zum Thema Switche und Hubs ...

Windows Tools
Netzwerkkarte pro Software bestimmen (19)

Frage von SirTobi27 zum Thema Windows Tools ...

Windows 7
W7 WSUS Console keine Verbindung zum Server herstellbar (14)

Frage von XPFanUwe zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...