Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

2 Makrofenster - welches davon kann ich löschen?

Frage Entwicklung Basic

Mitglied: imebro

imebro (Level 2) - Jetzt verbinden

19.02.2015, aktualisiert 08:01 Uhr, 1160 Aufrufe, 7 Kommentare

Hallo,

ich habe vor kurzem mit Eurer Hilfe ein Makro erstellt, welches den Druckvorgang für mehrere Kollegen erleichtert.
Hierbei wird automatisch eine Grafik mit der Unterschrift der Kollegen in ein Word-Dokument eingesetzt.

Nun passiert es bei einem speziellen Kollegen immer wieder, dass dieses Makro plötzlich nicht mehr funktioniert.
Bei diesem Kollegen hatte ich auch damals schon das Problem, dass bei ihm 2 verschiedene Makrofenster auftauchten.

Eines nennt sich "Normal - NewMacros (Code)" und das andere nennt sich "Normal - NewMacros1 (Code)".

Ich habe dann hin und her probiert und gedacht, ich könnte einfach alle Makros in eines der beiden Fenster kopieren und das andere löschen.
Aber das hatte damals nicht funktioniert. Ich hatte mich dann dazu entschlossen, beide Fenster zu belassen und habe in beide die gleichen Makros hinein kopiert.
Das funktioniert ja grundsätzlich auch.

Nun hat der Kollege aber mit dem Makro-Recorder ein neues Makro erstellt mit dem Namen "Seite_2".
Wie gesagt, ist es immer mal wieder plötzlich so, dass er das von mir erstellte Makro mit der autom. Unterschrift nicht mehr ausführen kann.

Meine Idee war nun, dass es mit seinem selbst erstellten Makro zusammenhängen könnte, welches nur im Fenster "Normal - NewMacros (Code)"
läuft. Ich habe dieses Makro nun auch in das andere Fenster "Normal - NewMacros1 (Code)" kopiert um zu sehen, ob der Fehler erneut auftaucht.

Meine Frage ist aber nun, wie verhält sich das mit den beiden Makro-Fenstern?
Wieso sind da überhaupt 2 verschiedene Makro-Ablageplätze entstanden?
Und... was wäre Eurer Tipp, dass alle Makros sicher funktionieren, ohne dass ich sie 2 x abspeichern muss?

Hier mal ein Screenshot:
6d987f0bc53633864623318f13dcf956 - Klicke auf das Bild, um es zu vergrößern

Danke und schöne Grüße,
imebro
Mitglied: 114757
19.02.2015, aktualisiert um 08:08 Uhr
Oh mönsch, das wurde die hier doch schon lang und breit erklärt und dir auch eine Lösung dafür aufgezeigt!!
http://www.administrator.de/frage/makro-wurde-nicht-gefunden-deaktivier ...
Aber anscheinend bist du beratungsrestistent ;-P

Gruß jodel32
Bitte warten ..
Mitglied: imebro
19.02.2015 um 08:33 Uhr
Danke Dir "jodel32"

Beratungsresistent stimmt so zwar nicht, aber in dem anderen Thread ging es ja hauptsächlich noch um das eigentliche Makro.
Alles funktioniert ja einwandfrei und bei den anderen Kollegen ja auch zu jeder Zeit!!

Im jetzigen Fall habe ich einfach nur die Frage, wieso ich (nur bei einem Kollegen) 2 Ablageplätze für Makros habe und wodurch das passiert?

Am Ende möchte ich einfach nur EINEN Ablageplatz erhalten, der einfach ALLE Makros enthält.
Was muss ich dafür tun?

Verstehe da einfach nicht den Zusammenhang.

Danke und Gruss,
imebro
Bitte warten ..
Mitglied: 114757
19.02.2015, aktualisiert um 09:14 Uhr
Im jetzigen Fall habe ich einfach nur die Frage, wieso ich (nur bei einem Kollegen) 2 Ablageplätze für Makros habe und wodurch das passiert?
Das sind Module, und davon kannst du so viel anlegen wie du willst.
Die siehst du in der linken Baumansicht. Je nachdem was für Addins und Vorlagen bei dem Kollegen eingebunden sind können da halt auch mehrere Module vorhanden sein. Da jedes Dokument bzw. Vorlage seine eigenen Module beinhalten kann! Aber das haben wir dir auch schon in o. verlinkten Beitrag geschrieben.
Wichtig ist nur das dein Makro-Button auf das richtige Makro in seinem Modul zeigt. Ob du dein Makro nun in ein anderes Modul packst ist egal, nur muss halt dein Makro-Referenz des Buttons auf das richtige Makro zeigen.
Das ist alles.
Bitte warten ..
Mitglied: imebro
19.02.2015 um 09:16 Uhr
OK...

Aber alle Kollegen benutzen die gleichen Word-Vorlagen (.dot).
Bei den anderen Kollegen gibt es dieses Problem ja nicht, dass plötzlich das Makro, welches die Grafik einfügt, nicht mehr funktioniert.
Und... der Makro-Button muss ja auf das richtige Makro zeigen, denn grds. funktioniert ja alles... nur halt irgendwann plötzlich dann nicht mehr

LG
imebro
Bitte warten ..
Mitglied: 114757
19.02.2015, aktualisiert um 09:29 Uhr
nur halt irgendwann plötzlich dann nicht mehr
geile Fehlermeldung ... und du meinst das hilft uns hier weiter ?
Erstell das Userprofil des Users neu und alles wird gut.

-edit- und checke ob die Normal.dot des Users durch eine andere ersetzt wird. Ich hoffe nicht das ihr die Normal.dot irgendwo im Netz mit anderen Usern shared ?
Bitte warten ..
Mitglied: imebro
19.02.2015, aktualisiert um 11:53 Uhr
Zitat von 114757:

> nur halt irgendwann plötzlich dann nicht mehr
geile Fehlermeldung ... und du meinst das hilft uns hier weiter ?

Naja... wenn ich es besser erklären könnte, müßte ich hier nicht fragen

Genau so ist es nämlich.
Der Kollege schreibt vielleicht 5 Word-Dokumente und beim 6. kann er plötzlich die Grafik nicht mehr einfügen.
Habe ihn jetzt darum gebeten, mal darauf zu achten, ob er dann vorher sein selbst erstelltes Makro genutzt hat...

Jeder Kollege nutzt seine eigene "normal.dot".

--> Bezüglich Deines vorherigen Posts nochmal:
Könnte ich mal versuchen, eines der beiden Fenster (Module) zu löschen, nachdem ich alle erstellten Makros in einem untergebracht habe?
Wenn ja... welches soll ich erhalten? Das "Normal - NewMacros (Code)" oder das "Normal - NewMacros1 (Code)"?

Danke und Gruss,
imebro
Bitte warten ..
Mitglied: 114757
19.02.2015 um 13:26 Uhr
Wenn ja... welches soll ich erhalten? Das "Normal - NewMacros (Code)" oder das "Normal - NewMacros1 (Code)"?
Egal, Hauptsache du überprüfst hinterher die Makroverknüpfungen auf den Buttons bzw. korrigierst diese bei Bedarf.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Microsoft Office
Microsoftaccount löschen (1)

Frage von Kroni99 zum Thema Microsoft Office ...

Exchange Server
Exchange 2010 Akzeptierte Domäne löschen (4)

Frage von Rob1982 zum Thema Exchange Server ...

Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...